summaryrefslogtreecommitdiff
path: root/app-dicts/myspell-nl/myspell-nl-2.10g.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-09-13 17:49:31 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-09-13 17:49:31 +0100
commit36ac65103bf5503e5bad1ecc7e8cb9e7643f6840 (patch)
treed9d1fbc20509d4c90f57fb2d9e1459bc8034c831 /app-dicts/myspell-nl/myspell-nl-2.10g.ebuild
parenta1392efe64137262023d92492396ca9156d22396 (diff)
Revert "gentoo resync : 13.09.2019"
This reverts commit a1392efe64137262023d92492396ca9156d22396.
Diffstat (limited to 'app-dicts/myspell-nl/myspell-nl-2.10g.ebuild')
-rw-r--r--app-dicts/myspell-nl/myspell-nl-2.10g.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/app-dicts/myspell-nl/myspell-nl-2.10g.ebuild b/app-dicts/myspell-nl/myspell-nl-2.10g.ebuild
new file mode 100644
index 000000000000..56b4625bc85c
--- /dev/null
+++ b/app-dicts/myspell-nl/myspell-nl-2.10g.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+MYSPELL_DICT=(
+ "nl_NL.aff"
+ "nl_NL.dic"
+)
+
+MYSPELL_HYPH=(
+ "hyph_nl_NL.dic"
+)
+
+MYSPELL_THES=(
+ "th_nl_NL_v2.dat"
+ "th_nl_NL_v2.idx"
+)
+
+inherit myspell-r2
+
+DESCRIPTION="Dutch dictionaries for myspell/hunspell"
+HOMEPAGE="https://www.opentaal.org"
+# Thesarus is not versioned at all, I suppose we could bump it with each dict
+# release, or when people say that the download uri checksum changed.
+SRC_URI="
+ https://www.opentaal.org/bestanden/license_result/20-woordenlijst-v-${PV//./}-voor-openofficeorg-3?bid=20&agree=1 -> ${P}.oxt
+ https://data.opentaal.org/opentaalbank/thesaurus/download/thes_nl.oxt -> ${P}_thes.oxt
+"
+
+LICENSE="BSD-2 CC-BY-3.0"
+SLOT="0"
+KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ~mips ppc ppc64 ~sh sparc x86 ~amd64-fbsd ~x86-fbsd"
+IUSE=""
+
+src_prepare() {
+ default
+ # thesarus has ugly name
+ mv th_nl_v2.dat th_nl_NL_v2.dat || die
+ mv th_nl_v2.idx th_nl_NL_v2.idx || die
+
+ # remove dutch translated license so it aint installed
+ rm -rf licentie* || die
+}