summaryrefslogtreecommitdiff
path: root/app-dicts/myspell-gl
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-06-15 14:57:03 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-06-15 14:57:03 +0100
commitd18bf1e01b65ee4bf0c804e2843b282d3d4e5d7c (patch)
tree4a95cbc6ffdf13bad6ecbc7f8d5af99631984123 /app-dicts/myspell-gl
parente748ba9741f6540f4675c23e3e37b73e822c13a4 (diff)
gentoo resync : 15.06.2021
Diffstat (limited to 'app-dicts/myspell-gl')
-rw-r--r--app-dicts/myspell-gl/Manifest2
-rw-r--r--app-dicts/myspell-gl/myspell-gl-20180710.ebuild40
2 files changed, 42 insertions, 0 deletions
diff --git a/app-dicts/myspell-gl/Manifest b/app-dicts/myspell-gl/Manifest
index b0b241aa9373..2bcef8308d19 100644
--- a/app-dicts/myspell-gl/Manifest
+++ b/app-dicts/myspell-gl/Manifest
@@ -1,3 +1,5 @@
DIST myspell-gl-20131013.oxt 771221 BLAKE2B cee0815ae69d00334cca4341ed5c694c3d8f97a3904f5427b7deb94d706947e536adc890b2bfbff41c666b8ae6c5c277edc4843f4c4ef4131548145a42b2313d SHA512 ae13d7137e6b8e51570bcbeba00f73d9887a24556c2409249a39858d385168a03aff3ec2cf3222cad50686a4169debbe310a05ce3bd40aaab408de3ed01885ee
+DIST myspell-gl-20180710.oxt 1929371 BLAKE2B f5ffbcd9417935828db5e951b1b37deb6a72c22f19afd48cc9e03f167bbc3285b3ae3141c2393aeff50be48752cd8620167e2539f6d2eb28f29c72ca56f88c84 SHA512 ea19a917a3f4a7d6a144a9219e30f1a8cdd4865c98c1a3f901dd2ffb8a20143c2e80c4b458ea71ce97684042a4209852c9d21861710c52658fa7391eb221c7a4
EBUILD myspell-gl-20131013.ebuild 626 BLAKE2B 9403306a980fccc68afceed4bebb28e3f235070da12dfb58f20a02f1961cc43fb20b21498296248a55511de42e0418c46c3919263a651e17eb605a2ab4e76bd6 SHA512 ccc0c641894fa5ffe7a680547df9595df7637270c18ec873284d459cff4b9394347d8ae1260ffd7fedbadc21f0509424107c415f1b52a8fd7842d8ee7e9fedff
+EBUILD myspell-gl-20180710.ebuild 989 BLAKE2B 95f375f713287f3d6a5d3475a0529a1f395b3a98fa90c72d978ae5bd0d79cca7dec6e8c82f4dde7b1f91543eaec1c63437e96e6fefb65670f3ae47ade3e2f437 SHA512 a4636307e6d631ea37452813354618bc7feb2434c88bc46214eaecc67fcb402b208793eef88ffcf066ee911bce4ebdaab19ebc15d1ee2bff15e35b7f2b44d14e
MISC metadata.xml 191 BLAKE2B 8bff04ca02f4930d6f77dd32df009c145cacaad2d1cf271d91ae928f85acdccb0d73b0202a41aa3e60470ba6c7853e41ef76587601b2163f9ec249b7fa1c5274 SHA512 da06af54ba93db06f717082e3f09bbca9e17adad4b070a28131f2ffec15d0dfc82c79a3b2fb045fa33d6756c6df85254733622b0b7b1952b33d5590a71865c62
diff --git a/app-dicts/myspell-gl/myspell-gl-20180710.ebuild b/app-dicts/myspell-gl/myspell-gl-20180710.ebuild
new file mode 100644
index 000000000000..1d5e545c3378
--- /dev/null
+++ b/app-dicts/myspell-gl/myspell-gl-20180710.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MYSPELL_DICT=(
+ "gl_ES.aff"
+ "gl_ES.dic"
+)
+
+MYSPELL_HYPH=(
+ "hyph_gl_ES.dic"
+)
+
+MYSPELL_THES=(
+ "thes_gl_ES.dat"
+ "thes_gl_ES.idx"
+)
+
+inherit myspell-r2
+
+DESCRIPTION="Galician dictionaries for myspell/hunspell"
+LICENSE="GPL-2 LGPL-2.1"
+HOMEPAGE="https://extensions.libreoffice.org/en/extensions/show/corrector-ortografico-para-galego"
+SRC_URI="https://extensions.libreoffice.org/assets/downloads/z/corrector-18-07-para-galego.oxt -> ${P}.oxt"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+DOCS=( changelog.txt package-description.txt readme.txt readme-gl.txt readme_hyph-gl.txt readme_th_gl.txt )
+
+src_prepare() {
+ default
+ # Naming correctly
+ mv gl.aff gl_ES.aff || die
+ mv gl.dic gl_ES.dic || die
+ mv hyph_gl.dic hyph_gl_ES.dic || die
+ mv thesaurus_gl.dat thes_gl_ES.dat || die
+ mv thesaurus_gl.idx thes_gl_ES.idx || die
+}