summaryrefslogtreecommitdiff
path: root/app-dicts/myspell-en
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-07-09 15:43:36 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-07-09 15:43:36 +0100
commit2719f73b6813d11d13a9650cdd2ab8ec6e69385d (patch)
tree8c816148bcbd22757d892089c989ae614eae4f5a /app-dicts/myspell-en
parent0f558761aa2dee1017b4751e4017205e015a9560 (diff)
gentoo resync : 09.07.2022
Diffstat (limited to 'app-dicts/myspell-en')
-rw-r--r--app-dicts/myspell-en/Manifest2
-rw-r--r--app-dicts/myspell-en/myspell-en-20220701.ebuild53
2 files changed, 55 insertions, 0 deletions
diff --git a/app-dicts/myspell-en/Manifest b/app-dicts/myspell-en/Manifest
index f7daa621dd3a..4958f02361f1 100644
--- a/app-dicts/myspell-en/Manifest
+++ b/app-dicts/myspell-en/Manifest
@@ -1,3 +1,5 @@
DIST dict-en-20210601.oxt 6104083 BLAKE2B 192252e85918d3d47167ff9243f70178bc548de3e93152c4139e64ffb013e147fda1fa9c7741ce7bf74b149ec0ab6e001760990cd1ee33dad06fd5e3813ef591 SHA512 c9d791a12aa97d6c2a0928f9f500b22492208b415f877d6b5bd192b5da4c243c32b8d0b7af6b3f5cbfefe6b1c695626db204fc29a922dc4b083538ed144cb472
+DIST dict-en-20220701_lo.oxt 6124450 BLAKE2B 0fcd479efcbe9cbf6d2e7d479cb070b32bcf62d6ab6154e64c27d155dbc6d9e7521aee4a76e08288b77b583a7f3273f7817694a3b7fe194861ac64b785188ce8 SHA512 3df04d9ff2edf12d1d717a6b95893cf69e394fe2cbdcba77d0c804b37500feeaf42379d743f3c21cb9c8f8ae17ad2eb990806ea3f9fc8af954bd7b89f3253a4d
EBUILD myspell-en-20210601-r2.ebuild 1432 BLAKE2B 433a131aeb2f9beb156d526c98fe2cc03ab9935a125967f2cb222a3743de320126b6f1358b0a20d4bb914b1ebf7aa1b30d17ca5ce3e875886c5beb22c0da6fd3 SHA512 2aec560d10cde9ec95bf148d835c426ec6da2e55aee9d23b7cce5b232ec97f3bcded28917d898266d12c5bd532795d258e9738fb5ff26be41ad7fe84bd4bd333
+EBUILD myspell-en-20220701.ebuild 1453 BLAKE2B eff587f6c9e26102478d1b348a9910a8ce246263f00b2434a824e78f8bd0c1c11c9d29a57b71a47c633fdf555ed72bff25b267459295df9599478e935a072b17 SHA512 57dd06637c1cd77849f96d77ca6c374c1108d58794ac1984ee8d05940ed6a758e382ae0879187c960944ec0f7408cae2f667bce10d13ee3da8764af81c264caf
MISC metadata.xml 422 BLAKE2B 2a08cd9598f852c8ef8a83649d7ac8c8617eb2d5dbe160c5bc21457c412b51ff8fe0c7413238252333e9622e0bc367b9e5b33d5d8051bed9c53a1287296f8385 SHA512 ebc962ac0a2aa0cda987269d52b5dd9607e59aecc73ec265dc6f0b4469827502482dc5c18f5b9122831ed554b852a823c7fb31d58beb5b2a8e14cd16ee12c474
diff --git a/app-dicts/myspell-en/myspell-en-20220701.ebuild b/app-dicts/myspell-en/myspell-en-20220701.ebuild
new file mode 100644
index 000000000000..6f7a8205cd41
--- /dev/null
+++ b/app-dicts/myspell-en/myspell-en-20220701.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit myspell-r2
+
+DESCRIPTION="English dictionaries for myspell/hunspell"
+HOMEPAGE="https://extensions.libreoffice.org/extensions/english-dictionaries"
+SRC_URI="https://extensions.libreoffice.org/assets/downloads/41/1656659156/dict-en-20220701_lo.oxt"
+
+LICENSE="BSD MIT LGPL-3+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~x86-solaris"
+
+PLOCALES=( "en" "en-AU" "en-CA" "en-GB" "en-US" "en-ZA" )
+IUSE+="${PLOCALES[@]/#/l10n_}"
+REQUIRED_USE="|| ( ${IUSE[@]} )"
+
+src_prepare() {
+ if use l10n_en-GB || use l10n_en; then
+ MYSPELL_HYPH+=( "hyph_en_GB.dic" )
+ fi
+ if use l10n_en-US || use l10n_en; then
+ MYSPELL_THES+=(
+ "th_en_US_v2.dat"
+ "th_en_US_v2.idx"
+ )
+ MYSPELL_HYPH+=( "hyph_en_US.dic" )
+ fi
+
+ MYSPELL_DICT=( )
+ for lang in "${PLOCALES[@]}"; do
+ if [[ "${lang}" == "en" ]]; then
+ continue
+ fi
+ local mylinguas="${lang//-/_}"
+ if use "l10n_${lang}" || use l10n_en; then
+ MYSPELL_DICT+=( "${mylinguas}.aff" "${mylinguas}.dic" )
+ else
+ rm "README_${mylinguas}.txt" || die
+ if [[ ${lang} == "en-US" ]]; then
+ rm "README_hyph_en_US.txt" || die
+ fi
+ if [[ ${lang} == "en-GB" ]]; then
+ rm "README_hyph_en_GB.txt" || die
+ rm "README_en_GB_thes.txt" || die
+ fi
+ fi
+ done
+
+ default
+}