summaryrefslogtreecommitdiff
path: root/app-dicts/kasumi/kasumi-2.5-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /app-dicts/kasumi/kasumi-2.5-r1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'app-dicts/kasumi/kasumi-2.5-r1.ebuild')
-rw-r--r--app-dicts/kasumi/kasumi-2.5-r1.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/app-dicts/kasumi/kasumi-2.5-r1.ebuild b/app-dicts/kasumi/kasumi-2.5-r1.ebuild
new file mode 100644
index 000000000000..c0b6a4f5f4a8
--- /dev/null
+++ b/app-dicts/kasumi/kasumi-2.5-r1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+DESCRIPTION="Anthy dictionary maintenance tool"
+HOMEPAGE="http://kasumi.osdn.jp/"
+SRC_URI="mirror://sourceforge.jp/${PN}/41436/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 ppc sparc x86 ~x86-fbsd"
+IUSE="nls"
+
+RDEPEND="app-i18n/anthy
+ virtual/libiconv
+ x11-libs/gtk+:2
+ nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ nls? ( sys-devel/gettext )"
+
+PATCHES=( "${FILESDIR}"/${PN}-desktop.patch )
+
+src_configure() {
+ econf $(use_enable nls)
+}