summaryrefslogtreecommitdiff
path: root/app-dicts/gnome-dictionary
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-12-24 14:11:38 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-12-24 14:11:38 +0000
commitde49812990871e1705b64051c35161d5e6400269 (patch)
tree5e1e8fcb0ff4579dbd22a1bfee28a6b97dc8aaeb /app-dicts/gnome-dictionary
parent536c3711867ec947c1738f2c4b96f22e4863322d (diff)
gentoo resync : 24.12.2018
Diffstat (limited to 'app-dicts/gnome-dictionary')
-rw-r--r--app-dicts/gnome-dictionary/Manifest2
-rw-r--r--app-dicts/gnome-dictionary/gnome-dictionary-3.26.1.ebuild48
2 files changed, 50 insertions, 0 deletions
diff --git a/app-dicts/gnome-dictionary/Manifest b/app-dicts/gnome-dictionary/Manifest
index be4a208e1f57..3b96762c5acf 100644
--- a/app-dicts/gnome-dictionary/Manifest
+++ b/app-dicts/gnome-dictionary/Manifest
@@ -1,3 +1,5 @@
DIST gnome-dictionary-3.24.1.tar.xz 880500 BLAKE2B f730276612d2578e7b25121b49be9639cf7a9fc67bda9687285f6d3873d3b825301246447d968b24ed29240a1b0e7fc48d63c8454e704b799eebdf340f5f6da2 SHA512 b3ee838888a97e914add58dd4b61fa096b9488aab360815f2e7b674e7a57b237849a1ccaf107c1e94968e534b24ee24d827c42a3a1b0dfd8c5ef25eeb90456d3
+DIST gnome-dictionary-3.26.1.tar.xz 662048 BLAKE2B 3b77d3632629f8502476f029ab9ba3c66225cd619992e185b1403adfeba718b7e0fa0f32762eb086c1e9ef80a08cf79cd872e2ca3026b8cb3975954077c5f7c1 SHA512 da7169795740295c13f02143f5263603f0f6c621e96cecf88a4ee089114399d59f083987bc4571821467da64dc43f00bebbe4ea66b46a035088f85d35d6aee27
EBUILD gnome-dictionary-3.24.1.ebuild 1050 BLAKE2B fa0f6f433e2785c838646926ec43398039e61b501eb70323b745ff471f59c2e29b2240ea9dd608f79eda1530e1676b2b454dee92f41e88e6b9b841792fd64144 SHA512 609a5a40b89a226fe75d14c7e9ed939c45a1b499aedaa977e69cdd7d41da318be31d2fc6de01a1d3cd8b89d315d318c94c852e7027f8a2833000787a7b8e51ec
+EBUILD gnome-dictionary-3.26.1.ebuild 1016 BLAKE2B a53d0841a92dd5f15f59eccd783cbeaefa850b46eecc5562181f3acf55a7a6a2bdf328139586685367ed633d0d314fa24645ac8539cee4baccbe2ef714ff2d9b SHA512 e8aa44803a2db6c901346798c053db11e6f19c4c21a19d8161812b532215335b603e3729c8eb027610b69b8cc31c30d0436b13cde2037d73b4ffec258e794935
MISC metadata.xml 316 BLAKE2B 61e50cf64e718dff6380a8840d59f5679e8f084efadcda41cfb45af74177d1121af1db7485fe57690090b0d1deaceaf9d53733fe39447827643c1785b4c68f3d SHA512 c46d3611dc1954a3229a98892c23aa1ebbc74c572dc5562660fce3390cfb74252515ee3a3048418c855c8165a5cea8e5df1fc10c94f81915eac400d7c58850aa
diff --git a/app-dicts/gnome-dictionary/gnome-dictionary-3.26.1.ebuild b/app-dicts/gnome-dictionary/gnome-dictionary-3.26.1.ebuild
new file mode 100644
index 000000000000..d5ced459001d
--- /dev/null
+++ b/app-dicts/gnome-dictionary/gnome-dictionary-3.26.1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit gnome.org gnome2-utils meson xdg
+
+DESCRIPTION="Dictionary utility for GNOME"
+HOMEPAGE="https://wiki.gnome.org/Apps/Dictionary"
+
+LICENSE="GPL-2+ LGPL-2.1+ FDL-1.1+"
+SLOT="0" # does not provide a public libgdict-1.0.so anymore
+IUSE="ipv6"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux"
+
+COMMON_DEPEND="
+ >=dev-libs/glib-2.42:2
+ >=x11-libs/gtk+-3.21.2:3
+"
+RDEPEND="${COMMON_DEPEND}
+ gnome-base/gsettings-desktop-schemas
+"
+DEPEND="${COMMON_DEPEND}
+ app-text/docbook-xsl-stylesheets
+ app-text/docbook-xml-dtd:4.3
+ dev-libs/libxslt
+ dev-util/glib-utils
+ dev-util/itstool
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+src_configure() {
+ local emesonargs=(
+ $(meson_use ipv6 use_ipv6)
+ -Dbuild_man=true
+ )
+ meson_src_configure
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}