summaryrefslogtreecommitdiff
path: root/app-dicts/gnome-dictionary
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
commit40aaaa64e86ba6710bbeb31c4615a6ce80e75e11 (patch)
tree758c221bad35c9288d0bd6df9c7dfc226728e52c /app-dicts/gnome-dictionary
parent8d5dbd847cbc704a6a06405856e94b461011afe3 (diff)
gentoo resync : 28.04.2021
Diffstat (limited to 'app-dicts/gnome-dictionary')
-rw-r--r--app-dicts/gnome-dictionary/Manifest2
-rw-r--r--app-dicts/gnome-dictionary/gnome-dictionary-40.0.ebuild47
2 files changed, 49 insertions, 0 deletions
diff --git a/app-dicts/gnome-dictionary/Manifest b/app-dicts/gnome-dictionary/Manifest
index 62e90c6d5aef..0820e24123fd 100644
--- a/app-dicts/gnome-dictionary/Manifest
+++ b/app-dicts/gnome-dictionary/Manifest
@@ -1,3 +1,5 @@
DIST gnome-dictionary-3.26.1.tar.xz 662048 BLAKE2B 3b77d3632629f8502476f029ab9ba3c66225cd619992e185b1403adfeba718b7e0fa0f32762eb086c1e9ef80a08cf79cd872e2ca3026b8cb3975954077c5f7c1 SHA512 da7169795740295c13f02143f5263603f0f6c621e96cecf88a4ee089114399d59f083987bc4571821467da64dc43f00bebbe4ea66b46a035088f85d35d6aee27
+DIST gnome-dictionary-40.0.tar.xz 603388 BLAKE2B 1fae73ea5b554786f1ee1bf641b0dc94ee8953a045e4a59b72823075b8c0905d0098827ad35f94e26d26fcbdbed1fd2980391ce582871ae6df4d273d9de5add4 SHA512 96e8c5efbba43e1a7d247703ac17cbcb8579cc633f6db74b6fe4431e0b1aed47ab76fd15cc114497b5ee76fb33b57fd9936cc869ffe905f208c836b5a231b126
EBUILD gnome-dictionary-3.26.1.ebuild 1007 BLAKE2B 45d40936058cf017a4dbcd8a25c5185948049d842ea7f6aa53c6f89ec1a617d8107d1c3d6c887b3e1111d7b416cd62e9b4fffdb4157f9a8a86b19741df06a353 SHA512 ed7f62cc3ba6796ca60da8910d842f87a533031cd5ad33bb008de19c71cb275987f32ee19919cd2a5ec82a926a73998f9dbf1a42e414f65f9a33fa2615bbacdf
+EBUILD gnome-dictionary-40.0.ebuild 962 BLAKE2B fca0ffb141bae6b677eab9d2fa336899a5d67005cdb29ba02f41085f0e9b68bb0dba465cd994d0f4ef0e921c499ebc2304c7fd212ee360e8830a9657f1295aa9 SHA512 1f238ad6eb5ee8e29d8eb25227b832966d98154760efcca913d1b3e577524e6f011e18d3af15085d361506d649a54520d42d8ec6ad2a9454b117a0353ad861a7
MISC metadata.xml 316 BLAKE2B 61e50cf64e718dff6380a8840d59f5679e8f084efadcda41cfb45af74177d1121af1db7485fe57690090b0d1deaceaf9d53733fe39447827643c1785b4c68f3d SHA512 c46d3611dc1954a3229a98892c23aa1ebbc74c572dc5562660fce3390cfb74252515ee3a3048418c855c8165a5cea8e5df1fc10c94f81915eac400d7c58850aa
diff --git a/app-dicts/gnome-dictionary/gnome-dictionary-40.0.ebuild b/app-dicts/gnome-dictionary/gnome-dictionary-40.0.ebuild
new file mode 100644
index 000000000000..665d4408cceb
--- /dev/null
+++ b/app-dicts/gnome-dictionary/gnome-dictionary-40.0.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit gnome.org gnome2-utils meson xdg
+
+DESCRIPTION="Dictionary utility for GNOME"
+HOMEPAGE="https://wiki.gnome.org/Apps/Dictionary"
+
+LICENSE="GPL-2+ LGPL-2.1+ FDL-1.1+"
+SLOT="0" # does not provide a public libgdict-1.0.so anymore
+IUSE="ipv6"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+DEPEND="
+ >=dev-libs/glib-2.42:2
+ >=x11-libs/gtk+-3.21.2:3
+"
+RDEPEND="${DEPEND}
+ gnome-base/gsettings-desktop-schemas
+"
+BDEPEND="
+ app-text/docbook-xsl-stylesheets
+ app-text/docbook-xml-dtd:4.3
+ dev-libs/libxslt
+ dev-util/glib-utils
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+src_configure() {
+ local emesonargs=(
+ $(meson_use ipv6 use_ipv6)
+ -Dbuild_man=true
+ )
+ meson_src_configure
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}