summaryrefslogtreecommitdiff
path: root/app-dicts/gnome-dictionary
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-01-16 20:27:28 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-01-16 20:27:28 +0000
commit2fd57282f0262ca084e05b0f2c63fbada395d02b (patch)
tree4e0f23cea9ce9fd972e70ebc5214bf36fed465cc /app-dicts/gnome-dictionary
parentc3bc61051d7f12b4c682efa7a5460bbc8815649e (diff)
gentoo resync : 16.01.2021
Diffstat (limited to 'app-dicts/gnome-dictionary')
-rw-r--r--app-dicts/gnome-dictionary/Manifest1
-rw-r--r--app-dicts/gnome-dictionary/gnome-dictionary-40.0-r1.ebuild51
2 files changed, 52 insertions, 0 deletions
diff --git a/app-dicts/gnome-dictionary/Manifest b/app-dicts/gnome-dictionary/Manifest
index 99e07d055be2..157b856ecb28 100644
--- a/app-dicts/gnome-dictionary/Manifest
+++ b/app-dicts/gnome-dictionary/Manifest
@@ -1,3 +1,4 @@
DIST gnome-dictionary-40.0.tar.xz 603388 BLAKE2B 1fae73ea5b554786f1ee1bf641b0dc94ee8953a045e4a59b72823075b8c0905d0098827ad35f94e26d26fcbdbed1fd2980391ce582871ae6df4d273d9de5add4 SHA512 96e8c5efbba43e1a7d247703ac17cbcb8579cc633f6db74b6fe4431e0b1aed47ab76fd15cc114497b5ee76fb33b57fd9936cc869ffe905f208c836b5a231b126
+EBUILD gnome-dictionary-40.0-r1.ebuild 1140 BLAKE2B 7b285602a73c7b290ab25b991911e4372a65fb84e1c90ecac5d3af628b0b90034a50992b9750fd785db1707f4c5aa8adb40d53fa4e88bf4545ce79549e352a5e SHA512 551d09f658e75bb7c89345ccf1c18cc4b63bed486558ffe76aa3f959a24fd3447d10ae6a0e998bf74ec62ae4576fe6e304841ac22d7409a5a3d8a4c3389f6c2c
EBUILD gnome-dictionary-40.0.ebuild 985 BLAKE2B b027d9bbadabd18a6e7943fd1ea3c92c76d03ad608e361eefa27a3652bf8bb5943fda18033b38163bec37cdf73ca3496262ce8f8c9c56772407bb2c343800e0c SHA512 2d30869962ad3be0d26fb7d221ccdb68e373c38610a0c3297de1c8402665ce33ac60563da8eb688483e4cb5aeea230c21466b0a5013641118851c7a2c50d572f
MISC metadata.xml 317 BLAKE2B 0f99dd59faa31be1761a21290c1d34ed89467c22582727cb88030c0dba83bc7ee9d390f655ab7a63a0b5cb25e8efa2f17b90fbd08c093fece6d4d873018ea201 SHA512 28137d259d69aae3d9ea5161100a0063718bf43c3447ad5d42e75c4ab212288b07f5cbc281e44d648817c2fe7bc05af0a2428a9f9d5f495b2ecefa66f16bda34
diff --git a/app-dicts/gnome-dictionary/gnome-dictionary-40.0-r1.ebuild b/app-dicts/gnome-dictionary/gnome-dictionary-40.0-r1.ebuild
new file mode 100644
index 000000000000..0a2c8fabe1fc
--- /dev/null
+++ b/app-dicts/gnome-dictionary/gnome-dictionary-40.0-r1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit flag-o-matic gnome.org gnome2-utils meson xdg
+
+DESCRIPTION="Dictionary utility for GNOME"
+HOMEPAGE="https://wiki.gnome.org/Apps/Dictionary"
+
+LICENSE="GPL-2+ LGPL-2.1+ FDL-1.1+"
+SLOT="0" # does not provide a public libgdict-1.0.so anymore
+IUSE=""
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+DEPEND="
+ >=dev-libs/glib-2.42:2
+ >=x11-libs/gtk+-3.21.2:3
+"
+RDEPEND="${DEPEND}
+ gnome-base/gsettings-desktop-schemas
+"
+BDEPEND="
+ app-text/docbook-xsl-stylesheets
+ app-text/docbook-xml-dtd:4.3
+ dev-libs/libxslt
+ dev-util/glib-utils
+ dev-util/itstool
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+src_configure() {
+ # Replicate what a release buildtype would set, as we use -Dbuildtype=plain
+ append-cflags -DG_DISABLE_ASSERT -DG_DISABLE_CHECKS -DG_DISABLE_CAST_CHECKS
+
+ local emesonargs=(
+ -Duse_ipv6=true
+ -Dbuild_man=true
+ )
+ meson_src_configure
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}