summaryrefslogtreecommitdiff
path: root/app-crypt
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-09-01 19:24:10 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-09-01 19:24:10 +0100
commitb052fbf151106a4f47cac7fdf0ffff983decb773 (patch)
tree5d21279a4eeaf4076caee87654b610a0fe8a4051 /app-crypt
parentc3b55a6be7da027d97d8aef00ef88c3011121a42 (diff)
gentoo auto-resync : 01:09:2022 - 19:24:10
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/Manifest.gzbin23954 -> 23968 bytes
-rw-r--r--app-crypt/gpa/Manifest2
-rw-r--r--app-crypt/gpa/gpa-0.10.0-r1.ebuild44
-rw-r--r--app-crypt/gpgme/Manifest1
-rw-r--r--app-crypt/gpgme/gpgme-1.18.0-r1.ebuild130
-rw-r--r--app-crypt/kstart/Manifest2
-rw-r--r--app-crypt/kstart/kstart-4.3.ebuild4
-rw-r--r--app-crypt/scute/Manifest1
-rw-r--r--app-crypt/scute/scute-1.7.0-r1.ebuild52
9 files changed, 233 insertions, 3 deletions
diff --git a/app-crypt/Manifest.gz b/app-crypt/Manifest.gz
index 59232419ca8c..f463bdb16383 100644
--- a/app-crypt/Manifest.gz
+++ b/app-crypt/Manifest.gz
Binary files differ
diff --git a/app-crypt/gpa/Manifest b/app-crypt/gpa/Manifest
index 7c5b7bc047ec..1d514fef9aa6 100644
--- a/app-crypt/gpa/Manifest
+++ b/app-crypt/gpa/Manifest
@@ -1,3 +1,5 @@
+DIST gpa-0.10.0-autoconf.patch.xz 8500 BLAKE2B 0b1b99ef0096f4634b60cddf46d3eb6d70da17be1f506265f2642e742e8f7a016e2b340c6722d5976f185b20b1b2ad96661b375fcdd24595d225314bdfc97e56 SHA512 be59117bea8f254238306e6e8ef023f4485bc940387a7a3d4b47dab2962410d6bfb0a540476061beca531504ff5c56d7d8b2416d366810c73359807cdcc42207
DIST gpa-0.10.0.tar.bz2 782455 BLAKE2B ef663432cbe20fb5c543696627f448b3970099b6a0f8f68b57e3d87af03550597adcfe4c27c2774d1f278cfc9d07a089652f42ef4f8c3cbc0192b645c465ac0e SHA512 87004fb0806e76012bc194f95afe9ef6044aec890b26e845f45c314e1bd8864f056ba5e32f9ef2e15b24b50840235e6e548a5e3006b255b4f1c20e0fd7710a3b
+EBUILD gpa-0.10.0-r1.ebuild 976 BLAKE2B c6b4680072a8660232d22d81d97b7b5b5c31793d9f586ad0006be2771334723275388b03738fa6212a2d35a101fb131c9d3a26b667b3d9326355698e470c10a9 SHA512 8212b01aa3cae16eda672ae848a0b64e45db01153e7e1bf7ab374b3675210dea2a566a9be016ea5e02d2202fa98c26b33c4ca8b8bf169bde097cb310b7a4b8af
EBUILD gpa-0.10.0.ebuild 831 BLAKE2B eda7ac1940e4e5319baef416a93d088b20f84adea5e11432a5cdb3839159a056e37f3ce66c84e5c59e1055f606b6912702073cace915c3019ed6104aecfca1c8 SHA512 a2d244cf49742c1f8019fe89cdb3b4fc3fcdbf93db95275a1e436d890b6335a01ccc4e9c656334826f1cf042a8f6309b502b24827f6a6f3dda060e4d24cda43b
MISC metadata.xml 258 BLAKE2B b3ebb9691cf2c860b26172c2fc7ead843959a83806b7c06f4eec2ea349a6d2f39afe2f4b08c09bc7f65d18bece520b8b6306c8c7c2075d653f04b09af43db8fd SHA512 02ab38ca1547c68e87cbcad1dd4bb121e90d1fcca941cbfd29583ea803ed50617aa6a29df11915af5e95d63fc817df2250c7b8189157d705ef86e477d6a1685e
diff --git a/app-crypt/gpa/gpa-0.10.0-r1.ebuild b/app-crypt/gpa/gpa-0.10.0-r1.ebuild
new file mode 100644
index 000000000000..ebce5a63807e
--- /dev/null
+++ b/app-crypt/gpa/gpa-0.10.0-r1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools xdg
+
+DESCRIPTION="The GNU Privacy Assistant (GPA) is a graphical user interface for GnuPG"
+HOMEPAGE="http://gpa.wald.intevation.org"
+SRC_URI="mirror://gnupg/${PN}/${P}.tar.bz2"
+# Backport of upstream changes to 0.10.0
+SRC_URI+=" https://dev.gentoo.org/~sam/distfiles/${CATEGORY}/${PN}/${P}-autoconf.patch.xz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="nls"
+
+RDEPEND="
+ >=app-crypt/gnupg-2:=
+ >=app-crypt/gpgme-1.11.1:=
+ >=dev-libs/libassuan-1.1.0:=
+ >=dev-libs/libgpg-error-1.4:=
+ >=x11-libs/gtk+-2.10.0:2=
+"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig
+ nls? ( sys-devel/gettext )"
+
+PATCHES=(
+ "${WORKDIR}"/${P}-autoconf.patch
+)
+
+src_prepare() {
+ default
+ sed -i 's/Application;//' gpa.desktop
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable nls) \
+ GPGKEYS_LDAP="/usr/libexec/gpgkeys_ldap"
+}
diff --git a/app-crypt/gpgme/Manifest b/app-crypt/gpgme/Manifest
index 9c2d0783f0a6..58f86c4809cf 100644
--- a/app-crypt/gpgme/Manifest
+++ b/app-crypt/gpgme/Manifest
@@ -4,5 +4,6 @@ DIST gpgme-1.17.1.tar.bz2.sig 119 BLAKE2B 31832424c0e029dc520d3302a71b086d9fcb04
DIST gpgme-1.18.0.tar.bz2 1762323 BLAKE2B a071b839eb75455378514f003920cd387320e9fae416e71151cf6ac1b4a058b58ed054450b79e3eeaf820ff5324ea14efa003612867477b7379a776942d62be6 SHA512 c0cb0b337d017793a15dd477a7f5eaef24587fcda3d67676bf746bb342398d04792c51abe3c26ae496e799c769ce667d4196d91d86e8a690d02c6718c8f6b4ac
DIST gpgme-1.18.0.tar.bz2.sig 119 BLAKE2B 968f8b24ec71b4157214dd026aed83c96894ef353a9cb171f268d640a62fe464ba43540f318abf95dcfc19dffab177a0c3ad8a6e9937dc80e4ececbc8ceb3203 SHA512 02958d86cc037fffc787c6611ace8676d4e04cc1f65fd117eb911d3bfd665dddb7849bcd838af598465be78960f54883eac09c29c42f891f2e4b9713095aed7d
EBUILD gpgme-1.17.1-r1.ebuild 3339 BLAKE2B b94b1c3ccbac471ad16c406823460d4ffca1c9428b1420f3b433f224faf2a4a760c23b2923bff5a007cf37c63497d9ed5737683ad9bb4cc97250443bb71e00b6 SHA512 f4479a00ae16770c7180c8465079a4cf0cb92811715f87439e92c591701d1ace2c6af35a2990120723ca4c4091fc673aa61fdbda67d6648891c24905279a0dd5
+EBUILD gpgme-1.18.0-r1.ebuild 3503 BLAKE2B 08e210140e79c270dcc4df020941d02a400c21541a84da283f51e3a2a9a5b490555cef626964561afa59cad55a9ca3a6af98bd5a6b76cec3a5b79b95b3ba6def SHA512 912acb47b31ea975d7821233a2d362aa15a32e44c56e84d584dafa6c1134d57dc3014bbd1cb0eebd94705dd6d3b6c1fe058ac48021f1f16f587b3f1a48e93bc0
EBUILD gpgme-1.18.0.ebuild 3585 BLAKE2B dd453284e0e7d65680de0bcb51013bafc85453924ac322a2928931f1c3967875af8dccc3dd1027fc87f3c004b24ed8e6f3f81ae556419bb0ed267588695beae5 SHA512 aba9378584f4bab17fde88193fe5c9d428ae05d90be96bf46009fe2e857c43af28a0463e1b9c3edb77cf9ad8b739eaffce08925e1a846c304b7e368b75e241dc
MISC metadata.xml 333 BLAKE2B 6dd18b63ec1f7656ab8bd705242bec45d7820db8be31f326172cad400711e6d7268c156d6b81facfdfa79118c04728ac910a8f8de36a11454227a1399235a582 SHA512 21b8d7bf3f14b5ab7e2ea587027395cdd881ecddd5a4f70237cafc70dc904b396a33f70dd7ef37519df5a204f4e3a89d9ea6ffc221df41bd9cbf23e69863f12f
diff --git a/app-crypt/gpgme/gpgme-1.18.0-r1.ebuild b/app-crypt/gpgme/gpgme-1.18.0-r1.ebuild
new file mode 100644
index 000000000000..66befaf859db
--- /dev/null
+++ b/app-crypt/gpgme/gpgme-1.18.0-r1.ebuild
@@ -0,0 +1,130 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..11} )
+DISTUTILS_OPTIONAL=1
+VERIFY_SIG_OPENPGP_KEY_PATH="${BROOT}"/usr/share/openpgp-keys/gnupg.asc
+
+inherit distutils-r1 libtool flag-o-matic qmake-utils toolchain-funcs verify-sig
+
+DESCRIPTION="GnuPG Made Easy is a library for making GnuPG easier to use"
+HOMEPAGE="https://www.gnupg.org/related_software/gpgme"
+SRC_URI="mirror://gnupg/gpgme/${P}.tar.bz2
+ verify-sig? ( mirror://gnupg/gpgme/${P}.tar.bz2.sig )"
+
+LICENSE="GPL-2 LGPL-2.1"
+# Please check ABI on each bump, even if SONAMEs didn't change: bug #833355
+# Use e.g. app-portage/iwdevtools integration with dev-libs/libabigail's abidiff.
+# Subslot: SONAME of each: <libgpgme.libgpgmepp.libqgpgme.FUDGE>
+# Bump FUDGE if a release is made which breaks ABI without changing SONAME.
+# (Reset to 0 if FUDGE != 0 if libgpgme/libgpgmepp/libqpggme change.)
+SLOT="1/11.6.15.1"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="common-lisp static-libs +cxx python qt5 test"
+RESTRICT="!test? ( test )"
+
+# Note: On each bump, update dep bounds on each version from configure.ac!
+RDEPEND=">=app-crypt/gnupg-2
+ >=dev-libs/libassuan-2.5.3:=
+ >=dev-libs/libgpg-error-1.36:=
+ python? ( ${PYTHON_DEPS} )
+ qt5? ( dev-qt/qtcore:5 )"
+ #doc? ( app-doc/doxygen[dot] )
+DEPEND="${RDEPEND}
+ test? (
+ qt5? ( dev-qt/qttest:5 )
+ )"
+BDEPEND="python? ( dev-lang/swig )
+ verify-sig? ( sec-keys/openpgp-keys-gnupg )"
+
+REQUIRED_USE="qt5? ( cxx ) python? ( ${PYTHON_REQUIRED_USE} )"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.18.0-tests-start-stop-agent-use-command-v.patch
+)
+
+do_python() {
+ if use python; then
+ pushd "lang/python" > /dev/null || die
+ top_builddir="../.." srcdir="." CPP="$(tc-getCPP)" distutils-r1_src_${EBUILD_PHASE}
+ popd > /dev/null || die
+ fi
+}
+
+src_prepare() {
+ default
+
+ elibtoolize
+
+ # bug #697456
+ addpredict /run/user/$(id -u)/gnupg
+
+ local MAX_WORKDIR=66
+ if use test && [[ "${#WORKDIR}" -gt "${MAX_WORKDIR}" ]]; then
+ eerror "Unable to run tests as WORKDIR='${WORKDIR}' is longer than ${MAX_WORKDIR} which causes failure!"
+ die "Could not run tests as requested with too-long WORKDIR."
+ fi
+
+ # Make best effort to allow longer PORTAGE_TMPDIR
+ # as usock limitation fails build/tests
+ ln -s "${P}" "${WORKDIR}/b" || die
+ S="${WORKDIR}/b"
+}
+
+src_configure() {
+ local languages=()
+
+ use common-lisp && languages+=( "cl" )
+ use cxx && languages+=( "cpp" )
+ if use qt5; then
+ languages+=( "qt" )
+ #use doc ||
+ export DOXYGEN=true
+ export MOC="$(qt5_get_bindir)/moc"
+ fi
+
+ # bug #847955
+ append-lfs-flags
+
+ econf \
+ $(use test || echo "--disable-gpgconf-test --disable-gpg-test --disable-gpgsm-test --disable-g13-test") \
+ --enable-languages="${languages[*]}" \
+ $(use_enable static-libs static)
+
+ use python && emake -C lang/python prepare
+
+ do_python
+}
+
+src_compile() {
+ default
+ do_python
+}
+
+src_test() {
+ default
+
+ use python && distutils-r1_src_test
+}
+
+python_test() {
+ emake -C lang/python/tests check \
+ PYTHON=${EPYTHON} \
+ PYTHONS=${EPYTHON} \
+ TESTFLAGS="--python-libdir=${BUILD_DIR}/lib"
+}
+
+src_install() {
+ default
+
+ do_python
+
+ find "${ED}" -type f -name '*.la' -delete || die
+
+ # Backward compatibility for gentoo
+ # (in the past, we had slots)
+ dodir /usr/include/gpgme
+ dosym ../gpgme.h /usr/include/gpgme/gpgme.h
+}
diff --git a/app-crypt/kstart/Manifest b/app-crypt/kstart/Manifest
index 28ead19829ee..82d01601fffd 100644
--- a/app-crypt/kstart/Manifest
+++ b/app-crypt/kstart/Manifest
@@ -1,5 +1,5 @@
DIST kstart-4.2.tar.gz 296651 BLAKE2B 127bf28ef538681d188ae79ed67cedaa7d9022c1fe6741b3486ce7d5901c4a77d0aec7d00164240a79ffc70b56dd7fdeaf42e76dd2b02effe79bcad41ad8e271 SHA512 7ce9c1f964c0d469b4b8a5de88ae83186e99116959941c4e7f69c59165d0c22aac432ac26dd5fe54f7c2f725048bb55b787107aea8408e2fd6c9ad02dcb31552
DIST kstart-4.3.tar.gz 324005 BLAKE2B eb8a115e114f62ac93a84fcacd427cb0cb56241973747bb841d2263d6333ea670b5beb1421d6beca0366b8a444e7d24910fde1329c4a35a34190d9bf9e22b17d SHA512 a5d5e6f7428af82012d2935a05398336cfd7caf66243cce158930e7a9b79f444cf88f5f23ecbc2efe2432493440ef913f60f85820d5d9943687637935eee97fd
EBUILD kstart-4.2.ebuild 663 BLAKE2B 0732109be0c35d1517247151805af28863124cdab144aa9d76da0b7124a38c24050d0f3bb38159a8649982574da830ff2687f1f9b2431b929601fbbcae1b768c SHA512 2720add693aa5acbddacf27d1c167ea3622aeb757dec1721154cc1e2c0769872ef6700427ce6eb69977d5ff598afed2b12b3e14fb26dadb68b048f7f595c5648
-EBUILD kstart-4.3.ebuild 708 BLAKE2B df78dcf955d3c6a34904eb1b284c40447eaef8dfb4610632ac823757786117048d5e8630d68b043c59d6d7ec65ca06b089266876dd15ac854fa9f7e7d833f4b5 SHA512 6e0f9cb57e6ddc16335e9c8aa6b5840b3beea9f57a2daad5aa96712c822dcea52910e4464d77b2713162dcb6e69e002d436232615781a12e94e58a4da82ef8f0
+EBUILD kstart-4.3.ebuild 707 BLAKE2B 55ca8df5b4e06e501c6551eedb55e73273922cad6e58dbde4ca4711a7e15129b8c34853322ec1bd4ed15852c7b03f9ba182b727ff8d5c83b473b58d553093683 SHA512 dc46ae449410574384c3ca6d9c83206ffbd0ae4ef1816c05b28ba5a962ec9195cff17fa9404fef2cf0e10976adb3779d7c98f2420c7257868675e8cf54ddb5e4
MISC metadata.xml 808 BLAKE2B ac04ac91db9cd0bd19767e3d3c0a6789d073990297d7215b0e442962a48070f0bd180a318e4708b405424bacbf2686a1234eebb561e4b4d6aff51c79382f19c9 SHA512 532b706226b5a76d1a8daefb03a54b24006bcbe5e9b21fc8a8a79172cd35f96094b38e30e1735b287b54a56c7b497d4dc37be0483bc23bc9c48d9f7abaa4fceb
diff --git a/app-crypt/kstart/kstart-4.3.ebuild b/app-crypt/kstart/kstart-4.3.ebuild
index 673a633213c6..8b386b7b9c4c 100644
--- a/app-crypt/kstart/kstart-4.3.ebuild
+++ b/app-crypt/kstart/kstart-4.3.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -9,7 +9,7 @@ SRC_URI="https://archives.eyrie.org/software/kerberos/${P}.tar.gz"
LICENSE="|| ( MIT Stanford ISC )"
SLOT="0"
-KEYWORDS="~amd64 ~x86"
+KEYWORDS="amd64 ~x86"
IUSE="afs"
DEPEND="virtual/krb5
diff --git a/app-crypt/scute/Manifest b/app-crypt/scute/Manifest
index d1430f64a305..4257aff9302b 100644
--- a/app-crypt/scute/Manifest
+++ b/app-crypt/scute/Manifest
@@ -1,5 +1,6 @@
AUX scute-1.7.0-fno-common.patch 1207 BLAKE2B 1dd361484b82786d00c2883913c0f1492df22c8d0d02cccaa1f4d4186d43a55058a9ebe2f0c61ec9cc02e22b0c43b26036147e385a28b25e5163b98031166174 SHA512 3e8074a9ba910069da5c4f84d4c779baf070a3ac656ddcccb8defacd0af9e1aaf522d1eb9745caa84483bc1f6da13fd177fa8c587865797b42868002196cec64
DIST scute-1.7.0-manual-eps-images.tar.xz 236940 BLAKE2B 499207d9059bd4505f426b75f292e66755919d3e4e0d04d2f2420e2e0ceafa14ee47f0a3d7fd2846478dd0878eb01a776582a8299014728f4508a982fec36a28 SHA512 d227111456e664a295ee466dc990364423734170bc82d9a9d38ff72e79abca84775f164c2cf0dd893b9dfb63ff5035334f1740f80601a04dbc9fcb0877f50da7
DIST scute-1.7.0.tar.bz2 851177 BLAKE2B 9a459fc07c53e44d6b194f0f7786644dae7c37402f69cc511ed7e6cc387236cfe01b13400779a90a123461a28e69629abc260f0fad9c302a9b630e23cb8b4293 SHA512 d58771a8e45632f468b60ec2255f84ef5f2f4cc5e11cf8b0fcd0cec60cc8fe0c49bdd523e855998d5aa6f126138981b2316ee825cf33ec14e723f158e36283d3
+EBUILD scute-1.7.0-r1.ebuild 1287 BLAKE2B 576cc29f62345e35f0286d690793558b314de63d7b192a535fea1cef266b23d246364c7c5116e13e574d7963de78a1c7dbebb28d5ecc443fabdd96c36da49aaf SHA512 82f8497fef7522f968a910dce6e99fb7462c41f15fc011e151a187139b2c16c0b6e223b2fa6c9ca9df0b3f30e869d7715573c7bf1986fef528d0d375b2b8ed63
EBUILD scute-1.7.0.ebuild 1382 BLAKE2B 2e272267d6ab5332b16dd221be3df005b4850667e6578bc013a3eb67821a1d7effd42ea5ed022a7de2e87a9377518885058e72d615edc2e419aecf8a33b651d9 SHA512 44226957eac57f9b78a60b4eea29977d22dc0f7f1c4df37f4c35687256f33a59f0daabf0cbcf4d309a5dda76e6acfc6785a16ff0c85df43740956a7e03fa6848
MISC metadata.xml 758 BLAKE2B f223ae2fd2a26cdf487e2a5942f1ef7c59381ef3059fc38798e7d9e8ac0a9c7abe11fa917f1b5ce97ed2686f862c57995ace036d28353f9f76d40181ec3fe539 SHA512 c3ff684ddbbdad228eb40ad0f27c8d504d7f876c3762b99946031050d6917a76fb1b82e97a326d9f655402432d1e3939d4becb6fbf70c261fa0b6a9439e903eb
diff --git a/app-crypt/scute/scute-1.7.0-r1.ebuild b/app-crypt/scute/scute-1.7.0-r1.ebuild
new file mode 100644
index 000000000000..1a09b4e0e44a
--- /dev/null
+++ b/app-crypt/scute/scute-1.7.0-r1.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="A PKCS #11 module for OpenPGP smartcards"
+HOMEPAGE="http://www.scute.org/"
+SRC_URI="
+ mirror://gnupg/scute/${P}.tar.bz2
+ https://dev.gentoo.org/~soap/distfiles/${P}-manual-eps-images.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+
+# configure script try to check the version of gpgsm and gpg-agent when
+# non-crosscompiling so we need to have them as build-time dependency as
+# well as runtime. Require a version of gnupg that is patched to have
+# gpgsm-gencert.sh working (as that's what the documentation describe).
+BDEPEND="
+ >=app-crypt/pinentry-0.7.0
+ >=app-crypt/gnupg-2.0.17-r1[smartcard]"
+DEPEND="
+ >=dev-libs/libgpg-error-1.4
+ >=dev-libs/libassuan-2.0.0"
+RDEPEND="
+ ${DEPEND}
+ ${BDEPEND}"
+BDEPEND+="
+ sys-apps/texinfo"
+
+PATCHES=( "${FILESDIR}"/${P}-fno-common.patch )
+
+src_unpack() {
+ default
+
+ # have to use pregenerated EPS files required for the texinfo documentation,
+ # due to bug 664236 preventing even converting *to* eps.
+ mv scute-eps/*.eps "${S}"/doc/ || die
+}
+
+src_configure() {
+ econf \
+ --libdir="${EPREFIX}"/usr/$(get_libdir)/pkcs11
+}
+
+src_install() {
+ default
+
+ # only building plugins
+ find "${ED}" -name '*.la' -delete || die
+}