summaryrefslogtreecommitdiff
path: root/app-crypt
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-01-31 17:48:50 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-01-31 17:48:50 +0000
commit88e6368ac393fb69b358b60fcedf125f4724172f (patch)
treef2511a593c9c60c29d08b5d8f9684d2666bc20b4 /app-crypt
parent0c7c7c833ab740636f5a76d53ebe5bb6e0e793a8 (diff)
gentoo auto-resync : 31:01:2024 - 17:48:49
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/Manifest.gzbin24805 -> 24801 bytes
-rw-r--r--app-crypt/chntpw/Manifest2
-rw-r--r--app-crypt/chntpw/chntpw-140201-r1.ebuild7
3 files changed, 6 insertions, 3 deletions
diff --git a/app-crypt/Manifest.gz b/app-crypt/Manifest.gz
index 78cce728bdcc..4b548ea63323 100644
--- a/app-crypt/Manifest.gz
+++ b/app-crypt/Manifest.gz
Binary files differ
diff --git a/app-crypt/chntpw/Manifest b/app-crypt/chntpw/Manifest
index 5bda29bba0c2..b26a1b7d5e82 100644
--- a/app-crypt/chntpw/Manifest
+++ b/app-crypt/chntpw/Manifest
@@ -1,4 +1,4 @@
AUX chntpw-140201-missing-stdint.patch 596 BLAKE2B 093eb3d96bd34d6d436e69dcdbee64433af52e9f5db3fb92bbe110864040694db3b41ce53e29a4671649a870150bb90fee8c7e1211023cc8d153b76f456df8de SHA512 ab88107c1df99e7fd544a5779f1a9526a3e6d9c93b121f9076dc668e3823e63056df284bed60dd48f60ab2eccb198beee3a26292820805f1be1451776cc46531
DIST chntpw-source-140201.zip 1404098 BLAKE2B 86c93861983613496fcd82879a5b000537d4a7ee2add466aa26c67feabefdb5363f610234f99615139997a04aedb448468ef8b29cc6c4bf49b2e295f41308644 SHA512 a26d747f6e077d1bb3e9b8077781f8c37dd978e07b7426495862f15c9004572b706c34736fc4d1ed8856b1a43335d726b4d87c688f7f9a11fd6cc3a74d71a7fa
-EBUILD chntpw-140201-r1.ebuild 1076 BLAKE2B 4121569dbf98b0f80d1ac9503e972dcdcbb53208776fd26d8d4b614b8bdc3fbc1b5a06d6e2437938e7cf64644872f84659391d009bd22b75388be2f2c3b857de SHA512 f315bc2074aba9b9cd9cc402c338ec7a5dc612965ee75f5cdb4d13564a457e5cfbc799be1aead5fa57a039f0df66c52c5a413030b5a72e7586096a3ad54af9d5
+EBUILD chntpw-140201-r1.ebuild 1183 BLAKE2B 1337b4e411dbf48daae283126dd0397fc3944711000fa6d2fae4bf6f5d85fc2bd37970839d12be1b1423860f1fa9877de9fce1f1e1d3ca1c7da9b302746ab796 SHA512 66c4dbca7f58c8dfe80f81024f8d33af0be027db0747d482f623d44a96e4880e93565d0efa453c245f1116836e4ee6e004cc0c45d1efbe31cad60d7cc2ca8535
MISC metadata.xml 246 BLAKE2B f808bbbcb9c53d005d1a1667cd6217a601a3bd3bd2267121c0043a870ae44bb91bb27bc9825d5d6eafe01b73fe58a553655aa252737c0b066f2286ff9415d65e SHA512 b620abb7732628010a8a3792d40bde878492be97ce14c99c4d2466240df2f25edf7734ad4d210bc954f27323f0e26698e660766c65be5868646a3866020373fd
diff --git a/app-crypt/chntpw/chntpw-140201-r1.ebuild b/app-crypt/chntpw/chntpw-140201-r1.ebuild
index 2aeae846a75b..8594fba742f8 100644
--- a/app-crypt/chntpw/chntpw-140201-r1.ebuild
+++ b/app-crypt/chntpw/chntpw-140201-r1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-inherit toolchain-funcs
+inherit flag-o-matic toolchain-funcs
DESCRIPTION="Offline Windows NT Password & Registry Editor"
HOMEPAGE="https://pogostick.net/~pnh/ntpasswd/"
@@ -34,6 +34,9 @@ src_prepare() {
default
sed -i -e '/-o/s:$(CC):$(CC) $(LDFLAGS):' Makefile || die
+ # MANY changes would be required for this code to be c99-compliant
+ append-flags -std=gnu90
+
if ! use static ; then
sed -i -e "/^all:/s/ \(chntpw\|reged\).static//g" Makefile || die
fi