summaryrefslogtreecommitdiff
path: root/app-crypt
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-07-12 08:41:54 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-07-12 08:41:54 +0100
commit4df3bf9762850b34cd1ead5c80374d1a0fc3362e (patch)
tree3080c5cb7ad17abcb63776a9f21c4947845546a6 /app-crypt
parent814f4cf860e299a046b649eaee5463427984c09c (diff)
gentoo resync : 12.07.2021
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/Manifest.gzbin28267 -> 28269 bytes
-rw-r--r--app-crypt/acme/Manifest2
-rw-r--r--app-crypt/acme/acme-1.17.0.ebuild68
-rw-r--r--app-crypt/certbot-apache/Manifest2
-rw-r--r--app-crypt/certbot-apache/certbot-apache-1.17.0.ebuild30
-rw-r--r--app-crypt/certbot-nginx/Manifest2
-rw-r--r--app-crypt/certbot-nginx/certbot-nginx-1.17.0.ebuild32
-rw-r--r--app-crypt/certbot/Manifest2
-rw-r--r--app-crypt/certbot/certbot-1.17.0.ebuild36
9 files changed, 174 insertions, 0 deletions
diff --git a/app-crypt/Manifest.gz b/app-crypt/Manifest.gz
index 92b044bb269f..5a11171381c4 100644
--- a/app-crypt/Manifest.gz
+++ b/app-crypt/Manifest.gz
Binary files differ
diff --git a/app-crypt/acme/Manifest b/app-crypt/acme/Manifest
index 2c81995dcab0..187d718ce6b0 100644
--- a/app-crypt/acme/Manifest
+++ b/app-crypt/acme/Manifest
@@ -1,4 +1,6 @@
DIST certbot-1.16.0.tar.gz 1384177 BLAKE2B 4e46e7d7b9db2f6ef19fab60c2d904f84b502d2911ed496967bbe272db5352c1e9bdb65b8f45358f222214bce4721ceecc12c018b875148bc897f83c5eb63933 SHA512 c2a0c4ea52ab241e387d686a9e5ed67aa5e8b4b7d34ad8996e34562e036c25ab8b397bf482a856758ca787b97bbd78c890189250c0c3d948f03fbf91aa25ece0
+DIST certbot-1.17.0.tar.gz 1386471 BLAKE2B 26cf23c481cc67e1fa0f698dee83dd42b1d382814f10bdb4d2a459f1274f3d661d2a58815c30110701d46362c3fbaee9f57089a7eda1221c9b9dadb2c48dc79d SHA512 104deb8e6e804a3a3f50c730f00307aa39d9d42756f24be009fedc27c889c1575b456455ee11441e341025db6f528359e927a347554ebd57b64c39e789576eda
EBUILD acme-1.16.0.ebuild 1679 BLAKE2B ff4806292419911de014008dc51d250464f90368325db9a0cd73b6ba2881c6f60563fd7831d999ffba75772cbfa24af517d9fa52556f260f13c5855400d635bf SHA512 fbdc63af62a50e9ca6f98ed17b1b1be58a0a206b4e0940557b592f715a3d8bb81c6432132623e497e94806d595d4e71f0a660512c8ee23bd15b84088a62821cf
+EBUILD acme-1.17.0.ebuild 1681 BLAKE2B b3ede9a67c5e6462e623921bc02190a909c2b22d712c527a9de590af5892fc4770d9d3bd1174a0f0f1fcb054a93fdb88862b315260b74aae3755f666d1d91cfa SHA512 61652a5c834a08bcfe9aa806a985c25c9845022db1d458b7e8d77629a483269e41e583cfff536097bde43ad02a021be3652c5a73eda0f4661aa206aaff800eda
EBUILD acme-9999.ebuild 1681 BLAKE2B b3ede9a67c5e6462e623921bc02190a909c2b22d712c527a9de590af5892fc4770d9d3bd1174a0f0f1fcb054a93fdb88862b315260b74aae3755f666d1d91cfa SHA512 61652a5c834a08bcfe9aa806a985c25c9845022db1d458b7e8d77629a483269e41e583cfff536097bde43ad02a021be3652c5a73eda0f4661aa206aaff800eda
MISC metadata.xml 400 BLAKE2B a09af005ab6b00b9eb6e9252814273c932609e4dd6020c2289f5dafc8aa3e6bcb9696dc887767f29271af4a93fae73116f688937613ff9a340d5747a801097e5 SHA512 92c877fdfd16f55997573f2719eed9a9609fe34baff4c8b09bdb500c9eaf3e2bd3536e60127f171a92c4a1b8d9446e00208856754758c21779a8bbd137c3fab7
diff --git a/app-crypt/acme/acme-1.17.0.ebuild b/app-crypt/acme/acme-1.17.0.ebuild
new file mode 100644
index 000000000000..6e86a07321fd
--- /dev/null
+++ b/app-crypt/acme/acme-1.17.0.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=(python{3_7,3_8,3_9})
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+if [[ ${PV} == 9999* ]]; then
+ EGIT_REPO_URI="https://github.com/certbot/certbot.git"
+ inherit git-r3
+ S=${WORKDIR}/${P}/${PN}
+else
+ SRC_URI="https://github.com/certbot/certbot/archive/v${PV}.tar.gz -> certbot-${PV}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+ S=${WORKDIR}/certbot-${PV}/acme
+fi
+
+inherit distutils-r1
+
+DESCRIPTION="An implementation of the ACME protocol"
+HOMEPAGE="https://github.com/certbot/certbot https://letsencrypt.org/"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE="doc test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-python/cryptography-2.1.4[${PYTHON_USEDEP}]
+ >=dev-python/idna-2.0.0[${PYTHON_USEDEP}]
+ >=dev-python/josepy-1.1.0[${PYTHON_USEDEP}]
+ >=dev-python/pyopenssl-17.3.0[${PYTHON_USEDEP}]
+ dev-python/pyrfc3339[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.10[${PYTHON_USEDEP}]
+ >=dev-python/requests-toolbelt-0.3.0[${PYTHON_USEDEP}]
+"
+DEPEND="
+ doc? (
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ dev-python/sphinx_rtd_theme[${PYTHON_USEDEP}]
+ )
+ test? (
+ ${RDEPEND}
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+"
+
+src_compile() {
+ python_foreach_impl run_in_build_dir default
+ distutils-r1_src_compile
+ if use doc ; then
+ cd docs || die
+ sphinx-build -b html -d _build/doctrees . _build/html
+ fi
+}
+
+python_test() {
+ nosetests -w ${PN} || die
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+
+ distutils-r1_python_install_all
+}
diff --git a/app-crypt/certbot-apache/Manifest b/app-crypt/certbot-apache/Manifest
index 9789b91c5882..f2b9fc95cba4 100644
--- a/app-crypt/certbot-apache/Manifest
+++ b/app-crypt/certbot-apache/Manifest
@@ -1,4 +1,6 @@
DIST certbot-1.16.0.tar.gz 1384177 BLAKE2B 4e46e7d7b9db2f6ef19fab60c2d904f84b502d2911ed496967bbe272db5352c1e9bdb65b8f45358f222214bce4721ceecc12c018b875148bc897f83c5eb63933 SHA512 c2a0c4ea52ab241e387d686a9e5ed67aa5e8b4b7d34ad8996e34562e036c25ab8b397bf482a856758ca787b97bbd78c890189250c0c3d948f03fbf91aa25ece0
+DIST certbot-1.17.0.tar.gz 1386471 BLAKE2B 26cf23c481cc67e1fa0f698dee83dd42b1d382814f10bdb4d2a459f1274f3d661d2a58815c30110701d46362c3fbaee9f57089a7eda1221c9b9dadb2c48dc79d SHA512 104deb8e6e804a3a3f50c730f00307aa39d9d42756f24be009fedc27c889c1575b456455ee11441e341025db6f528359e927a347554ebd57b64c39e789576eda
EBUILD certbot-apache-1.16.0.ebuild 915 BLAKE2B e6cfa64a1bfad2719088c2ff8355040b8a607833f3372deb7236a0660788a4a4f7957df10aea8c7d9fa82ffe47ccc2c68542b1724f07f9495299166b87a4cb51 SHA512 91c65759d818a7c8c279de035f8280dda7408d46108139e689038906e212628d4a69b7a427448fb36a726090e0aa0805043da8a78764f6e3b925f44e94a657ae
+EBUILD certbot-apache-1.17.0.ebuild 917 BLAKE2B 6664a0470bc7631d492a7aa9b0b04cf0c86d6a60aa8056acae86f2a3bdcf137aae5290a320b18c323d0d6ab6178b304c2d9d2e1bdc4ae21237e7afa6fb4874ed SHA512 4047b9448fc589864019c87d08885480905c3da411f3b86774be9ac806b70db72ee60c01407eaec43f40d44fceaab23accc53d0bb4dec65a201d374d7457f5e3
EBUILD certbot-apache-9999.ebuild 917 BLAKE2B 6664a0470bc7631d492a7aa9b0b04cf0c86d6a60aa8056acae86f2a3bdcf137aae5290a320b18c323d0d6ab6178b304c2d9d2e1bdc4ae21237e7afa6fb4874ed SHA512 4047b9448fc589864019c87d08885480905c3da411f3b86774be9ac806b70db72ee60c01407eaec43f40d44fceaab23accc53d0bb4dec65a201d374d7457f5e3
MISC metadata.xml 358 BLAKE2B c94560461dda9d2d671208dd9a7e25586f86fe262bb06303a2a5e7f6f717d6936abe8c16dc6c7308aed4f8d11d4d5ae69969367b14d5bcfe838f60fc8b583642 SHA512 04670ec371be696e3da0328059ac4a336995a230823b10b6e5073fdb780ad1b873d510f31ec6c324b82562c0cfc86bfd3cbd797ef577fba7dccfe50c496627f7
diff --git a/app-crypt/certbot-apache/certbot-apache-1.17.0.ebuild b/app-crypt/certbot-apache/certbot-apache-1.17.0.ebuild
new file mode 100644
index 000000000000..7f0e325d33df
--- /dev/null
+++ b/app-crypt/certbot-apache/certbot-apache-1.17.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=(python{3_7,3_8,3_9})
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+if [[ ${PV} == 9999* ]]; then
+ EGIT_REPO_URI="https://github.com/certbot/certbot.git"
+ inherit git-r3
+ S=${WORKDIR}/${P}/${PN}
+else
+ SRC_URI="https://github.com/${PN%-apache}/${PN%-apache}/archive/v${PV}.tar.gz -> ${PN%-apache}-${PV}.tar.gz"
+ KEYWORDS="~amd64 ~arm64 ~x86"
+ S=${WORKDIR}/${PN%-apache}-${PV}/${PN}
+fi
+
+inherit distutils-r1
+
+DESCRIPTION="Apache plugin for certbot (Let's Encrypt Client)"
+HOMEPAGE="https://github.com/certbot/certbot https://letsencrypt.org/"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+
+RDEPEND=">=app-crypt/acme-${PV}[${PYTHON_USEDEP}]
+ >=app-crypt/certbot-${PV}[${PYTHON_USEDEP}]
+ dev-python/python-augeas[${PYTHON_USEDEP}]
+ dev-python/zope-component[${PYTHON_USEDEP}]
+ dev-python/zope-interface[${PYTHON_USEDEP}]"
diff --git a/app-crypt/certbot-nginx/Manifest b/app-crypt/certbot-nginx/Manifest
index c10d4228b6b4..0c09353d03e3 100644
--- a/app-crypt/certbot-nginx/Manifest
+++ b/app-crypt/certbot-nginx/Manifest
@@ -1,4 +1,6 @@
DIST certbot-1.16.0.tar.gz 1384177 BLAKE2B 4e46e7d7b9db2f6ef19fab60c2d904f84b502d2911ed496967bbe272db5352c1e9bdb65b8f45358f222214bce4721ceecc12c018b875148bc897f83c5eb63933 SHA512 c2a0c4ea52ab241e387d686a9e5ed67aa5e8b4b7d34ad8996e34562e036c25ab8b397bf482a856758ca787b97bbd78c890189250c0c3d948f03fbf91aa25ece0
+DIST certbot-1.17.0.tar.gz 1386471 BLAKE2B 26cf23c481cc67e1fa0f698dee83dd42b1d382814f10bdb4d2a459f1274f3d661d2a58815c30110701d46362c3fbaee9f57089a7eda1221c9b9dadb2c48dc79d SHA512 104deb8e6e804a3a3f50c730f00307aa39d9d42756f24be009fedc27c889c1575b456455ee11441e341025db6f528359e927a347554ebd57b64c39e789576eda
EBUILD certbot-nginx-1.16.0.ebuild 933 BLAKE2B 019025bd57899cca498bc2011e4d4822a0aafe94b974cc785eb8c770b6a7b00c19f9891f5ed890046467d6ebb31fd1f9b1452b63c2e2c6eb7cd09db318a282f4 SHA512 57f1466ad320578076f5ab974d92791fed4c2469df0c91ca21b649ea86ed0dc6ab9caf5c0db7d669944e893e40f2fbef33eb42a1addf7d11cac310616cabd2c2
+EBUILD certbot-nginx-1.17.0.ebuild 935 BLAKE2B c658bd5e5c2aae786e6e41cf77fc840c61e2fd1b7470706bb4cd573edf2117344ab29173fb24ab370e9ee3a5f28c644d4cb12a4bafc5cedb72ad4282627939ca SHA512 c3c33b250a0e830d4498a5864643b117d0b2c29b4130795aafb135d7b369754836a65704cdc437828a5f8991368c2b03bc5b11963328e5c6cf826c92d42c5f80
EBUILD certbot-nginx-9999.ebuild 935 BLAKE2B c658bd5e5c2aae786e6e41cf77fc840c61e2fd1b7470706bb4cd573edf2117344ab29173fb24ab370e9ee3a5f28c644d4cb12a4bafc5cedb72ad4282627939ca SHA512 c3c33b250a0e830d4498a5864643b117d0b2c29b4130795aafb135d7b369754836a65704cdc437828a5f8991368c2b03bc5b11963328e5c6cf826c92d42c5f80
MISC metadata.xml 334 BLAKE2B e7b28e7d3e7c6fdce0c5120b29fbf5aa607408e2add6c0ad42e921fb1add9def38c6cb191129a5a6e1f0e3ea119caa6cdc74955b572e5d2c6f854d0b7c7c521a SHA512 a24ccf633fc9c2670dcd35801d95bd8ca0f4ea4d3d53b6651f2e8e3e280b95ec8a464d99f5423942c14b0777ae4551f46c1ff285caea460bc91cbc417a7a5b70
diff --git a/app-crypt/certbot-nginx/certbot-nginx-1.17.0.ebuild b/app-crypt/certbot-nginx/certbot-nginx-1.17.0.ebuild
new file mode 100644
index 000000000000..b4f61386b477
--- /dev/null
+++ b/app-crypt/certbot-nginx/certbot-nginx-1.17.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=(python{3_7,3_8,3_9})
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+if [[ ${PV} == 9999* ]]; then
+ EGIT_REPO_URI="https://github.com/certbot/certbot.git"
+ inherit git-r3
+ S=${WORKDIR}/${P}/${PN}
+else
+ SRC_URI="https://github.com/${PN%-nginx}/${PN%-nginx}/archive/v${PV}.tar.gz -> ${PN%-nginx}-${PV}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+ S=${WORKDIR}/${PN%-nginx}-${PV}/${PN}
+fi
+
+inherit distutils-r1
+
+DESCRIPTION="Nginx plugin for certbot (Let's Encrypt Client)"
+HOMEPAGE="https://github.com/certbot/certbot https://letsencrypt.org/"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ >=app-crypt/acme-${PV}[${PYTHON_USEDEP}]
+ >=app-crypt/certbot-${PV}[${PYTHON_USEDEP}]
+ >=dev-python/pyopenssl-17.3.0[${PYTHON_USEDEP}]
+ >=dev-python/pyparsing-2.2.0[${PYTHON_USEDEP}]
+ dev-python/zope-interface[${PYTHON_USEDEP}]"
diff --git a/app-crypt/certbot/Manifest b/app-crypt/certbot/Manifest
index eba92f631787..a1b24059bc3b 100644
--- a/app-crypt/certbot/Manifest
+++ b/app-crypt/certbot/Manifest
@@ -1,4 +1,6 @@
DIST certbot-1.16.0.tar.gz 1384177 BLAKE2B 4e46e7d7b9db2f6ef19fab60c2d904f84b502d2911ed496967bbe272db5352c1e9bdb65b8f45358f222214bce4721ceecc12c018b875148bc897f83c5eb63933 SHA512 c2a0c4ea52ab241e387d686a9e5ed67aa5e8b4b7d34ad8996e34562e036c25ab8b397bf482a856758ca787b97bbd78c890189250c0c3d948f03fbf91aa25ece0
+DIST certbot-1.17.0.tar.gz 1386471 BLAKE2B 26cf23c481cc67e1fa0f698dee83dd42b1d382814f10bdb4d2a459f1274f3d661d2a58815c30110701d46362c3fbaee9f57089a7eda1221c9b9dadb2c48dc79d SHA512 104deb8e6e804a3a3f50c730f00307aa39d9d42756f24be009fedc27c889c1575b456455ee11441e341025db6f528359e927a347554ebd57b64c39e789576eda
EBUILD certbot-1.16.0.ebuild 1150 BLAKE2B 3d12f9623927d69800604d841f3159d131160be4d80bd1ff44242164c813600a117778c22f6bad056ff22412897a7449444d6cd685123ab390afb7b75d2787b5 SHA512 4fae07647cb002f625e7fff6dae5d6a15bcaa9dbdf3de847c1f8dc8cb6e4b5e2f64369967f0955ab10451921e0c200504478956fd7903ed32fbb04978bc4ba2e
+EBUILD certbot-1.17.0.ebuild 1152 BLAKE2B d30a158dbe17a5706583ce7de83f152e5627d5481318b82a0ef2fd9dc5b99c0109a65c819878dc86fbc715d42d707e9a6556fd7ab9a599264209aeae7f7823f2 SHA512 15f463ff5a385e639ab8abe14f064e1c8da5ad14255200cf21ea90083eeaccb75dde1e054be2b193452e81af25f6ccb9f4933343cb5071a3d920390af9073de1
EBUILD certbot-9999.ebuild 1152 BLAKE2B d30a158dbe17a5706583ce7de83f152e5627d5481318b82a0ef2fd9dc5b99c0109a65c819878dc86fbc715d42d707e9a6556fd7ab9a599264209aeae7f7823f2 SHA512 15f463ff5a385e639ab8abe14f064e1c8da5ad14255200cf21ea90083eeaccb75dde1e054be2b193452e81af25f6ccb9f4933343cb5071a3d920390af9073de1
MISC metadata.xml 358 BLAKE2B c94560461dda9d2d671208dd9a7e25586f86fe262bb06303a2a5e7f6f717d6936abe8c16dc6c7308aed4f8d11d4d5ae69969367b14d5bcfe838f60fc8b583642 SHA512 04670ec371be696e3da0328059ac4a336995a230823b10b6e5073fdb780ad1b873d510f31ec6c324b82562c0cfc86bfd3cbd797ef577fba7dccfe50c496627f7
diff --git a/app-crypt/certbot/certbot-1.17.0.ebuild b/app-crypt/certbot/certbot-1.17.0.ebuild
new file mode 100644
index 000000000000..bf9117a89b96
--- /dev/null
+++ b/app-crypt/certbot/certbot-1.17.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=(python{3_7,3_8,3_9})
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+if [[ ${PV} == 9999* ]]; then
+ EGIT_REPO_URI="https://github.com/certbot/certbot.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+fi
+S=${WORKDIR}/${P}/${PN}
+
+inherit distutils-r1
+
+DESCRIPTION="Let's encrypt client to automate deployment of X.509 certificates"
+HOMEPAGE="https://github.com/certbot/certbot https://letsencrypt.org/"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+
+RDEPEND="
+ >=app-crypt/acme-${PV}[${PYTHON_USEDEP}]
+ >=dev-python/configargparse-0.9.3[${PYTHON_USEDEP}]
+ >=dev-python/configobj-5.0.6[${PYTHON_USEDEP}]
+ >=dev-python/cryptography-2.8[${PYTHON_USEDEP}]
+ >=dev-python/distro-1.0.1[${PYTHON_USEDEP}]
+ >=dev-python/josepy-1.1.0[${PYTHON_USEDEP}]
+ >=dev-python/parsedatetime-2.4[${PYTHON_USEDEP}]
+ dev-python/pyrfc3339[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+ dev-python/zope-component[${PYTHON_USEDEP}]
+ dev-python/zope-interface[${PYTHON_USEDEP}]"