summaryrefslogtreecommitdiff
path: root/app-crypt
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-02-01 11:48:39 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-02-01 11:48:39 +0000
commit1e39e6a8c127767a57f0465ed9ece4fefb44b4ae (patch)
tree3559e11cac3d1d8c48d4a253876d1927017c508f /app-crypt
parentd13aef5a4ce5eb3b31565d0d9e67e903e5e932df (diff)
gentoo auto-resync : 01:02:2024 - 11:48:38
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/Manifest.gzbin24801 -> 24801 bytes
-rw-r--r--app-crypt/loop-aes-losetup/Manifest3
-rw-r--r--app-crypt/loop-aes-losetup/loop-aes-losetup-2.39.2.ebuild71
3 files changed, 74 insertions, 0 deletions
diff --git a/app-crypt/Manifest.gz b/app-crypt/Manifest.gz
index 4b548ea63323..14c43b653886 100644
--- a/app-crypt/Manifest.gz
+++ b/app-crypt/Manifest.gz
Binary files differ
diff --git a/app-crypt/loop-aes-losetup/Manifest b/app-crypt/loop-aes-losetup/Manifest
index 724619c2f752..e06e3a11b778 100644
--- a/app-crypt/loop-aes-losetup/Manifest
+++ b/app-crypt/loop-aes-losetup/Manifest
@@ -1,4 +1,7 @@
DIST loop-AES-v3.7q.tar.bz2 376027 BLAKE2B 7f3206196fcb7ecc928bda4cd127042f61cd5ac7f39e483fb91db388572be1c8e252d5c4adb653e6fd00ff6a7ba4c1406c35f2b2659e9cb38fd817f1bdb2a15f SHA512 103869695f6b18bcc765804865468db4b24fc2fcce3ec97d8468fdc0bd37c480386960730e280cd93c707026dddc5e79d8d25e2601c3678330e016835166ad20
+DIST loop-AES-v3.8b.tar.bz2 411795 BLAKE2B 51e2c4ddd25f288c5cc5cbbbe20d79951d68bc2b7ecc91fe6eddbb829b297fe6946590512f423efcf5be3c4a1c9ce450c0cf49ed44ac6ad8eb2568468570d48f SHA512 8143649cc9616735cb9a9c8cb8b5c8a709b139e8b41aec444d56c85ef7852d103f657d0d702ffb04783963f0d0e919a6fe4e10b31cd373cd326e546caad90661
DIST util-linux-2.35.2.tar.xz 5150488 BLAKE2B 93eb90ab33db7795b46425ec4ec87f8a2d3d6e0dad671345375ea02efd654bf72041932d30b41bea494e4b62952e2fd14ea9f9e6c738d4eb4b050bd170b9bb0e SHA512 59e038ba71aa74c9af6f927b357483a965f675ab3ffcd25cf0c1b043656312d2d2d07c55659fd3da69ede165bec313e0ae7e1cd73758e49681ae610604b399a2
+DIST util-linux-2.39.2.tar.xz 8362220 BLAKE2B 963c257b86f8a025a3452f102656f479382b9e03dd8ce39b9561302b484c595005aa0bbce9b91422d9be038037143772483363c2a1eec569355316fc8d5d5765 SHA512 cebecdd62749d0aeea2c4faf7ad1606426eff03ef3b15cd9c2df1126f216a4ed546d8fc3218c649fa95944eb87a98bb6a7cdd0bea31057c481c5cf608ffc19a3
EBUILD loop-aes-losetup-2.35.2.ebuild 2178 BLAKE2B 107eeffbd0719d1d89a8ffba218ab9859c9b5ff06a9338d55a6feacd91126a3ebee2419ca781fa870db0c8cc2bd5dc5874cb55ccf6730efbdb964faa335e4922 SHA512 34cdf0cc74b9646bfc2b2d47d1c6c8f35cf051505db1fab8ed7285c86bd633189d29a255e7de1a874412045e7c9770d58fc6035bc2c0bcf079c5a1fdec72fd92
+EBUILD loop-aes-losetup-2.39.2.ebuild 1860 BLAKE2B 1fff1cc03a7685ea91488ce6d771200c9a802a5ed267a12d04d03172f50ec04f7560ba4d7de5f4d0488f5d5bcbf10cf4f06bd6baee391b68356409ba5fff587e SHA512 c1894299c4dd018665a0b76e39b4b32e79890c32fcf2bd57ff2c044a6c867af4e7ca5447be676315ac4785b61fa66d4d5ed9df1c30391dbb94232886775c55a5
MISC metadata.xml 475 BLAKE2B b7d28308b25a35ee91e01780ef8097e29f5cd76bb38fb3cf61227f7ca2de5ae67a8dca87c3ef0a2b257ed0d0e2de2c7d733134ccfa6a1d93a357b5225f617cc4 SHA512 edb3191a17626c07b1bea7e5e07c14f91f6b85b9a9302b2f4d3222b55bb160fc89277d8c17feb28ce551e0b2ed34669a106a18c12d2af38c7f231ab26a536cee
diff --git a/app-crypt/loop-aes-losetup/loop-aes-losetup-2.39.2.ebuild b/app-crypt/loop-aes-losetup/loop-aes-losetup-2.39.2.ebuild
new file mode 100644
index 000000000000..7551cf619b3e
--- /dev/null
+++ b/app-crypt/loop-aes-losetup/loop-aes-losetup-2.39.2.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs libtool flag-o-matic
+
+MY_PV="${PV/_/-}"
+MY_P="util-linux-${MY_PV}"
+LOOPAES_P="loop-AES-v3.8b"
+S="${WORKDIR}/${MY_P}"
+
+DESCRIPTION="Loop-AES losetup utility"
+HOMEPAGE="https://www.kernel.org/pub/linux/utils/util-linux/ https://github.com/util-linux/util-linux"
+SRC_URI="https://www.kernel.org/pub/linux/utils/util-linux/v${PV:0:4}/${MY_P}.tar.xz
+ http://loop-aes.sourceforge.net/loop-AES/${LOOPAES_P}.tar.bz2"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~sparc ~x86"
+
+LICENSE="GPL-2 LGPL-2.1 BSD-4 MIT public-domain"
+SLOT="0"
+IUSE="nls selinux static"
+
+RDEPEND="selinux? ( >=sys-libs/libselinux-2.2.2-r4 )"
+BDEPEND="
+ virtual/pkgconfig
+ nls? ( sys-devel/gettext )
+"
+DEPEND="
+ ${RDEPEND}
+ virtual/os-headers
+"
+
+PATCHES=(
+ "${WORKDIR}/${LOOPAES_P}/util-linux-${PV}.diff"
+)
+
+src_prepare() {
+ default
+ elibtoolize
+}
+
+src_configure() {
+ append-lfs-flags
+
+ # The scanf test in a run-time test which fails while cross-compiling.
+ # Blindly assume a POSIX setup since we require libmount, and libmount
+ # itself fails when the scanf test fails. #531856
+ tc-is-cross-compiler && export scanf_cv_alloc_modifier=ms
+
+ ECONF_SOURCE=${S} \
+ econf \
+ --disable-all-programs \
+ --disable-libmount-mountfd-support \
+ --disable-pylibmount \
+ --enable-libsmartcols \
+ --enable-losetup \
+ --without-ncurses \
+ --without-udev \
+ $(use_enable nls) \
+ $(use_with selinux) \
+ $(tc-has-tls || echo --disable-tls) \
+ $(use_enable static) \
+ $(use static && echo --enable-static-programs=losetup)
+}
+
+src_install() {
+ emake install DESTDIR="${T}/root"
+ newsbin "${T}/root/sbin/losetup" loop-aes-losetup
+ newman "${T}/root/usr/share/man/man8/losetup.8" loop-aes-losetup.8
+ use static && newsbin "${T}/root/bin/losetup.static" loop-aes-losetup.static
+}