summaryrefslogtreecommitdiff
path: root/app-crypt
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-09-25 05:33:01 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-09-25 05:33:01 +0100
commit1a256280f70812d1ae23f0ce2a2569291b6609da (patch)
tree76a302e99d339c5c3b0d18ed3f01a983740a03cb /app-crypt
parent83c7eb1835fcfdf7072b953d23ab34f03c7e8ed6 (diff)
gentoo auto-resync : 25:09:2022 - 05:33:00
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/Manifest.gzbin23974 -> 23971 bytes
-rw-r--r--app-crypt/tpm2-tss-engine/Manifest2
-rw-r--r--app-crypt/tpm2-tss-engine/files/tpm2-tss-engine-1.1.0-tests-Allow-compilation-under-musl.patch35
-rw-r--r--app-crypt/tpm2-tss-engine/tpm2-tss-engine-1.1.0-r2.ebuild47
4 files changed, 84 insertions, 0 deletions
diff --git a/app-crypt/Manifest.gz b/app-crypt/Manifest.gz
index e0ea46ee85f3..10848ebda380 100644
--- a/app-crypt/Manifest.gz
+++ b/app-crypt/Manifest.gz
Binary files differ
diff --git a/app-crypt/tpm2-tss-engine/Manifest b/app-crypt/tpm2-tss-engine/Manifest
index 7f144660be37..617723eb5ead 100644
--- a/app-crypt/tpm2-tss-engine/Manifest
+++ b/app-crypt/tpm2-tss-engine/Manifest
@@ -1,3 +1,5 @@
+AUX tpm2-tss-engine-1.1.0-tests-Allow-compilation-under-musl.patch 1025 BLAKE2B 4f957dc6a7ceafe53dcf68ded61e2d75d9c09f4b8c056ab92857662e42223b83d99595d7d5c4f89547d3001427a27370d45597349be5261ebd35f30dd105a498 SHA512 6505fa8eba5ead5b75b48d6b4bd1bbf65ac5060fb1d5b77a2b3eec14420fb80d4a712ebb01c7485fc8dd36c5c9a1e9f0b1bd3d9867338858fa63a0070abfec10
DIST tpm2-tss-engine-1.1.0.tar.gz 394448 BLAKE2B 0502907dc9ce872f31be3b980f975a02af2e3e4b369d188afa5327bd4475d93dbf43769dc7ddc11e8cbda8d1fde09f28a9aef9145e859a90225cd397f62c7a2c SHA512 5d2e08178be54350e8672245023d601a0d9d520f8c49e977af49d7c59b91d033c14b4a347b71e042fe7c5ff12af9fcc43b69fd1dc83a9f0db12d47d43e1107f4
EBUILD tpm2-tss-engine-1.1.0-r1.ebuild 873 BLAKE2B a08a6ac9fb15bb90576eba365aa80e3c23b67df12a6186a84df4f949e2dfb7995d928ffeddfc66367f93fa62b9da9e0898f617f263aaab16e6caed237f912086 SHA512 828b2b3317317f049a00bd073c257db6b39d3aae9d902a6fc6e8206615b18a6f78e3ad26a1f93bd564ac209d2a9defea80dce849c648e6da550af9557516a823
+EBUILD tpm2-tss-engine-1.1.0-r2.ebuild 995 BLAKE2B 637e5639800057b2f132781774944431bb6bbfcf6c66ad64c08dccfa6a8c1b2a720055788db69a45907e1e1760133d82fa82b83c960ee49053aa07b5a8ef7c48 SHA512 d357f6ce46b93ef9d7d3546dec2d128ff91d5a5aa288c5f69ed18b4e436e618771005610e9d8448c9be4333148495e9101492d9725e1ac01d88f78188ce03caa
MISC metadata.xml 498 BLAKE2B 00c3e4cdaaf71d33864bfdca3585e9874a6d984aa6d825e8ed2dcc00afa022c5908b37da3e391238f4c7519408d4dcaafff40ceee644312e568627c44bfdecec SHA512 459f2c5d0a6051a81cf5f3c17f65248fe8e1681db2032ccebc2a1c0de6ea427c45bb317ffd374bb141f5f06bc16305e61bc591df9d943821fe1ac0f31e4f5323
diff --git a/app-crypt/tpm2-tss-engine/files/tpm2-tss-engine-1.1.0-tests-Allow-compilation-under-musl.patch b/app-crypt/tpm2-tss-engine/files/tpm2-tss-engine-1.1.0-tests-Allow-compilation-under-musl.patch
new file mode 100644
index 000000000000..b8114b4c25c0
--- /dev/null
+++ b/app-crypt/tpm2-tss-engine/files/tpm2-tss-engine-1.1.0-tests-Allow-compilation-under-musl.patch
@@ -0,0 +1,35 @@
+https://bugs.gentoo.org/833531
+--- a/configure.ac
++++ b/configure.ac
+@@ -174,6 +174,8 @@ AC_ARG_WITH([device],
+ [with_device_set=no])
+ AM_CONDITIONAL([TESTDEVICE],[test "x$with_device_set" = xyes])
+
++AC_CHECK_FUNC([backtrace_symbols_fd],[AC_DEFINE([HAVE_EXECINFO],[1], ['Define to 1 if you have the <execinfo.h> header file.'])])
++
+ # Integration test with simulator
+ AS_IF([test "x$enable_integration" = xyes && test "x$with_device_set" = xno],
+ [integration_args=""
+--- a/test/error_tpm2-tss-engine-common.c
++++ b/test/error_tpm2-tss-engine-common.c
+@@ -7,7 +7,9 @@
+ #include "tpm2-tss-engine.h"
+ #include "tpm2-tss-engine-common.h"
+
++#ifdef HAVE_EXECINFO
+ #include <execinfo.h>
++#endif
+ #include <stdio.h>
+ #include <unistd.h>
+ #include <setjmp.h>
+@@ -17,8 +19,10 @@ TSS2_RC
+ __wrap_Esys_Initialize()
+ {
+ printf("Esys_Initialize called\n");
++#ifdef HAVE_EXECINFO
+ void* b[128];
+ backtrace_symbols_fd(b, backtrace(b, sizeof(b)/sizeof(b[0])), STDOUT_FILENO);
++#endif
+ return -1;
+ }
+
diff --git a/app-crypt/tpm2-tss-engine/tpm2-tss-engine-1.1.0-r2.ebuild b/app-crypt/tpm2-tss-engine/tpm2-tss-engine-1.1.0-r2.ebuild
new file mode 100644
index 000000000000..c320b9d81d6f
--- /dev/null
+++ b/app-crypt/tpm2-tss-engine/tpm2-tss-engine-1.1.0-r2.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools bash-completion-r1
+
+DESCRIPTION="OpenSSL Engine for TPM2 devices"
+HOMEPAGE="https://github.com/tpm2-software/tpm2-tss-engine"
+SRC_URI="https://github.com/tpm2-software/${PN}/releases/download/v${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="app-crypt/tpm2-tss:=
+ >=dev-libs/openssl-1.1.1:=
+ <dev-libs/openssl-3.0.0:="
+DEPEND="${RDEPEND}
+ test? ( dev-util/cmocka )"
+BDEPEND="sys-devel/autoconf-archive
+ virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-1.1.0-tests-Allow-compilation-under-musl.patch"
+ )
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable test unit) \
+ --disable-defaultflags \
+ --disable-static \
+ --with-completionsdir="$(get_bashcompdir)"
+}
+
+src_install () {
+ default
+ find "${ED}" -name '*.la' -delete || die
+ dobashcomp bash-completion/*
+}