summaryrefslogtreecommitdiff
path: root/app-crypt/yubioath-flutter-bin
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-03-12 18:13:14 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-03-12 18:13:14 +0000
commitf1ced5f5f09c4d27185e6986a465f7bc3b828c65 (patch)
treebb4a65f6889f3cbcc2f8e5053b624f23291d7921 /app-crypt/yubioath-flutter-bin
parent70d27c1344f6a6a51e11c610966542333b6f432a (diff)
gentoo auto-resync : 12:03:2023 - 18:13:14
Diffstat (limited to 'app-crypt/yubioath-flutter-bin')
-rw-r--r--app-crypt/yubioath-flutter-bin/Manifest3
-rw-r--r--app-crypt/yubioath-flutter-bin/metadata.xml11
-rw-r--r--app-crypt/yubioath-flutter-bin/yubioath-flutter-bin-6.1.0.ebuild70
3 files changed, 84 insertions, 0 deletions
diff --git a/app-crypt/yubioath-flutter-bin/Manifest b/app-crypt/yubioath-flutter-bin/Manifest
new file mode 100644
index 000000000000..9d4c0dfde996
--- /dev/null
+++ b/app-crypt/yubioath-flutter-bin/Manifest
@@ -0,0 +1,3 @@
+DIST yubico-authenticator-6.1.0-linux.tar.gz 46363854 BLAKE2B f50f8dc6cdca9044c9c1a0f370cc71d627358038bd00f34bb3801d9b5cc31a5fc904ba817e5ad613c6947c9546691d965e6b373c89e220314747a5eb0321e217 SHA512 e4a63aa40e06ae4cbeee5fc32b749bcc94c9a22b86104ff32e8f94dcd34cf0a0e61e686efd4a21ea8965f37e997f53d452739bb4c332af2387473dccd5b72b99
+EBUILD yubioath-flutter-bin-6.1.0.ebuild 2163 BLAKE2B 9dbb38e4873e59f14f9508ab4be478a1e9979ad702f887fbe506619bbea93f6b267d9f50881d0a4e6d0e34aeb7b4887ada819c54c2d7e500c0d7a52b1f762146 SHA512 aea37b417e5ae34dc5909d720a8f95fc4cbb81b93cd64e01b41fac5beed059164bcf3a1994ce89687b87b149a2ad619260d528b4e45bef3015346c8e4e90f9ae
+MISC metadata.xml 333 BLAKE2B 7f04bc0877fb881af8d867ef35b9e9998e22be0c69747a2f36e16de3632cf0cb7835483430396244551dcac978021e9281301ebf0bde51a3ae2f022b9a03f354 SHA512 f857a7150979f6a9e93c21ab6a60dcfaf70998021605e94eb486d8db73371c9bcf7f02b80f4b65dcda84ead94fd3641acd00ed78a92e807f57ddd59a78080093
diff --git a/app-crypt/yubioath-flutter-bin/metadata.xml b/app-crypt/yubioath-flutter-bin/metadata.xml
new file mode 100644
index 000000000000..a5fba6897c0d
--- /dev/null
+++ b/app-crypt/yubioath-flutter-bin/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>soap@gentoo.org</email>
+ <name>David Seifert</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">Yubico/yubioath-flutter</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-crypt/yubioath-flutter-bin/yubioath-flutter-bin-6.1.0.ebuild b/app-crypt/yubioath-flutter-bin/yubioath-flutter-bin-6.1.0.ebuild
new file mode 100644
index 000000000000..7662796ea649
--- /dev/null
+++ b/app-crypt/yubioath-flutter-bin/yubioath-flutter-bin-6.1.0.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit desktop xdg
+
+DESCRIPTION="Yubico Authenticator for TOTP"
+HOMEPAGE="
+ https://developers.yubico.com/yubioath-flutter/
+ https://github.com/Yubico/yubioath-flutter"
+SRC_URI="https://github.com/Yubico/yubioath-flutter/releases/download/${PV}/yubico-authenticator-${PV}-linux.tar.gz"
+S="${WORKDIR}/yubico-authenticator-${PV}-linux"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="-* ~amd64"
+
+RDEPEND="
+ app-accessibility/at-spi2-core:2
+ dev-libs/glib:2
+ media-libs/libepoxy
+ x11-libs/cairo
+ x11-libs/gdk-pixbuf:2
+ x11-libs/gtk+:3
+ x11-libs/libxcb
+ x11-libs/pango"
+BDEPEND="app-admin/chrpath"
+
+# "Modern" app, built using Google's flutter framework.
+#
+# Don't even *think* about unbundling the dependencies, they're all
+# hardcoded into the main binary and the helper, including but not
+# limited to a full-fledged python interpreter that gets dlopen'd, an
+# assortment of python packages, the X11 kitchen sink, random GCC
+# libraries, and OpenSSL 1.1, oftentimes using git checkouts instead of
+# released versioned libraries.
+#
+# The only way to avoid this mess would be to build flutter from source,
+# but unfortunately life is too short to be dealing with whatever is
+# Google's framework-de-jour on a regular basis.
+QA_PREBUILT="opt/yubico-authenticator/*"
+
+src_install() {
+ einstalldocs
+ rm -r README* || die
+
+ sed -e 's|@EXEC_PATH/authenticator|authenticator|' \
+ -e 's|@EXEC_PATH/linux_support/com.yubico.yubioath.png|com.yubico.yubioath|g' \
+ -i linux_support/com.yubico.authenticator.desktop || die
+ domenu linux_support/com.yubico.authenticator.desktop
+ doicon -s 128 linux_support/com.yubico.yubioath.png
+ rm -r linux_support || die
+
+ exeinto /opt/yubico-authenticator
+ doexe authenticator
+ rm authenticator || die
+
+ exeinto /opt/yubico-authenticator/helper
+ doexe helper/authenticator-helper
+ rm helper/authenticator-helper || die
+
+ # prevent rpath_security_checks() trigger
+ chrpath -d helper/libjpeg*.so.* || die
+
+ insinto /opt/yubico-authenticator
+ doins -r .
+
+ dosym ../../opt/yubico-authenticator/authenticator /usr/bin/authenticator
+}