summaryrefslogtreecommitdiff
path: root/app-crypt/yubioath-desktop
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-11-13 13:10:00 +0000
committerV3n3RiX <venerix@koprulu.sector>2021-11-13 13:10:00 +0000
commite9d044d4b9b71200a96adfa280848858c0f468c9 (patch)
tree1bd8ef816043a8cd340f1d774e79553a1a7d31d8 /app-crypt/yubioath-desktop
parentfc2f1018fc323ef2c6572734a9b130427cba76a6 (diff)
gentoo resync : 13.11.2021
Diffstat (limited to 'app-crypt/yubioath-desktop')
-rw-r--r--app-crypt/yubioath-desktop/Manifest2
-rw-r--r--app-crypt/yubioath-desktop/yubioath-desktop-5.1.0.ebuild56
2 files changed, 58 insertions, 0 deletions
diff --git a/app-crypt/yubioath-desktop/Manifest b/app-crypt/yubioath-desktop/Manifest
index 9552097fbabb..ddc71705b23a 100644
--- a/app-crypt/yubioath-desktop/Manifest
+++ b/app-crypt/yubioath-desktop/Manifest
@@ -1,3 +1,5 @@
DIST yubioath-desktop-5.0.5.tar.gz 5659179 BLAKE2B 31dd1a7e9b8a5034e916f38c7893572b6b7e75fa0bc45b5b807c89010ac0e4a01a446f03d1591dd6323a015fc8fb17861fa60dc5a5e4eff40b5261fb6e3f7088 SHA512 b5a0df306916896e1fd84d6a794a43365b0e0a2cecd97ec1dacc6312507dd2e4dd55fc12b0de9d72d1d0a1b40625330373b7c74dacb2ec37a24ea3e1fd2d4ff7
+DIST yubioath-desktop-5.1.0.tar.gz 6322224 BLAKE2B e1fc93bd38af3c6937f390c738248e43dbd17052df5103a0e25547adf7b34eca60ed8b45c9681568202d01802a5d8503cf2a5bf53d57c7c18ee2ee53cecd8d51 SHA512 152e27fca3c082c996c96fb05ed66781a52a47f30d8c5649d43937cf87c566f09c1fcb6afd65402b5f7fbe2a1f71872f10c8b456bd8a9b240c360018defd48c9
EBUILD yubioath-desktop-5.0.5.ebuild 1292 BLAKE2B 8cfc49d3f1068ebc2c730ae1b2ea0c38a1272f3f81e361ea8c3fcd1b500988776f99a82e9bb9b91d5025f368a37001e3e498f90360d1d66d8d8dbda9acf1bb91 SHA512 ee8a4a17140221e486d85f392499f8f41ecdda7c9f0d747fa10d33cb8e51e9497f7caa632cdbd601a6e445e8886d960f586af7e6eff563671ceafb27607c4d5f
+EBUILD yubioath-desktop-5.1.0.ebuild 1338 BLAKE2B 5ab32f86942969f53800512509a39a6cb6365a0977ed156f46968c9466cefb7eb17848a1be91164c20855a813225d30757376b969bc283414f9337528cb834ef SHA512 2108ce8fa01982c7199ca33c2668c313e4ee703d06f8c32fb6ecd5465ff5a8a6772c5921da8fc4aac11078271e19c522a156d746fa9404e47d6212c6cf3c0f73
MISC metadata.xml 351 BLAKE2B ab6920491637edc42b25934202cf24529718ef72b907364a09939a6c73b2667872698da96534a624db98ac33bb9c7933413067c9eb0ff79563e289e73aa4587a SHA512 ce8b9a953eb1d0c88eb2b6dcc54a28e7e6df5ca3f9dada0619ea7d10ae4d2d5ac0717b7a0158331475c5e7cbeb576ed9ae177941892549be687c17340f3af88f
diff --git a/app-crypt/yubioath-desktop/yubioath-desktop-5.1.0.ebuild b/app-crypt/yubioath-desktop/yubioath-desktop-5.1.0.ebuild
new file mode 100644
index 000000000000..e2f85896c574
--- /dev/null
+++ b/app-crypt/yubioath-desktop/yubioath-desktop-5.1.0.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit desktop python-single-r1 qmake-utils xdg
+
+DESCRIPTION="Library and tool for personalization of Yubico's YubiKey NEO"
+HOMEPAGE="
+ https://developers.yubico.com/yubioath-desktop/
+ https://github.com/Yubico/yubioath-desktop"
+SRC_URI="https://github.com/Yubico/yubioath-desktop/archive/${P}.tar.gz"
+S="${WORKDIR}/${PN}-${P}"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="
+ ${PYTHON_DEPS}
+ dev-qt/qtconcurrent:5
+ dev-qt/qtcore:5
+ dev-qt/qtquickcontrols2:5
+ dev-qt/qtdeclarative:5
+ dev-qt/qtmultimedia:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtgui:5
+ dev-qt/qtnetwork:5
+ x11-libs/libdrm"
+RDEPEND="${DEPEND}
+ $(python_gen_cond_dep '>=app-crypt/yubikey-manager-4.0.0[${PYTHON_USEDEP}]')
+ dev-python/pyotherside[${PYTHON_SINGLE_USEDEP}]"
+
+src_prepare() {
+ default
+ sed -i \
+ -e "s:python build_qrc.py:${PYTHON} build_qrc.py:" \
+ yubioath-desktop.pro || die
+
+ python_fix_shebang "${S}"
+}
+
+src_configure() {
+ eqmake5 yubioath-desktop.pro
+}
+
+src_install() {
+ emake INSTALL_ROOT="${D}" install
+
+ domenu resources/com.yubico.yubioath.desktop
+ doicon resources/icons/com.yubico.yubioath.png
+ doicon -s scalable resources/icons/com.yubico.yubioath.svg
+}