summaryrefslogtreecommitdiff
path: root/app-crypt/yubikey-manager
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-02-17 01:16:38 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-02-17 01:16:38 +0000
commit53cba99042fa967e2a93da9f8db806fe2d035543 (patch)
tree9780d3b87dfc6bdebc6b7b7d15af1ecb813c6853 /app-crypt/yubikey-manager
parent71deace00d1a2b091313fe137ab7092418c6f87c (diff)
gentoo resync : 17.02.2020
Diffstat (limited to 'app-crypt/yubikey-manager')
-rw-r--r--app-crypt/yubikey-manager/Manifest2
-rw-r--r--app-crypt/yubikey-manager/yubikey-manager-3.1.1.ebuild63
2 files changed, 65 insertions, 0 deletions
diff --git a/app-crypt/yubikey-manager/Manifest b/app-crypt/yubikey-manager/Manifest
index 73adcc5c0743..1cae98855174 100644
--- a/app-crypt/yubikey-manager/Manifest
+++ b/app-crypt/yubikey-manager/Manifest
@@ -1,3 +1,5 @@
DIST yubikey-manager-3.1.0.tar.gz 115010 BLAKE2B 1b27b9af7f3adac87a1bca58929bffef2ae397b359f70580a07193d2bd2f8cd4d2d867053f6494f1e262668443388d79dfe3775f2c3d0a5528840df8826cdf91 SHA512 518eedb52cfcf725c13114c433f848b97f711e94fa9c71685916fb8cb20e5bfc431f648b0ec710ef9ebed2bc8ddd8722ca1c9865d7a1b29537b719e167ed5f60
+DIST yubikey-manager-3.1.1.tar.gz 116632 BLAKE2B 252c419280143fa6f44daf3de8ec27bbdc3218e4552e39799e1daca5b46939c4042ae1d43abeab110fe1abaf2e87d94c270442ee6fce05e26927add5b34e9f66 SHA512 8229d5442ddf89fe90abb0153aa005cb0d149a84634b994dc283f7cbac2f72d4b913c238c277c6aa07f431aed8905008aeb11e594e730be71c9ca88150a6ef68
EBUILD yubikey-manager-3.1.0-r1.ebuild 1599 BLAKE2B 0a737c8dcffadb01fa75041b4341fafbd4e82615a04841def05ea42c0ff275e2aca6b23adbf17c8c5f839ecfe0d4f6383e1e90b7a60f79bb89252c89ecf4c44d SHA512 fcd0fbe3d09128a9e7360371171407bf732a22eccb8216077052f5184820bb4badfe6f0682fd9259257fda5b0f455f34c5c129c18073cce713ad2f094cc9e855
+EBUILD yubikey-manager-3.1.1.ebuild 1601 BLAKE2B f1e8d4d55b6365b00bc1acddfc4eceae2fc018962eabdbee15795ce2ef4cbac6bcae462a19631c8fcc68966b323f985104dd6f1a3e5221319190ac57e7852aff SHA512 e0e4b0c4c5f38f90e478cdd3216b5f60b092b10a73e5625d2cf29bcf1935c8a1e3c8db0359635a4356683e4c483097c859a727afde5638bd8fa0e7ce99f481da
MISC metadata.xml 466 BLAKE2B 258688bf55e0d7d5d13a45996c2177d2154626a75ffd0c5b39cbc5c3f83979a00ec1d9a993870c00785d0e1d02cdeb1dadfa38f39d91b5992c5b495f644c6253 SHA512 6355c94235c5a7a9dbe37fb954d7de5807bbd48d62921f819da7ac1c56f0214820cbf74b2f91311573f8a1726b05960d944b536fbf0e0f27fe49a5aa0a827e1b
diff --git a/app-crypt/yubikey-manager/yubikey-manager-3.1.1.ebuild b/app-crypt/yubikey-manager/yubikey-manager-3.1.1.ebuild
new file mode 100644
index 000000000000..c510503999b1
--- /dev/null
+++ b/app-crypt/yubikey-manager/yubikey-manager-3.1.1.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python3_6 )
+inherit readme.gentoo-r1 distutils-r1
+
+DESCRIPTION="Python library and command line tool for configuring a YubiKey"
+HOMEPAGE="https://developers.yubico.com/yubikey-manager/"
+# Per https://github.com/Yubico/yubikey-manager/issues/217, Yubico is
+# the official source for tarballs, not Github
+SRC_URI="https://developers.yubico.com/${PN}/Releases/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-python/click[${PYTHON_USEDEP}]
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/enum34[${PYTHON_USEDEP}]' python2_7)
+ >=dev-python/fido2-0.7.0[${PYTHON_USEDEP}]
+ <dev-python/fido2-0.8.0[${PYTHON_USEDEP}]
+ dev-python/pyopenssl[${PYTHON_USEDEP}]
+ dev-python/pyscard[${PYTHON_USEDEP}]
+ dev-python/pyusb[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ >=sys-auth/ykpers-1.19.0
+"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ ${RDEPEND}
+ $(python_gen_cond_dep 'dev-python/mock[${PYTHON_USEDEP}]' 'python2_7')
+ )
+"
+
+python_test() {
+ esetup.py test
+}
+
+python_install_all() {
+ local DOC_CONTENTS
+
+ distutils-r1_python_install_all
+
+ DOC_CONTENTS="
+ The 'openpgp' command may require the package 'app-crypt/ccid'
+ to be installed on the system. Furthermore, make sure that pcscd
+ daemon is running and has correct access permissions to USB
+ devices.
+ "
+ readme.gentoo_create_doc
+
+ doman "${S}"/man/ykman.1
+}
+
+pkg_postinst() {
+ readme.gentoo_print_elog
+}