summaryrefslogtreecommitdiff
path: root/app-crypt/yubikey-manager-qt
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-05-22 07:31:18 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-05-22 07:31:18 +0100
commit908778078736bd36f7a60a2d576d415cb8e000fa (patch)
treec6a4796c48b608c14dc7e9674cdbd38f905e3c15 /app-crypt/yubikey-manager-qt
parent185fa19bbf68a4d4dca534d2b46729207a177f16 (diff)
gentoo resync : 22.05.2021
Diffstat (limited to 'app-crypt/yubikey-manager-qt')
-rw-r--r--app-crypt/yubikey-manager-qt/Manifest2
-rw-r--r--app-crypt/yubikey-manager-qt/yubikey-manager-qt-1.2.2.ebuild58
2 files changed, 60 insertions, 0 deletions
diff --git a/app-crypt/yubikey-manager-qt/Manifest b/app-crypt/yubikey-manager-qt/Manifest
index 3106663b79ed..be12f10bf46d 100644
--- a/app-crypt/yubikey-manager-qt/Manifest
+++ b/app-crypt/yubikey-manager-qt/Manifest
@@ -1,3 +1,5 @@
DIST yubikey-manager-qt-1.1.5.tar.gz 16066508 BLAKE2B cd15950c68cacc3e2904a5e1fbb3a2d98544084717f379202ccfe70082b0971959178730afb9ddbbfa20f436ef8d7cdf820df1e88539f99ce77913f60228af0f SHA512 b019a7cdebd741cd536a18670795f83c7e010e221b4f9c82dcd3c57b0c4bce878865c6605f10c962f4bd5e926c285a894ea97d2925ba091847ece5ffa7ce5bb6
+DIST yubikey-manager-qt-1.2.2.tar.gz 17311287 BLAKE2B 115dbf18ce0bfd48a1b172153d9770a3bde754b1dbef55ee1ec9480128305b9fb0d52af23906a6f6040df71cc4d3d4be216615fc3807395f7e7be1615a5568da SHA512 dbac2d51b198ab15051790e080ad92aaef4b0d44596ad136115469e7bf038d6b56d1bfa78a69d1fda3644543f9762051767b8a1fd46a80f2f62ecf836f7df3d8
EBUILD yubikey-manager-qt-1.1.5.ebuild 1482 BLAKE2B ef6a4e9604b3b7d9f86e019b9a1cce9c93259fd4b4e2332dca7ebc64d6a4dc9c0228c31584fd4b0e5346bf21b02846f1156e31b3d2ff344e883997abbf314e08 SHA512 c6d558b98f125fbeeccf0ffd3553b7a36f90956558b9b14c5842519b97dc4f14083e84dc05222d602ea101106cad515228b8f3e82075d2a00740379d9b12a98c
+EBUILD yubikey-manager-qt-1.2.2.ebuild 1418 BLAKE2B 239b5e71f825e75280e157648b95350e433a56d69c58e50e0e5687ecd9a33b995ac9ad45e1f0aedc07c22b66d3f8ca4c553ed56826d92e278a4a6076f9b909d8 SHA512 a4371ee94e1b4cf5272c88a6dc0ffdad3ec347458501b15e32b93b95bd840af4c29004452cd039917e5698f947f92c0aeb9872c61caf66b88376bc4767da22aa
MISC metadata.xml 371 BLAKE2B 1081e69aeb641c9d7de472bed98dfb336bc37e5374becbec4603316176419dcdb337f29b355b3395b778d250a99e32b181b84b42d4b7c10dedce7c47a6a187f6 SHA512 ed480648e967bfa3d95f71a5131963290e4265c487a345b69e34ad23c4ab18d82b08cd1e4a12f389533cc9690163fed90c05d471375fadd074c99a235105e837
diff --git a/app-crypt/yubikey-manager-qt/yubikey-manager-qt-1.2.2.ebuild b/app-crypt/yubikey-manager-qt/yubikey-manager-qt-1.2.2.ebuild
new file mode 100644
index 000000000000..2e4e7d2727c9
--- /dev/null
+++ b/app-crypt/yubikey-manager-qt/yubikey-manager-qt-1.2.2.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7,8,9} )
+
+inherit qmake-utils python-single-r1 desktop
+
+DESCRIPTION="Cross-platform application for configuring any YubiKey over all USB transports"
+HOMEPAGE="https://developers.yubico.com/yubikey-manager-qt https://github.com/Yubico/yubikey-manager-qt"
+SRC_URI="https://developers.yubico.com/${PN}/Releases/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64"
+REQUIRED_USE=${PYTHON_REQUIRED_USE}
+
+DEPEND="${PYTHON_DEPS}
+ $(python_gen_cond_dep '
+ >=app-crypt/yubikey-manager-4.0.0[${PYTHON_MULTI_USEDEP}]
+ dev-python/cryptography[${PYTHON_MULTI_USEDEP}]
+ ')
+ dev-python/pyotherside[${PYTHON_SINGLE_USEDEP}]
+ dev-qt/qtcore:5
+ dev-qt/qtdeclarative:5
+ dev-qt/qtgraphicaleffects:5
+ dev-qt/qtgui:5
+ dev-qt/qtquickcontrols:5[widgets]
+ dev-qt/qtquickcontrols2:5[widgets]
+ dev-qt/qtsingleapplication[qt5(+),X]
+ dev-qt/qtsvg:5
+ dev-qt/qtwidgets:5"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${PN}"
+
+src_prepare() {
+ default
+
+ sed -i -e "s/ykman-cli//" ${PN}.pro || die
+ sed -e "/CONFIG += c++11/a CONFIG += qtsingleapplication" \
+ -i ykman-gui/ykman-gui.pro || die
+}
+
+src_configure() {
+ eqmake5
+}
+
+src_install() {
+ emake install INSTALL_ROOT="${D}"
+
+ domenu resources/ykman-gui.desktop
+ doicon -s 128 resources/icons/ykman.png
+ doicon -s scalable resources/icons/ykman.svg
+
+ einstalldocs
+}