summaryrefslogtreecommitdiff
path: root/app-crypt/yubihsm-connector
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-04-11 23:39:55 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-04-11 23:39:55 +0100
commit7d040c2d1b0c38c8635ec28dfaa632a2db8be895 (patch)
tree78e9474cad949bcd1254749d61f4f6b9e7d488bf /app-crypt/yubihsm-connector
parent0d39cf7bd8aae36b5d8eb4272a42dc6919216e34 (diff)
gentoo auto-resync : 11:04:2023 - 23:39:54
Diffstat (limited to 'app-crypt/yubihsm-connector')
-rw-r--r--app-crypt/yubihsm-connector/Manifest4
-rw-r--r--app-crypt/yubihsm-connector/metadata.xml11
-rw-r--r--app-crypt/yubihsm-connector/yubihsm-connector-3.0.4.ebuild49
3 files changed, 64 insertions, 0 deletions
diff --git a/app-crypt/yubihsm-connector/Manifest b/app-crypt/yubihsm-connector/Manifest
new file mode 100644
index 000000000000..53dfab85cdc2
--- /dev/null
+++ b/app-crypt/yubihsm-connector/Manifest
@@ -0,0 +1,4 @@
+DIST yubihsm-connector-3.0.4-vendor.tar.xz 972044 BLAKE2B cae22a6a581689663460980ff12ab3055547967881e6cac68a65c43c33fbb76116b50b9646e7fdebebd8d68cdb2e506a1a99634c09bc4981554d3d8cd1b4d186 SHA512 accc9934c81321019e140c71e92e4382a1525c797df52243cf76be1f338e873ce0fac54439dbeb9acb5b57dd6a1dee8ab433d35d23ad5b0e53f5d8c490ad2bcc
+DIST yubihsm-connector-3.0.4.tar.gz 38522 BLAKE2B 51efcecfad9e4276f05ead81b1ce1646396f99b89046a14daaac4c1d41b6a88306934291070842507f616dc90ce9e61d0c99a424d7c4291fa3f2610cdb16f619 SHA512 cdd56bb95061e5e45ecbbc2f46b4e669d2b2faa57b2b9484646161fc332ab7f46fd4c3825d0e075397f39634fad94870a646ca8f93368197da7dd379f000abf0
+EBUILD yubihsm-connector-3.0.4.ebuild 882 BLAKE2B a0ebe89650634992d2aab8bfd248c93f9a0c9195edaae10c266a4ca4dead936d3d83c3819387f83294007fb18473859e7b406f7d38f1be7be46f244cbe238926 SHA512 bece3f9b18551a627ce3bb3c9d359b8924e4b80627615f29e39612e4cb73bf84c6281960da92ad3790baae593b4af710481101fb4947a0cfe2c0723143798181
+MISC metadata.xml 340 BLAKE2B f44a791d47cdcdd1ba97a7ca7adcfb248cda7b100994d485f98932c4f79c71b7c70045a93e951804a815d59ed659c3d50a39bb66d9b272c1753bea3c795f04c3 SHA512 68887229c457feec279441065cc9926668bc7f17e7f75c3cd1132de0c46477f0adb8cd384b8f553040fc7ff0ecd300130fa1a1c2dd2fcf98b8059c3942da9fc7
diff --git a/app-crypt/yubihsm-connector/metadata.xml b/app-crypt/yubihsm-connector/metadata.xml
new file mode 100644
index 000000000000..2d2ca25e4c70
--- /dev/null
+++ b/app-crypt/yubihsm-connector/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>zx2c4@gentoo.org</email>
+ <name>Jason A. Donenfeld</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">Yubico/yubihsm-connector</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-crypt/yubihsm-connector/yubihsm-connector-3.0.4.ebuild b/app-crypt/yubihsm-connector/yubihsm-connector-3.0.4.ebuild
new file mode 100644
index 000000000000..2eb8fd785e8a
--- /dev/null
+++ b/app-crypt/yubihsm-connector/yubihsm-connector-3.0.4.ebuild
@@ -0,0 +1,49 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit go-module systemd udev
+
+DESCRIPTION="Server to expose YubiHSM 2 to network"
+HOMEPAGE="https://developers.yubico.com/yubihsm-connector/"
+SRC_URI="
+ https://developers.yubico.com/${PN}/Releases/${P}.tar.gz
+ https://dev.gentoo.org/~zx2c4/distfiles/${P}-vendor.tar.xz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+RESTRICT="test"
+
+DEPEND=""
+RDEPEND="
+ virtual/libusb:1
+ virtual/udev
+ acct-user/yubihsm-connector
+ acct-group/yubihsm-connector
+"
+BDEPEND=""
+
+src_compile() {
+ ego generate
+ ego build ${GOFLAGS}
+}
+
+src_install() {
+ dobin yubihsm-connector
+ systemd_dounit deb/yubihsm-connector.service
+ udev_dorules deb/70-yubihsm-connector.rules
+ insinto /etc
+ doins deb/yubihsm-connector.yaml
+}
+
+pkg_postinst() {
+ udev_reload
+}
+
+pkg_postrm() {
+ udev_reload
+}