summaryrefslogtreecommitdiff
path: root/app-crypt/xor-analyze
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-crypt/xor-analyze
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-crypt/xor-analyze')
-rw-r--r--app-crypt/xor-analyze/Manifest3
-rw-r--r--app-crypt/xor-analyze/metadata.xml5
-rw-r--r--app-crypt/xor-analyze/xor-analyze-0.5-r1.ebuild26
3 files changed, 34 insertions, 0 deletions
diff --git a/app-crypt/xor-analyze/Manifest b/app-crypt/xor-analyze/Manifest
new file mode 100644
index 000000000000..e1c3420f870d
--- /dev/null
+++ b/app-crypt/xor-analyze/Manifest
@@ -0,0 +1,3 @@
+DIST xor-analyze-0.5.tar.gz 26635 BLAKE2B ad5134b50366cdfb4af31d1944cc4c02c43b2bac171b20054fd7960e62a96b3b959f5b973ab82076ca8cdb0ae7068c0917f89c581936e16723c0223ac64d78a0 SHA512 e28aef799dc6f64a57609638f578bbe66c3ced5784599a65be6bf4ee14921600b7d292880f1288b5ad81ed3dd0897b6aeff2d741b96efc30cf0eab453e4b21b1
+EBUILD xor-analyze-0.5-r1.ebuild 614 BLAKE2B 7122073e7238af80bd7469a9df8e9d0ee7ebb896688b7f1d5ec5cdc94c6886b2611cd1eefef0be7ca04379b89cfb0e4948cb1e143f81e477400d81c0e3017a4c SHA512 2077ae200122f2c1e2d3ecadaaa9053e2fcf43efba003d3ad48e7b6612d98bfbcec2980c86098f12878bf93e11a156b8be482b78f92fd6310defb8e6a90aba76
+MISC metadata.xml 166 BLAKE2B c254f1fb642881aba57637be14fb0a89b10384f91a128feaec3a8c870d76efc2cbacb92caccc0dee2dd19a5ac5eaf8643080dafa05c4e2ac96a68568927e5afd SHA512 a56648c974a1d14dd4c18237532773c72057a13ab90c58b5da04f185e3c12a8bd8d5c21fb06053507f31766291a82dc7d87b34cd65fd94cfe2af7295c813ef84
diff --git a/app-crypt/xor-analyze/metadata.xml b/app-crypt/xor-analyze/metadata.xml
new file mode 100644
index 000000000000..6f49eba8f496
--- /dev/null
+++ b/app-crypt/xor-analyze/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<!-- maintainer-needed -->
+</pkgmetadata>
diff --git a/app-crypt/xor-analyze/xor-analyze-0.5-r1.ebuild b/app-crypt/xor-analyze/xor-analyze-0.5-r1.ebuild
new file mode 100644
index 000000000000..07b15f1f1e7e
--- /dev/null
+++ b/app-crypt/xor-analyze/xor-analyze-0.5-r1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit toolchain-funcs
+
+DESCRIPTION="program for cryptanalyzing xor 'encryption' with variable key length"
+HOMEPAGE="http://www.habets.pp.se/synscan/programs.php?prog=xor-analyze"
+SRC_URI="http://www.habets.pp.se/synscan/files/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+src_compile() {
+ rm -f Makefile || die
+ emake CC="$(tc-getCC)" CXX="$(tc-getCXX)" xor-analyze xor-enc
+}
+
+src_install() {
+ dobin xor-analyze xor-enc
+ dosym xor-enc /usr/bin/xor-dec
+ dodoc README TODO
+}