summaryrefslogtreecommitdiff
path: root/app-crypt/xca
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-crypt/xca
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-crypt/xca')
-rw-r--r--app-crypt/xca/Manifest4
-rw-r--r--app-crypt/xca/files/xca-1.0.0-desktop.patch8
-rw-r--r--app-crypt/xca/metadata.xml11
-rw-r--r--app-crypt/xca/xca-1.4.1.ebuild59
4 files changed, 82 insertions, 0 deletions
diff --git a/app-crypt/xca/Manifest b/app-crypt/xca/Manifest
new file mode 100644
index 000000000000..644facf944cf
--- /dev/null
+++ b/app-crypt/xca/Manifest
@@ -0,0 +1,4 @@
+AUX xca-1.0.0-desktop.patch 391 BLAKE2B 1cbec5681df8da9230b783c8ea048a199bd31a38fce6781dcd86b926e03b245de05b148d8df9034f5c7470dcf5823bd4a080cbb011a1a32fc0b96d8a8a5d950d SHA512 5dd62d8d2f4485b6155e466bb9a012f44104ff36c97bae61e8155880b937fc1271e94fb5b83627bd828e3cde0ab421a150458d050cb512d633d1c5c97f80f163
+DIST xca-1.4.1.tar.gz 959107 BLAKE2B 7437cdbaa5277998de200e9a5ad3a7d44aed9ae8af8fd926d7ed1917d49bec79562455ca2e82557149d748840f299ffd66edfc7f265be7d5bdcd6e4fe8dbaf9b SHA512 8294669c4887ba7a9060c3c2c06014b8a1807898569842ed61c066e8a864de014fba51a2ff867b579048083fdd4934cc7f97c92268de4944bf4aafea9c2e7b42
+EBUILD xca-1.4.1.ebuild 1180 BLAKE2B f865e4def8314ca7effeb87b6a38c30a3ce2a5f96fff87fc25280459e1224bdfce0623a5d3f6e21b435ba0c2dc0abe1e69e34e2c085b7a10d082d884ef9d33a2 SHA512 35e94c1323c4664cca88e396a45a6d06c50d98535349d28311edd774907aaa5d7815b93018d9ac6872815e39b763652188a953d4d8865b5f8197a5192fd8e693
+MISC metadata.xml 313 BLAKE2B 6e1376d870ee5ab083ed80dcc19c1acd60d487e285e9bdba7b92c13e97cb05a3a6fa8bc4c6107d5d54470e6ca93889fca15c1a2f7e690a169ca7aff64bd2499e SHA512 ebc38746afd94878384ef0e4d7933e2a7433216716b1854cfc0227c3f0abf0847d784d36de4b04a778743e442298abd3769329deecdc771003681ecd3dbf3fa1
diff --git a/app-crypt/xca/files/xca-1.0.0-desktop.patch b/app-crypt/xca/files/xca-1.0.0-desktop.patch
new file mode 100644
index 000000000000..e2da3a103cf8
--- /dev/null
+++ b/app-crypt/xca/files/xca-1.0.0-desktop.patch
@@ -0,0 +1,8 @@
+--- a/misc/xca.desktop 2012-05-12 05:37:14.000000000 -0400
++++ b/misc/xca.desktop 2013-01-03 19:43:35.877856711 -0500
+@@ -7,5 +7,5 @@
+ Icon=xca-32x32
+ Terminal=false
+-Categories=Application;Utility;Qt;
++Categories=Utility;Qt;
+ MimeType=application/x-xca-database;application/x-xca-template;application/x-x509-ca-cert;application/pkcs10;application/x-pkcs7-certificates;application/x-pkcs12;
diff --git a/app-crypt/xca/metadata.xml b/app-crypt/xca/metadata.xml
new file mode 100644
index 000000000000..27fe33dd45b0
--- /dev/null
+++ b/app-crypt/xca/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>crypto@gentoo.org</email>
+ <name>Crypto</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="sourceforge">xca</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-crypt/xca/xca-1.4.1.ebuild b/app-crypt/xca/xca-1.4.1.ebuild
new file mode 100644
index 000000000000..06f30c351d9c
--- /dev/null
+++ b/app-crypt/xca/xca-1.4.1.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit xdg-utils
+
+DESCRIPTION="A GUI to OpenSSL, RSA public keys, certificates, signing requests etc"
+HOMEPAGE="http://hohnstaedt.de/xca/"
+SRC_URI="https://github.com/chris2511/${PN}/releases/download/RELEASE.${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 ppc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE="bindist doc libressl"
+
+RDEPEND="
+ dev-libs/libltdl:0=
+ dev-qt/qtgui:5
+ dev-qt/qtwidgets:5
+ !libressl? ( dev-libs/openssl:0=[bindist=] )
+ libressl? ( dev-libs/libressl:0= )
+ doc? ( app-text/linuxdoc-tools )"
+DEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-1.0.0-desktop.patch"
+)
+
+src_configure() {
+ econf \
+ --with-qt-version=5 \
+ $(use_enable doc) \
+ STRIP=true
+}
+
+src_compile() {
+ # enforce all to avoid the automatic silent rules
+ emake all
+}
+
+src_install() {
+ # non standard destdir
+ emake install destdir="${ED}"
+ einstalldocs
+
+ insinto /etc/xca
+ doins misc/*.txt
+}
+
+pkg_postinst() {
+ xdg_desktop_database_update
+ xdg_mimeinfo_database_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+ xdg_mimeinfo_database_update
+}