summaryrefslogtreecommitdiff
path: root/app-crypt/xca
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-04-12 03:41:30 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-04-12 03:41:30 +0100
commit623ee73d661e5ed8475cb264511f683407d87365 (patch)
tree993eb27c93ec7a2d2d19550300d888fc1fed9e69 /app-crypt/xca
parentceeeb463cc1eef97fd62eaee8bf2196ba04bc384 (diff)
gentoo Easter resync : 12.04.2020
Diffstat (limited to 'app-crypt/xca')
-rw-r--r--app-crypt/xca/Manifest2
-rw-r--r--app-crypt/xca/xca-2.2.1.ebuild65
2 files changed, 67 insertions, 0 deletions
diff --git a/app-crypt/xca/Manifest b/app-crypt/xca/Manifest
index 5142e810ddcc..7e509447f486 100644
--- a/app-crypt/xca/Manifest
+++ b/app-crypt/xca/Manifest
@@ -1,4 +1,6 @@
AUX xca-1.0.0-desktop.patch 391 BLAKE2B 1cbec5681df8da9230b783c8ea048a199bd31a38fce6781dcd86b926e03b245de05b148d8df9034f5c7470dcf5823bd4a080cbb011a1a32fc0b96d8a8a5d950d SHA512 5dd62d8d2f4485b6155e466bb9a012f44104ff36c97bae61e8155880b937fc1271e94fb5b83627bd828e3cde0ab421a150458d050cb512d633d1c5c97f80f163
DIST xca-2.1.2.tar.gz 1086563 BLAKE2B d48727fffad16d840633af6e0ee38a279978a5b865eb6f391a3d852a0105817254ea0a4780875f2956e1f7e9931e6930c6ffbe82b117dbf8ad0058ec9d6f5c88 SHA512 1f104a22b83b802576b4820b7139971da50f9b3dd70aca8e1199e996bad4379b8681bb31b197b84a3dfa49cef4ae093f6622d15fac9667547ff47af43c1e5f07
+DIST xca-2.2.1.tar.gz 1339412 BLAKE2B 5d3e33a711919d85bc3457ddd596f2272f0136d96290aeb31e6d03ea86faff00be3590862e4c96d9214542db1bd536d0d22c6c04cd5071b253bbefe3ab3f4f56 SHA512 90eaf4a859779d57a4c0201dc403d67e005bd540145b9f543e13b8d5c42199f2ea05543de24b071d19a0db8e5b1e9f3bef2aea4bfe9f71f81007a5f5bb3ba406
EBUILD xca-2.1.2.ebuild 1455 BLAKE2B 1aea6cd367a144b64aba3439204e81d2afdbac0e506596eeb02731b439c4b4812a6e3b572f2b974a881a3765832edda9a87301eb593d7c1f569543425d55ffc9 SHA512 d3156e68bd839e5d332190389605759db233c00cb70485b2f8238b4c684473836e817f0af8da44c87d9ff6b736ac6464479b2216572594a5eb7a53881ceab5a2
+EBUILD xca-2.2.1.ebuild 1455 BLAKE2B dd8fac4045b49c7521b5df82c966506aef2824a9233b4f1c06e0b99001a1d81e2ef23f1b2c5355f70d9aec237cc44f08425121c926f14f9dae8f2e0b0850d9d9 SHA512 36d5f5d6461a04fed506053de5d2a64b5f5f108d0a4f71ec833e42c06b3a9cb38598c4f794fdb9b7994f7901e7c75f975b17e2ef68c32bb6b2094dd4acc75b09
MISC metadata.xml 350 BLAKE2B 825e045b03a40c1b9a3c5af631d1748532ad4c84e83d0efd1d4866c5cc1284afab67f1e3e00a2c31a376a19d4e4608404a5830ab1a8a738079a3b6128f5c9bad SHA512 fd4e95bcd679b22bdfa620896e81e0a63bc6f084c60bf42caa853f9dcef2c797ff640801f206caceb6969ee4e347492200b37af4920c50c9764a3bac48910cf3
diff --git a/app-crypt/xca/xca-2.2.1.ebuild b/app-crypt/xca/xca-2.2.1.ebuild
new file mode 100644
index 000000000000..e8d94c254cf3
--- /dev/null
+++ b/app-crypt/xca/xca-2.2.1.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+inherit xdg-utils
+
+DESCRIPTION="A GUI to OpenSSL, RSA public keys, certificates, signing requests etc"
+HOMEPAGE="https://hohnstaedt.de/xca/"
+SRC_URI="https://github.com/chris2511/${PN}/releases/download/RELEASE.${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE="bindist doc libressl"
+
+RDEPEND="
+ dev-libs/libltdl:0=
+ dev-qt/qtgui:5
+ dev-qt/qtsql:5[sqlite]
+ dev-qt/qtwidgets:5
+ !libressl? ( dev-libs/openssl:0=[bindist=] )
+ libressl? ( >=dev-libs/libressl-2.7.0:0= )
+ doc? ( app-text/linuxdoc-tools )"
+DEPEND="${RDEPEND}
+ dev-qt/linguist-tools:5"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-1.0.0-desktop.patch"
+)
+
+src_configure() {
+ econf \
+ --with-qt-version=5 \
+ $(use_enable doc) \
+ STRIP=true
+}
+
+src_compile() {
+ # enforce all to avoid the automatic silent rules
+ emake all
+}
+
+src_install() {
+ # non standard destdir
+ emake install destdir="${ED}"
+ einstalldocs
+
+ insinto /etc/xca
+ doins misc/*.txt
+
+ ewarn "Make a backup copy of your database!"
+ ewarn "Version 2 completely changes the database format to SQL(ite)"
+ ewarn "Don't try to open it with older versions of XCA (< 1.4.0). They will corrupt the database."
+}
+
+pkg_postinst() {
+ xdg_desktop_database_update
+ xdg_mimeinfo_database_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+ xdg_mimeinfo_database_update
+}