summaryrefslogtreecommitdiff
path: root/app-crypt/tpm2-tools
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-12-31 13:43:35 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-12-31 13:43:35 +0000
commit2891d29af8907ce881662f4a02844926d7a293c7 (patch)
tree56979d96839d0827aa52008b81b746b4934d88df /app-crypt/tpm2-tools
parentde49812990871e1705b64051c35161d5e6400269 (diff)
gentoo resync : 31.12.2018
Diffstat (limited to 'app-crypt/tpm2-tools')
-rw-r--r--app-crypt/tpm2-tools/Manifest3
-rw-r--r--app-crypt/tpm2-tools/metadata.xml11
-rw-r--r--app-crypt/tpm2-tools/tpm2-tools-3.1.3.ebuild27
3 files changed, 41 insertions, 0 deletions
diff --git a/app-crypt/tpm2-tools/Manifest b/app-crypt/tpm2-tools/Manifest
new file mode 100644
index 000000000000..4bd9b9b41eab
--- /dev/null
+++ b/app-crypt/tpm2-tools/Manifest
@@ -0,0 +1,3 @@
+DIST tpm2-tools-3.1.3.tar.gz 544098 BLAKE2B 4c22ae98ed444b7d5b5f99e6a7d4cc37fcf9d46979669a2225b6f2abf8ccaaff203ccc8c816169be215c6160ce2480e4c9a0197040764013ab362dd060c29bec SHA512 37edf59e47168c42ffc66e948722753334ae3e00f3e258d9e801dffd259a763a1bf4f63b3feecf7728b4dade69ca5da15d631e1a606f68e10f7d314a1a757bdc
+EBUILD tpm2-tools-3.1.3.ebuild 634 BLAKE2B 7a79635d19aee0774d05675b1cd793b08696948405c04de215e9778ea3706be681d9d968a16d2c6e07e3e487f08afbd301e86083633415e4a7c96a661bbd4a81 SHA512 f7d0d985ffcb2d66c1eae57673028643941270660a5aa05864626ca503a37365c4fa0dedb41a206184211c45b5a961813c974dcea2c86c9f4b5f41d461cf8311
+MISC metadata.xml 329 BLAKE2B 4839966acc6a4c84deaf050a21adaa680d3a93e5cb17ecff79dd6818723264570b215796e9733ef9beb078b17977078bad12deb6716ee3774947502e8efbbd78 SHA512 49d92ff1f240ce29957166befc9af7af18e665a388943f81c5a3c11c6dd12a924b19ed8dfaf2656223028444bfafa63fb15a54ad6c51e7c37b55ff1fe7287912
diff --git a/app-crypt/tpm2-tools/metadata.xml b/app-crypt/tpm2-tools/metadata.xml
new file mode 100644
index 000000000000..a1035736860b
--- /dev/null
+++ b/app-crypt/tpm2-tools/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>crypto@gentoo.org</email>
+ <name>Crypto</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">tpm2-software/tpm2-tools</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-crypt/tpm2-tools/tpm2-tools-3.1.3.ebuild b/app-crypt/tpm2-tools/tpm2-tools-3.1.3.ebuild
new file mode 100644
index 000000000000..a23c0b4d9a6a
--- /dev/null
+++ b/app-crypt/tpm2-tools/tpm2-tools-3.1.3.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Tools for the TPM 2.0 TSS"
+HOMEPAGE="https://github.com/tpm2-software/tpm2-tools"
+SRC_URI="https://github.com/tpm2-software/${PN}/releases/download/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="libressl test"
+
+RDEPEND=">=app-crypt/tpm2-tss-2.0
+ net-misc/curl
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )"
+DEPEND="${RDEPEND}
+ test? ( dev-util/cmocka )"
+BDEPEND="virtual/pkgconfig"
+
+src_configure() {
+ econf \
+ --disable-hardening \
+ $(use_enable test unit)
+}