summaryrefslogtreecommitdiff
path: root/app-crypt/tpm2-tools/tpm2-tools-5.4.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-02-16 08:04:03 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-02-16 08:04:03 +0000
commit97f40b36b1afa9726e32962d11f3ac2d0bc5792e (patch)
tree1c7d586bc8a53d3b768630527bb80a477d661fa3 /app-crypt/tpm2-tools/tpm2-tools-5.4.ebuild
parentb435e036d9775b71048373b91d4c7c3398826858 (diff)
gentoo auto-resync : 16:02:2023 - 08:04:02
Diffstat (limited to 'app-crypt/tpm2-tools/tpm2-tools-5.4.ebuild')
-rw-r--r--app-crypt/tpm2-tools/tpm2-tools-5.4.ebuild10
1 files changed, 9 insertions, 1 deletions
diff --git a/app-crypt/tpm2-tools/tpm2-tools-5.4.ebuild b/app-crypt/tpm2-tools/tpm2-tools-5.4.ebuild
index 6b996f725753..9a0ccfad1d4a 100644
--- a/app-crypt/tpm2-tools/tpm2-tools-5.4.ebuild
+++ b/app-crypt/tpm2-tools/tpm2-tools-5.4.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -36,6 +36,14 @@ BDEPEND="virtual/pkgconfig
)
${PYTHON_DEPS}"
+python_check_deps() {
+ python_has_version "dev-python/pyyaml[${PYTHON_USEDEP}]"
+}
+
+pkg_setup() {
+ use test && python-any-r1_pkg_setup
+}
+
src_configure() {
# tests fail with LTO enabbled. See bug 865275 and 865277
filter-lto