summaryrefslogtreecommitdiff
path: root/app-crypt/tpm2-pkcs11
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
committerV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
commit752d6256e5204b958b0ef7905675a940b5e9172f (patch)
tree330d16e6362a49cbed8875a777fe641a43376cd3 /app-crypt/tpm2-pkcs11
parent0c100b7dd2b30e75b799d806df4ef899fd98e1ea (diff)
gentoo resync : 12.05.2022
Diffstat (limited to 'app-crypt/tpm2-pkcs11')
-rw-r--r--app-crypt/tpm2-pkcs11/Manifest4
-rw-r--r--app-crypt/tpm2-pkcs11/tpm2-pkcs11-1.8.0.ebuild (renamed from app-crypt/tpm2-pkcs11/tpm2-pkcs11-1.7.0.ebuild)36
2 files changed, 18 insertions, 22 deletions
diff --git a/app-crypt/tpm2-pkcs11/Manifest b/app-crypt/tpm2-pkcs11/Manifest
index a7b7c18c0a89..38f96d5ea483 100644
--- a/app-crypt/tpm2-pkcs11/Manifest
+++ b/app-crypt/tpm2-pkcs11/Manifest
@@ -1,3 +1,3 @@
-DIST tpm2-pkcs11-1.7.0.tar.gz 1386693 BLAKE2B bf53a76be712bda374a8d107910440bab087fdb6c34fee3c748128d471a7a84b08f887ff97c8cdfef632679dd4343cf020e9459b96553cd5feecf76e65d6e290 SHA512 eb2736a7ef00fefa91bb70cc96d94d1c7b6ce3701ab12301658b7b076d8fca93bc590c7cdba5a84934b6bd09dad252b13670804c686e76a65b03c7ef6d96427d
-EBUILD tpm2-pkcs11-1.7.0.ebuild 1436 BLAKE2B 9bbf63d22a2f29bcc0fe5860563a7f445e19ec5ac293eae4c547a90e7fd1c99eebf9d5820469095d6d2a6dc5dc272e7a4b10b039950521153c7fe7009d5bf835 SHA512 ab607f6dc726f8afc9e0a6c71c0d8a7007bbe09d5f4b3d3bdcd8d8d9b994356c07d2a1f03d695ec543daeb4a2de975fa53d06b9825e40af3a49167335df759e2
+DIST tpm2-pkcs11-1.8.0.tar.gz 1393977 BLAKE2B c959e9e593dde903eac4b26ac85a39d1c73bfb9b6be558d7338dae1a710eb836385b08ddca27689f0573242d40ee072fa5d6685186a50e10ea42b8679389cf92 SHA512 599feb4d888c25a3359927b1d408f9ce85ba69d8a0e7af7ae9f3736e8940ec8d5f58b3094bef3b6515c0b1810249ea98cd73dbce592cb63de3b45ff976adda80
+EBUILD tpm2-pkcs11-1.8.0.ebuild 1397 BLAKE2B f27c924aa1036e2a8a164031ea45fb881e10faac6d90f55b59c6c51006d54f8bbe27f6276f13183bc69893718d3e4d3e652bb34746a9339327a3909e6d342bb4 SHA512 1371fefd248c4bc9b8282c992efbea51586b034256b5bdeb63386b0df6814336a04d1454774a45289207118062a718dfcb9b59ecd9077bc9ed3c414651b99b17
MISC metadata.xml 473 BLAKE2B 66d9a37ccc8a1dc4e94798394a6e33090a42922d40ca87b55b687207da072ed50a12b985e9261863a4208bced5a76c856e1d05eeed78b27a766dc56234a40ff1 SHA512 e15ae6f4fa11fe7719ba7692b04f7b81563f6c1ea7caa1984c0e0957c18a53abb87ea70c27f0972fec6f6b8608f94142e7791cbd9c2025d7ad0d17889968a549
diff --git a/app-crypt/tpm2-pkcs11/tpm2-pkcs11-1.7.0.ebuild b/app-crypt/tpm2-pkcs11/tpm2-pkcs11-1.8.0.ebuild
index 407c9604607b..5a58280d4e3b 100644
--- a/app-crypt/tpm2-pkcs11/tpm2-pkcs11-1.7.0.ebuild
+++ b/app-crypt/tpm2-pkcs11/tpm2-pkcs11-1.8.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -6,7 +6,7 @@ EAPI=8
PYTHON_COMPAT=( python3_{8..10} )
PYTHON_REQ_USE="sqlite"
-inherit distutils-r1
+inherit python-single-r1
DESCRIPTION="A PKCS#11 interface for TPM2 hardware"
HOMEPAGE="https://tpm2-software.github.io/"
@@ -17,27 +17,34 @@ SLOT="0"
KEYWORDS="~amd64"
IUSE="fapi test"
+REQUIRED_USE="( ${PYTHON_REQUIRED_USE} )"
# Units tests only for now
RESTRICT="!test? ( test )"
-RDEPEND="app-crypt/p11-kit
+RDEPEND="${PYTHON_DEPS}
+ app-crypt/p11-kit
app-crypt/tpm2-abrmd
app-crypt/tpm2-tools[fapi?]
- !fapi? ( app-crypt/tpm2-tss )
- fapi? ( >=app-crypt/tpm2-tss-3.0.1[fapi] )
+ !fapi? ( app-crypt/tpm2-tss:= )
+ fapi? ( >=app-crypt/tpm2-tss-3.0.1:=[fapi] )
dev-db/sqlite:3
dev-libs/libyaml
dev-libs/openssl:=
+ $(python_gen_cond_dep '
dev-python/bcrypt[${PYTHON_USEDEP}]
dev-python/cryptography[${PYTHON_USEDEP}]
dev-python/pyasn1[${PYTHON_USEDEP}]
dev-python/pyasn1-modules[${PYTHON_USEDEP}]
- dev-python/pyyaml[${PYTHON_USEDEP}]"
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-python/tpm2-pytss[${PYTHON_USEDEP}]
+ ')
+"
DEPEND="test? ( dev-util/cmocka )
${RDEPEND}"
-BDEPEND="sys-devel/autoconf-archive
+BDEPEND="${PYTHON_DEPS}
+ sys-devel/autoconf-archive
virtual/pkgconfig"
src_configure() {
@@ -46,20 +53,9 @@ src_configure() {
$(use_enable test unit)
}
-src_compile() {
- default
- cd "${S}/tools" || die
- BUILD_DIR="${S}/tools" python_foreach_impl distutils-r1_python_compile
-}
-
src_install() {
default
- cd "${S}/tools" || die
- BUILD_DIR="${S}/tools" python_foreach_impl distutils-r1_python_install
- dobin "${S}/tools/tpm2_ptool"
+ python_domodule tools/tpm2_pkcs11
+ python_newscript tools/tpm2_ptool.py tpm2_ptool
find "${ED}" -name '*.la' -delete || die
}
-
-src_test() {
- default
-}