summaryrefslogtreecommitdiff
path: root/app-crypt/tpm-tools
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
commitd934827bf44b7cfcf6711964418148fa60877668 (patch)
tree0625f358789b5e015e49db139cc1dbc9be00428f /app-crypt/tpm-tools
parent2e34d110f164bf74d55fced27fe0000201b3eec5 (diff)
gentoo resync : 25.11.2020
Diffstat (limited to 'app-crypt/tpm-tools')
-rw-r--r--app-crypt/tpm-tools/Manifest2
-rw-r--r--app-crypt/tpm-tools/tpm-tools-1.3.9.2.ebuild53
2 files changed, 55 insertions, 0 deletions
diff --git a/app-crypt/tpm-tools/Manifest b/app-crypt/tpm-tools/Manifest
index 52fd51eaa26a..7e17186639c2 100644
--- a/app-crypt/tpm-tools/Manifest
+++ b/app-crypt/tpm-tools/Manifest
@@ -1,4 +1,6 @@
AUX tpm-tools-1.3.9.1-openssl-1.1.patch 6028 BLAKE2B bd7a7b3dc748618004cbbfb7dc51a6f4e3f1c53654193b227c4b3eccd75fbb6d22ed46241a3e201399daa418d58cdd5b124cc2a467f8f59b4b33f54394035602 SHA512 caf3f9a3f82073d71618305132b883ab51ba3220d30ce5c160b9785bcb2e7268cf47621381530d39e1641e0b27bfeb30dcbfd62ae235d82d07942824f533cc7a
DIST tpm-tools-1.3.9.1.tar.gz 482859 BLAKE2B ee915679e23bead04672bf719ce59bb6f20b550be39855b5304caeff554bf54d3cfe9104d464af7762388995e51d2bed0f9bedad83e42146cb7457382d09f4b2 SHA512 63a9c0e761cd890cc0a218de79a9c0169e151aba7824c19bf6b7ec894cf41c4950de1f63bd849aa93a4bdff36cf0fe557bc17113912b6d77f57f2bf1190b6a08
+DIST tpm-tools-1.3.9.2.tar.gz 431930 BLAKE2B bbea3848765d9907c6faa1b5f4a60002e94243040985ce503f392bc8d7392bea41b54317b15fd227b5d73d589cf2c330729532448751d4375484375725310dfa SHA512 b684716c71702140591d89eb03d3724ed5b448e7ba2881bc44de9d44ffc23a9f7dfcf4351eec24e5438cc883f49a7dafee82bb19f90800610cf764ce74e60ccb
EBUILD tpm-tools-1.3.9.1-r1.ebuild 1014 BLAKE2B 709a67933038725f0d5f13c01f022784036980b4fefce6c6409b5dfbf1e688cda1602a44ca38ce6db09a1cb56a84e15366e0f70c241cf6aee2bd6ac9f47595f4 SHA512 96f5e4867454ed666a95fb843a1540514d6114bb40e7df7b6b11f5781851bbae7cf473e7ae0fc5ee361d72d620f57382cde33ee8d777bcbd5e9ffccf68e39d61
+EBUILD tpm-tools-1.3.9.2.ebuild 1157 BLAKE2B 5814481a8573971f5d89f795b02fb09a7c559772f55302a2004d4e45d3e65128448d0e454497f0696e319d632ea972500e29f865dbedc7c530b27b349a71f788 SHA512 4a34636c6382cdee294d9ff29f127a6d44df6d6e8041fd1b4d4952b641256ca03f8557193463ce4d10c6383322b8fb2d91692fb9fe4104c68252e58d0cf087c1
MISC metadata.xml 620 BLAKE2B 476e96fcb039ddb412218d88dcdd4cf2fff9fab8c1f84d4c8e8388963c3150facf9b23e661c5f3552928fe6695105e8ee713895e88bdcd87b648eec6d2adc59b SHA512 38c4cfaa0c8d3b3f606247d76a52e82e3dab7c487e73780180a197763a695c3d023ac54706c87238f75f2ef8ba6b1913bcfd7769c36506690830fd98b6cb7d6e
diff --git a/app-crypt/tpm-tools/tpm-tools-1.3.9.2.ebuild b/app-crypt/tpm-tools/tpm-tools-1.3.9.2.ebuild
new file mode 100644
index 000000000000..27bfb41b11f5
--- /dev/null
+++ b/app-crypt/tpm-tools/tpm-tools-1.3.9.2.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools flag-o-matic
+
+DESCRIPTION="TrouSerS' support tools for the Trusted Platform Modules"
+HOMEPAGE="http://trousers.sourceforge.net"
+SRC_URI="mirror://sourceforge/trousers/${PN}/${P}.tar.gz"
+
+LICENSE="CPL-1.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~m68k ~s390 ~x86"
+IUSE="libressl nls pkcs11 debug"
+
+DEPEND=">=app-crypt/trousers-0.3.0
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )
+ pkcs11? ( dev-libs/opencryptoki )"
+RDEPEND="${DEPEND}"
+BDEPEND="nls? ( sys-devel/gettext )"
+
+src_prepare() {
+ default
+
+# upstream didn't generate the tarball correctly so we must bootstrap
+# ouselves
+ mkdir -p po || die
+ mkdir -p m4 || die
+ cp -R po_/* po/ || die
+ touch po/Makefile.in.in || die
+ touch m4/Makefile.am || die
+
+ sed -i -r \
+ -e '/CFLAGS/s/ -m64//' \
+ configure.ac || die
+
+ eautoreconf
+}
+
+src_configure() {
+ append-cppflags $(usex debug -DDEBUG -DNDEBUG)
+
+ econf \
+ $(use_enable nls) \
+ $(use pkcs11 || echo --disable-pkcs11-support)
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}