summaryrefslogtreecommitdiff
path: root/app-crypt/tpm-tools
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-04-28 20:02:04 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-04-28 20:02:04 +0100
commita4e2a46beb5e4858ef27bdedbb0ff6d2ced430ad (patch)
tree852c90a4bf354c30ea66504f70bfab5401fba18d /app-crypt/tpm-tools
parent5e8702bcbbed438e6c6cce023e7ef0cc9baa3e02 (diff)
gentoo resync : 28.04.2018
Diffstat (limited to 'app-crypt/tpm-tools')
-rw-r--r--app-crypt/tpm-tools/Manifest2
-rw-r--r--app-crypt/tpm-tools/tpm-tools-1.3.9.1.ebuild51
2 files changed, 53 insertions, 0 deletions
diff --git a/app-crypt/tpm-tools/Manifest b/app-crypt/tpm-tools/Manifest
index 5889f0fd0c5b..d6f97db1ffaf 100644
--- a/app-crypt/tpm-tools/Manifest
+++ b/app-crypt/tpm-tools/Manifest
@@ -1,4 +1,6 @@
AUX tpm-tools-1.3.9-gold.patch 451 BLAKE2B a322007af718189bd2a05da19c1b67ee0f630515233515569661e16b1a9f36c82c2b97a998ec526e0c9c617da3a4e5bf08b6c0eeb3642b16e65a47757ae59f36 SHA512 7f9473a456c5901c28ec0394158e43b3d8cc3a9a994e5be5d1a45b20f5360f2f0b7778eb93246964192e19fdd140ee5b50d1852500c9aface2824d83c6907c41
+DIST tpm-tools-1.3.9.1.tar.gz 482859 BLAKE2B ee915679e23bead04672bf719ce59bb6f20b550be39855b5304caeff554bf54d3cfe9104d464af7762388995e51d2bed0f9bedad83e42146cb7457382d09f4b2 SHA512 63a9c0e761cd890cc0a218de79a9c0169e151aba7824c19bf6b7ec894cf41c4950de1f63bd849aa93a4bdff36cf0fe557bc17113912b6d77f57f2bf1190b6a08
DIST tpm-tools-1.3.9.tar.gz 484023 BLAKE2B 5f9809a8dd4c565c647ceb394e6a6086cd42d256feb39599331b979f73150f60881ba9f25a3b0171173d66da8718f1475c6945b243b86c2261c4e8c489802803 SHA512 460e56031aa65ede6b7aebf0c594d4093d870fb46f7c453c429e53cca442d4c7797ac29b519bca28d42133bc6d7701cdf938adbdf11f8be841157d4f4a3e17ca
+EBUILD tpm-tools-1.3.9.1.ebuild 1022 BLAKE2B 4cdff4f76c73f77207e4a8e368cbdadf206648b095c07b496fb334edadbbd462663d73598c10400b8a0f58b7c5bd7fe2e85a29d497a167c9622b3b046fc6715e SHA512 d230f6b7379fa975d0ea284e661f6b169b2bd559f959ef57db54b05edcb81eeb104081794ed625334c3797aeccc0c40a21d75370c4dfba13e38ac0daed150e07
EBUILD tpm-tools-1.3.9.ebuild 1063 BLAKE2B 942d5fa06f92c84fed92068b3b9fd266081cc6822e5589725dc10ec6f48a5ccbdd0a2b27ebc7c50eee09f2139ce3d5a29e0834e4a56e2369c98697e322fc5a5f SHA512 a6b15b03b9d4018932080890b5bf9f156e600e8b89a033b895d0be5a6d304571acbd601775886293db542800f76d2805b613298f01a802a2ecbca4a9ba2c9120
MISC metadata.xml 515 BLAKE2B 06991185c31f6e40b7cda3c9842339911e9806d024e1493ef674751b4d253f5f701a8386a8969f7124b29b2c984f109ec98cb767380b48781fb22bd266d7863a SHA512 5aea8cabd5ae0a00b4a49717efaf8ed6d6363131ff8bdc2a9167108297d32dee72c5419bbc84ae9ba1263d515dff2aa092b991c8411771a2b8c361bcf000258a
diff --git a/app-crypt/tpm-tools/tpm-tools-1.3.9.1.ebuild b/app-crypt/tpm-tools/tpm-tools-1.3.9.1.ebuild
new file mode 100644
index 000000000000..4b922742df44
--- /dev/null
+++ b/app-crypt/tpm-tools/tpm-tools-1.3.9.1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools flag-o-matic ltprune
+
+DESCRIPTION="TrouSerS' support tools for the Trusted Platform Modules"
+HOMEPAGE="http://trousers.sourceforge.net"
+SRC_URI="mirror://sourceforge/trousers/${PN}/${P}.tar.gz"
+
+LICENSE="CPL-1.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~m68k ~s390 ~sh ~x86"
+IUSE="libressl nls pkcs11 debug"
+
+COMMON_DEPEND="
+ >=app-crypt/trousers-0.3.0
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )
+ pkcs11? ( dev-libs/opencryptoki )
+ "
+RDEPEND="${COMMON_DEPEND}
+ nls? ( virtual/libintl )"
+DEPEND="${COMMON_DEPEND}
+ nls? ( sys-devel/gettext )"
+
+S="${WORKDIR}"
+
+src_prepare() {
+ default
+
+ sed -i -r \
+ -e '/CFLAGS/s/ -m64//' \
+ configure.ac || die
+
+ eautoreconf
+}
+
+src_configure() {
+ append-cppflags $(usex debug -DDEBUG -DNDEBUG)
+
+ econf \
+ $(use_enable nls) \
+ $(use pkcs11 || echo --disable-pkcs11-support)
+}
+
+src_install() {
+ default
+ prune_libtool_files
+}