summaryrefslogtreecommitdiff
path: root/app-crypt/stoken
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-crypt/stoken
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-crypt/stoken')
-rw-r--r--app-crypt/stoken/Manifest3
-rw-r--r--app-crypt/stoken/metadata.xml16
-rw-r--r--app-crypt/stoken/stoken-0.92.ebuild30
3 files changed, 49 insertions, 0 deletions
diff --git a/app-crypt/stoken/Manifest b/app-crypt/stoken/Manifest
new file mode 100644
index 000000000000..de91d1f9d782
--- /dev/null
+++ b/app-crypt/stoken/Manifest
@@ -0,0 +1,3 @@
+DIST stoken-0.92.tar.gz 117212 BLAKE2B 8d236a73b0626ab91d145d01fa07c28ba8c54a3053aaba32b64b4dacc39dc8265d5740630ec2495d678c975b1bfa480a79a5ec1115accf39170229b444673f48 SHA512 b41262320c24e487ece884fc431d835c787f057947a92e3d57ed2047bc02b576b072e8a69f4b58b47ab1f913b5ae8c3ee8108d3b55c1477f15848420b668fea3
+EBUILD stoken-0.92.ebuild 635 BLAKE2B 4ad1ad155df7f4f933cbd9137637ef5f9dbeea5be8722b1ce7d9afe5df0cbdfe0b0d9e9e21803a1d3338adf6a5e6e5c6ca24ecae5daa543e67846967e86bab58 SHA512 207e1881941c7b3a8307b8d885d7105edd1b1c1ac56e987bb5b957e7987a08d18e0230c1ea2db5e70bc4cbe2d8d3ad27a0866a693f2ae009de83d803d387b30a
+MISC metadata.xml 620 BLAKE2B 2655c4310ae4cc76e7609e4646879d81ef6ee26b9dff67b922822c89de19416c96bd63762920633ff4e018c8431fbb45f8dc93971f2fb8afbe1dd66c8ea2e318 SHA512 bda231308c073a40db47dfaca96c6af8bf194d5ef4727e8c8c99ad1492150f79a9978daeb3ffe503db03501a0a6c6c465d036bec7ad58398319f8d01d27f7931
diff --git a/app-crypt/stoken/metadata.xml b/app-crypt/stoken/metadata.xml
new file mode 100644
index 000000000000..920373f43e65
--- /dev/null
+++ b/app-crypt/stoken/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>prometheanfire@gentoo.org</email>
+ <name>Matthew Thode</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">cernekee/stoken</remote-id>
+ <bugs-to>https://github.com/cernekee/stoken/issues</bugs-to>
+ </upstream>
+ <longdescription lang="en">
+ stoken is an open source tokencode generator compatible with RSA SecurID 128-bit (AES) tokens.
+ It is a hobbyist project, not affiliated with or endorsed by RSA Security.
+ </longdescription>
+</pkgmetadata>
diff --git a/app-crypt/stoken/stoken-0.92.ebuild b/app-crypt/stoken/stoken-0.92.ebuild
new file mode 100644
index 000000000000..06a2e2468cfd
--- /dev/null
+++ b/app-crypt/stoken/stoken-0.92.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit autotools
+
+DESCRIPTION="Software Token for Linux/UNIX"
+HOMEPAGE="https://github.com/cernekee/stoken"
+SRC_URI="https://github.com/cernekee/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+KEYWORDS="amd64 arm ~arm64 ppc64 x86"
+IUSE="gtk"
+
+# || ( dev-libs/nettle dev-libs/libtomcrypt ) libtomcrypt is not packaged
+RDEPEND="
+ dev-libs/nettle
+ gtk? ( >=x11-libs/gtk+-3.12:3 )"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ eautoreconf
+ eapply_user
+}
+
+src_configure() {
+ econf $(use_with gtk)
+}