summaryrefslogtreecommitdiff
path: root/app-crypt/stoken
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-05-18 22:13:50 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-05-18 22:13:50 +0100
commit6b36d02cbdfea303a1d9bf985b6e8c984c7ac3cf (patch)
tree5b12e13d34ece81eb6b5991db8928e24538287a2 /app-crypt/stoken
parentae7f349673c9e013e85bbc65e873d3363467a293 (diff)
gentoo auto-resync : 18:05:2023 - 22:13:50
Diffstat (limited to 'app-crypt/stoken')
-rw-r--r--app-crypt/stoken/Manifest2
-rw-r--r--app-crypt/stoken/stoken-0.92-r3.ebuild (renamed from app-crypt/stoken/stoken-0.92-r2.ebuild)12
2 files changed, 7 insertions, 7 deletions
diff --git a/app-crypt/stoken/Manifest b/app-crypt/stoken/Manifest
index 0d5b0d272019..31166344a949 100644
--- a/app-crypt/stoken/Manifest
+++ b/app-crypt/stoken/Manifest
@@ -1,3 +1,3 @@
DIST stoken-0.92.tar.gz 117212 BLAKE2B 8d236a73b0626ab91d145d01fa07c28ba8c54a3053aaba32b64b4dacc39dc8265d5740630ec2495d678c975b1bfa480a79a5ec1115accf39170229b444673f48 SHA512 b41262320c24e487ece884fc431d835c787f057947a92e3d57ed2047bc02b576b072e8a69f4b58b47ab1f913b5ae8c3ee8108d3b55c1477f15848420b668fea3
-EBUILD stoken-0.92-r2.ebuild 839 BLAKE2B 727344464bfbd8f4598987b8e89390ca0a96524b26a04a1a39b21df455313431975a67f89e0dba88f9b300c206a4ae091e0850d30614b4410c79a1dfb0e38d02 SHA512 4780981f06326d0681d212c8050ff529c231e597405a92e940c51a476bb87ad4e3a6fc991c0992d4eedd0be22f18c8faba28696e71bc4476952eef68353ea6f3
+EBUILD stoken-0.92-r3.ebuild 813 BLAKE2B fe159ad4453ca5121c184fa399e4b80ada9519cef7f667bf620e82d11c307b78db84d11603cf45692599e42c9967d9e8e1d4ac7df6f0ae63ff053a016ee74961 SHA512 c0e83db9352b673e7a44c3892c913851746832bb32a795f54b2b338798122f614636018bed63a266139f7a1812783ddd5901a470037503981b8951068fc40120
MISC metadata.xml 621 BLAKE2B e200a7bbf5f43900ecbfaf4acd8e52d83525e8be25a4167ccf8de7296ad5578b7795a8feb9aa902af0f5dd620e6d227482adfbf258bf92cf08ea8bbfa2e1be27 SHA512 40dc7ef9b3c995d44e0509f85a3b2862e959467fc10429470d16b3492c0c70f67769a0e1b5433063af92cb2bc8a2a49e8049ce957dab5ac013b6de3620612b0c
diff --git a/app-crypt/stoken/stoken-0.92-r2.ebuild b/app-crypt/stoken/stoken-0.92-r3.ebuild
index 71f62bf2c30a..11e11adeb2f1 100644
--- a/app-crypt/stoken/stoken-0.92-r2.ebuild
+++ b/app-crypt/stoken/stoken-0.92-r3.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="6"
+EAPI=8
inherit autotools
@@ -12,13 +12,14 @@ SRC_URI="https://github.com/cernekee/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="LGPL-2.1+"
SLOT="0"
KEYWORDS="amd64 arm arm64 ~loong ppc64 ~riscv x86"
-IUSE="gtk static-libs"
+IUSE="gtk"
# TODO: add a USE flag to enable optional use of tomcrypt instead of nettle.
RDEPEND="
- dev-libs/nettle
- gtk? ( >=x11-libs/gtk+-3.12:3 )"
+ dev-libs/nettle:=
+ gtk? ( x11-libs/gtk+:3 )"
DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
src_prepare() {
default
@@ -28,7 +29,6 @@ src_prepare() {
src_configure() {
local myconf=(
$(use_with gtk)
- $(use_enable static-libs static)
--with-nettle
--without-tomcrypt
)