summaryrefslogtreecommitdiff
path: root/app-crypt/ssss
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-03-03 13:42:34 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-03-03 13:42:34 +0000
commit066d27181e9a797ad9f8fc43b49fc9a10ff2f707 (patch)
tree3cb05783d73b2c33589ba305144a31c718e123cd /app-crypt/ssss
parent16449a80e28af2209916cc66d19c9a44ca2b90d9 (diff)
gentoo resync : 03.03.2019
Diffstat (limited to 'app-crypt/ssss')
-rw-r--r--app-crypt/ssss/Manifest3
-rw-r--r--app-crypt/ssss/metadata.xml17
-rw-r--r--app-crypt/ssss/ssss-0.5.ebuild39
3 files changed, 59 insertions, 0 deletions
diff --git a/app-crypt/ssss/Manifest b/app-crypt/ssss/Manifest
new file mode 100644
index 000000000000..eface075ab79
--- /dev/null
+++ b/app-crypt/ssss/Manifest
@@ -0,0 +1,3 @@
+DIST ssss-0.5.tar.gz 17435 BLAKE2B 76aae463ce11341f8b0336526f7d19c9921025cabc05bc9e00005b0bdeb676ed5e069226962232f277de2fecb1cd71bafbd4b2fa0c03ef4faf0f66daa24599d1 SHA512 be8df1666ac61d4097b5fd54f2cee3640db8f85ec21411f1b208a35b671c5699bc692079525d8d313d1cf2500da31bfb03771829a9fdccc0bb6d806749526ec9
+EBUILD ssss-0.5.ebuild 757 BLAKE2B 54c1a67582ef0ab340dab68767d1196d3c97c584ccfedf313afb0b9efeae95a09d0a0f855f1fcfcd70bb5c2fdb8c14310ab7127799d97449708db936ac38d6e7 SHA512 9c862dbe07aee602cb8613622a6af6c2b0e777e46b85b6dd215013a47a15dd7a799587241d12005206c933982d9bcf92462cf26f5695889473502a9eef792d8a
+MISC metadata.xml 615 BLAKE2B 268173e83a1880bde7f164f9bc93f499654928a537458334dc3a87ed706e3bf31b514582fdf890d107896a04cfe9936e2a4459201b04448d919bcd277f616a26 SHA512 8ddbb48727f79921b79da2ac26f560a56e5e55c8a335a5dc7469f6a6aed8715034abbe7b869467d3bdeca9dca120b07bfbf8b16aee03cd5a730c67b2fef74f8c
diff --git a/app-crypt/ssss/metadata.xml b/app-crypt/ssss/metadata.xml
new file mode 100644
index 000000000000..108893a39ca7
--- /dev/null
+++ b/app-crypt/ssss/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>ck+gentoo@bl4ckb0x.de</email>
+ <name>Conrad Kostecki</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <longdescription>
+ SSSS is an implementation of Shamir's Secret Sharing Scheme.
+ The program suite does both: the generation of shares for a known secret,
+ and the reconstruction of a secret using user-pro‐vided shares.
+ </longdescription>
+</pkgmetadata>
diff --git a/app-crypt/ssss/ssss-0.5.ebuild b/app-crypt/ssss/ssss-0.5.ebuild
new file mode 100644
index 000000000000..55fa43d76cb2
--- /dev/null
+++ b/app-crypt/ssss/ssss-0.5.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="Shamir's Secret Sharing Scheme"
+HOMEPAGE="http://point-at-infinity.org/ssss/"
+SRC_URI="http://point-at-infinity.org/${PN}/${P}.tar.gz"
+
+KEYWORDS="~amd64 ~x86"
+LICENSE="GPL-2"
+SLOT="0"
+
+RDEPEND="dev-libs/gmp:0="
+DEPEND="${RDEPEND}"
+BDEPEND="app-doc/xmltoman"
+
+DOCS=( "HISTORY" "THANKS" )
+HTML_DOCS=( "doc.html" "ssss.1.html" )
+
+src_prepare() {
+ default
+
+ tc-export CC
+
+ # Respect users CFLAGS and don't strip, as portage does this part.
+ sed -e 's/-O2/$(CFLAGS)/g' -e '/strip/d' -i Makefile || die
+}
+
+src_install() {
+ dobin ssss-split
+ dosym ssss-split /usr/bin/ssss-combine
+
+ doman ssss.1
+
+ einstalldocs
+}