summaryrefslogtreecommitdiff
path: root/app-crypt/simple-tpm-pk11
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-05-18 22:13:50 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-05-18 22:13:50 +0100
commit6b36d02cbdfea303a1d9bf985b6e8c984c7ac3cf (patch)
tree5b12e13d34ece81eb6b5991db8928e24538287a2 /app-crypt/simple-tpm-pk11
parentae7f349673c9e013e85bbc65e873d3363467a293 (diff)
gentoo auto-resync : 18:05:2023 - 22:13:50
Diffstat (limited to 'app-crypt/simple-tpm-pk11')
-rw-r--r--app-crypt/simple-tpm-pk11/Manifest2
-rw-r--r--app-crypt/simple-tpm-pk11/simple-tpm-pk11-0.06-r2.ebuild (renamed from app-crypt/simple-tpm-pk11/simple-tpm-pk11-0.06-r1.ebuild)32
2 files changed, 16 insertions, 18 deletions
diff --git a/app-crypt/simple-tpm-pk11/Manifest b/app-crypt/simple-tpm-pk11/Manifest
index e8d2783e5c21..ed454bf367b6 100644
--- a/app-crypt/simple-tpm-pk11/Manifest
+++ b/app-crypt/simple-tpm-pk11/Manifest
@@ -1,3 +1,3 @@
DIST simple-tpm-pk11-0.06.tar.gz 28993 BLAKE2B b592acf3d9fe334993ed1e72152ee2c0a25ea3be777035c2d113323522f7d99e6c564bd7c4de0725b0f04f5b6dad90c5a35ede815d28f40a3fb53a6cc9e2bee6 SHA512 72df0637cefdb0d81f741480cdfe24ac0d6a05a93d729f5e2180adf49b5d7ddb0b60d8c6f7d5e79a67bf4cea202067390c8d4532c906273408f7de4fcc5e66e8
-EBUILD simple-tpm-pk11-0.06-r1.ebuild 940 BLAKE2B 114cb19bdc2ec5bc0713c11b77f570b0d74403f1befeb97b1f8357574207a51f53db59bb86f59ddd4f246349cc0c9004cc548bc1b1c5f54efb6bf59c660fdb04 SHA512 3c46bf0c6be943e1372efd2c4b48008fb1882b2cceff4bcb0eef8f6b1d9280da5c9d9eb34bcc2bb20fe64b3625e2af55540bbaaa494bc4aa1c71d5b048afc5ce
+EBUILD simple-tpm-pk11-0.06-r2.ebuild 891 BLAKE2B 3c34f6e9c17ce9567ea867cfe67c95d9129b2f7848416e28ada9e017e3158d1cac5c945b9bd94d8255cf94a5b3091dae707ff4887a2698eac333ee3578bc68c9 SHA512 489852b31def3317f51a832a1aea52623cdfc6dc3cfa1c3f25922d4fbcbeb366e9de825b17a0cd20ccfaeb9259695f803fb90eb9c3817f9798bd11cdfad46b56
MISC metadata.xml 322 BLAKE2B 244fa220292d679f6da9a58481c447a5b8781f08f0a962800fb89c2b2099a13a18340b19853fa4a6924eb2d9fa3cd428a9a7a8d9cb166c1d2f512ef679436664 SHA512 5dc8891b9eef983ae3baf71d70806f2bc79a44fd3e69851144282e824a2678329843dbcad9abfe93c7b251b57189f6d0f90f04defa6ba16bb0554c196fdf19f0
diff --git a/app-crypt/simple-tpm-pk11/simple-tpm-pk11-0.06-r1.ebuild b/app-crypt/simple-tpm-pk11/simple-tpm-pk11-0.06-r2.ebuild
index 6b5facd3a1c1..fe55cfddc7f0 100644
--- a/app-crypt/simple-tpm-pk11/simple-tpm-pk11-0.06-r1.ebuild
+++ b/app-crypt/simple-tpm-pk11/simple-tpm-pk11-0.06-r2.ebuild
@@ -1,16 +1,11 @@
# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=8
inherit autotools
-DESCRIPTION="Simple PKCS11 provider for TPM chips"
-HOMEPAGE="https://github.com/ThomasHabets/simple-tpm-pk11"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-if [[ ${PV} == "9999" ]]; then
+if [[ ${PV} == *9999 ]]; then
EGIT_REPO_URI="https://github.com/ThomasHabets/${PN}.git"
inherit git-r3
else
@@ -18,28 +13,31 @@ else
KEYWORDS="~amd64"
fi
+DESCRIPTION="Simple PKCS11 provider for TPM chips"
+HOMEPAGE="https://github.com/ThomasHabets/simple-tpm-pk11"
+
+LICENSE="Apache-2.0"
+SLOT="0"
RESTRICT="test" # needs to communicate with the TPM and gtest is all broken
-DEPEND="app-crypt/tpm-tools[pkcs11]
- dev-libs/opencryptoki[tpm]
+DEPEND="
+ app-crypt/tpm-tools[pkcs11]
app-crypt/trousers
- dev-libs/openssl:0=
- "
+ dev-libs/opencryptoki[tpm]
+ dev-libs/openssl:=
+"
RDEPEND="${DEPEND}
|| (
>=net-misc/openssh-9.3_p1-r1
>=net-misc/openssh-contrib-9.3_p1[-X509]
- )"
+ )
+"
src_prepare() {
- eapply_user
+ default
eautoreconf
}
-src_configure() {
- econf --disable-static
-}
-
src_install() {
default
find "${ED}" -name '*.la' -delete || die