summaryrefslogtreecommitdiff
path: root/app-crypt/sign/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /app-crypt/sign/files
reinit the tree, so we can have metadata
Diffstat (limited to 'app-crypt/sign/files')
-rw-r--r--app-crypt/sign/files/1.0.7-as-needed.patch10
-rw-r--r--app-crypt/sign/files/1.0.7-openssl-0.9.8.patch12
2 files changed, 22 insertions, 0 deletions
diff --git a/app-crypt/sign/files/1.0.7-as-needed.patch b/app-crypt/sign/files/1.0.7-as-needed.patch
new file mode 100644
index 000000000000..56574d7131d7
--- /dev/null
+++ b/app-crypt/sign/files/1.0.7-as-needed.patch
@@ -0,0 +1,10 @@
+diff -Nur sign-1.0.7.orig/src/Makefile sign-1.0.7/src/Makefile
+--- sign-1.0.7.orig/src/Makefile 2004-08-07 07:15:00.000000000 +0000
++++ sign-1.0.7/src/Makefile 2006-09-16 17:21:12.400977608 +0000
+@@ -1,5 +1,5 @@
+ CFLAGS += -Wall -DNDEBUG -g
+-LDFLAGS += -lcrypto
++LDLIBS += -lcrypto
+
+ OBJS = buf.o die.o msg.o digest.o uue.o pki.o str.o system-nix.o \
+ system-nix-readpass.o util.o
diff --git a/app-crypt/sign/files/1.0.7-openssl-0.9.8.patch b/app-crypt/sign/files/1.0.7-openssl-0.9.8.patch
new file mode 100644
index 000000000000..179efbe77ef5
--- /dev/null
+++ b/app-crypt/sign/files/1.0.7-openssl-0.9.8.patch
@@ -0,0 +1,12 @@
+diff -Nur sign-1.0.7.orig/src/pki.c sign-1.0.7/src/pki.c
+--- sign-1.0.7.orig/src/pki.c 2004-08-04 04:10:35.000000000 +0000
++++ sign-1.0.7/src/pki.c 2006-09-16 17:17:34.335535125 +0000
+@@ -286,7 +286,7 @@
+
+ /* if it's not a decryption problem - bail out */
+ if (ERR_get_error() != ERR_PACK(ERR_LIB_EVP,
+- EVP_F_EVP_DECRYPTFINAL,
++ EVP_F_EVP_DECRYPTFINAL_EX,
+ EVP_R_BAD_DECRYPT))
+ goto cleanup;
+