summaryrefslogtreecommitdiff
path: root/app-crypt/shash/shash-0.2.6-r4.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-10-31 21:06:00 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-10-31 21:06:00 +0000
commitc9c609463fab9bcfb35694627bca1429a21fdbb2 (patch)
tree024860c3c54aa33cdb6972acd3e2e0b8484f3aa7 /app-crypt/shash/shash-0.2.6-r4.ebuild
parent6dd9db91dd6ce9bbe3197aa82642866e637ba68d (diff)
gentoo auto-resync : 31:10:2022 - 21:05:59
Diffstat (limited to 'app-crypt/shash/shash-0.2.6-r4.ebuild')
-rw-r--r--app-crypt/shash/shash-0.2.6-r4.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/app-crypt/shash/shash-0.2.6-r4.ebuild b/app-crypt/shash/shash-0.2.6-r4.ebuild
new file mode 100644
index 000000000000..2094f2880276
--- /dev/null
+++ b/app-crypt/shash/shash-0.2.6-r4.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools bash-completion-r1
+
+DESCRIPTION="Generate or check digests or MACs of files"
+HOMEPAGE="http://mcrypt.hellug.gr/shash/"
+SRC_URI="ftp://mcrypt.hellug.gr/pub/mcrypt/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE="static"
+
+DEPEND="
+ >=app-crypt/mhash-0.8.18-r1
+ static? ( app-crypt/mhash[static-libs(+)] )"
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${PV}-manpage-fixes.patch
+ "${FILESDIR}"/${P}-binary-files.patch
+ "${FILESDIR}"/${P}-format-security.patch
+ "${FILESDIR}"/${P}-C99-decls.patch
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use_enable static static-link)
+}
+
+src_install() {
+ default
+ dodoc doc/sample.shashrc doc/FORMAT
+ newbashcomp "${FILESDIR}"/shash.bash-completion ${PN}
+}