summaryrefslogtreecommitdiff
path: root/app-crypt/seahorse
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-crypt/seahorse
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-crypt/seahorse')
-rw-r--r--app-crypt/seahorse/Manifest3
-rw-r--r--app-crypt/seahorse/metadata.xml33
-rw-r--r--app-crypt/seahorse/seahorse-3.20.0.ebuild68
3 files changed, 104 insertions, 0 deletions
diff --git a/app-crypt/seahorse/Manifest b/app-crypt/seahorse/Manifest
new file mode 100644
index 000000000000..c4cb136fe40b
--- /dev/null
+++ b/app-crypt/seahorse/Manifest
@@ -0,0 +1,3 @@
+DIST seahorse-3.20.0.tar.xz 1556556 BLAKE2B e0742996045b50acb2d60f548f321e1ff0121c166209e2230d5839cc971f8560f316c91c3a88a30c302c5339ba0251e7faf64ae805c4f80e853cc67a6952d350 SHA512 a02d3da7af95256941ef065ac024bd5bfb53a026767b951fa2e26446fb0eed23707e69f72f6e8ebfa7d538823fa41411709fa2bebad4fbd662af1e81bc15ab82
+EBUILD seahorse-3.20.0.ebuild 1628 BLAKE2B 72e5b4170c9a9e57f8742b025bb9bb7a816e67dfacbf08e80f715178e06f9cbec10654366c0f74899a816f1f0cbc6d988fb17d258e31873e43eac7f337cb7e51 SHA512 d53d488ab47a2681e075df1894288e81e7c32d05c28b027a091fb91d903da3275e235774e3d0f0caf18dca51d077afce63c2ed40ad5af9a319682956521b593e
+MISC metadata.xml 871 BLAKE2B 5497bf54b134fb991034614308c76230b647a95ed4609d2271c83af737c5ff86325ca3e56ff3682752585d16cf9389e17bca47e3a673e386ca201aba78a006e6 SHA512 3e4844cf29c6343c93ee51a9d5643464256f7ad884e6af946166c251004d3cbbf6d1aaa6771faf27b1a531939a8401413b52aa84a6bee8a2a4365775b09e8514
diff --git a/app-crypt/seahorse/metadata.xml b/app-crypt/seahorse/metadata.xml
new file mode 100644
index 000000000000..6789dec723b8
--- /dev/null
+++ b/app-crypt/seahorse/metadata.xml
@@ -0,0 +1,33 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>gnome@gentoo.org</email>
+ <name>Gentoo GNOME Desktop</name>
+</maintainer>
+<use>
+ <flag name="ldap">Enable seahorse to manipulate GPG keys on a LDAP server.</flag>
+</use>
+<longdescription>Seahorse is a Gnome interface for GnuPG. It's main purpose is to be a PGP/GPG Key Manager, though
+it has other components including a text editor and file manager.
+
+Key Manager Features:
+Generating a key
+Deleting a key
+Importing keys from text or a file
+Exporting a key to text or a file
+View key properties
+
+Key Properties Features:
+Show key info
+Change owner trust
+Change primary key's expiration date
+Change passphrase
+Export key
+Delete Key
+
+Plugins:
+Nautilus Integration
+Gedit plugin
+</longdescription>
+</pkgmetadata>
diff --git a/app-crypt/seahorse/seahorse-3.20.0.ebuild b/app-crypt/seahorse/seahorse-3.20.0.ebuild
new file mode 100644
index 000000000000..3a5351bb36e0
--- /dev/null
+++ b/app-crypt/seahorse/seahorse-3.20.0.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit gnome2
+
+DESCRIPTION="A GNOME application for managing encryption keys"
+HOMEPAGE="https://wiki.gnome.org/Apps/Seahorse"
+
+LICENSE="GPL-2+ FDL-1.1+"
+SLOT="0"
+IUSE="debug ldap zeroconf"
+KEYWORDS="~alpha amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc x86 ~x86-fbsd"
+
+COMMON_DEPEND="
+ >=app-crypt/gcr-3.11.91:=
+ >=dev-libs/glib-2.10:2
+ >=x11-libs/gtk+-3.4:3
+ >=app-crypt/libsecret-0.16
+ >=net-libs/libsoup-2.33.92:2.4
+ x11-misc/shared-mime-info
+
+ net-misc/openssh
+ >=app-crypt/gpgme-1
+ >=app-crypt/gnupg-2.0.12
+
+ ldap? ( net-nds/openldap:= )
+ zeroconf? ( >=net-dns/avahi-0.6:= )
+"
+DEPEND="${COMMON_DEPEND}
+ app-text/yelp-tools
+ dev-util/gdbus-codegen
+ >=dev-util/intltool-0.35
+ dev-util/itstool
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+# Need seahorse-plugins git snapshot
+RDEPEND="${COMMON_DEPEND}
+ !<app-crypt/seahorse-plugins-2.91.0_pre20110114
+"
+
+src_prepare() {
+ # Do not mess with CFLAGS with USE="debug"
+ sed -e '/CFLAGS="$CFLAGS -g/d' \
+ -e '/CFLAGS="$CFLAGS -O0/d' \
+ -i configure.ac configure || die "sed 1 failed"
+
+ # Accept GnuPG 2.2.0
+ sed -e 's/GNUPG_ACCEPTED="2.0.12 2.1.4"/GNUPG_ACCEPTED="2.0.12 2.1.4 2.2.0"/g' \
+ -i configure.ac configure || die "sed failed"
+
+ gnome2_src_prepare
+}
+
+src_configure() {
+ # bindir is needed due to bad macro expansion in desktop file, bug #508610
+ gnome2_src_configure \
+ --bindir=/usr/bin \
+ --enable-pgp \
+ --enable-ssh \
+ --enable-pkcs11 \
+ --enable-hkp \
+ $(use_enable debug) \
+ $(use_enable ldap) \
+ $(use_enable zeroconf sharing) \
+ VALAC=$(type -P true)
+}