summaryrefslogtreecommitdiff
path: root/app-crypt/seahorse
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-04-12 03:41:30 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-04-12 03:41:30 +0100
commit623ee73d661e5ed8475cb264511f683407d87365 (patch)
tree993eb27c93ec7a2d2d19550300d888fc1fed9e69 /app-crypt/seahorse
parentceeeb463cc1eef97fd62eaee8bf2196ba04bc384 (diff)
gentoo Easter resync : 12.04.2020
Diffstat (limited to 'app-crypt/seahorse')
-rw-r--r--app-crypt/seahorse/Manifest3
-rw-r--r--app-crypt/seahorse/files/3.32.2-libsecret-0.20-compat.patch30
-rw-r--r--app-crypt/seahorse/seahorse-3.32.2.ebuild6
3 files changed, 37 insertions, 2 deletions
diff --git a/app-crypt/seahorse/Manifest b/app-crypt/seahorse/Manifest
index 24bd542bfe21..f89fba1cb6ed 100644
--- a/app-crypt/seahorse/Manifest
+++ b/app-crypt/seahorse/Manifest
@@ -1,3 +1,4 @@
+AUX 3.32.2-libsecret-0.20-compat.patch 1333 BLAKE2B c1c80f28531726c60a709e136c1c156980d6eb5e32911ded5220382905180a542440e27ace8feab410f963a9920a5d2945085a45da1bd7aa3fbce83f8f776a08 SHA512 468f843cbbee56ae82ed3c36ea18e27e8e21611724631d12da9022bc24f8822c9d863c12b59d6f7110193f5a65cbfe41d3a7b61466d6ba2d2f4f994892d4a4c5
DIST seahorse-3.32.2.tar.xz 1278668 BLAKE2B cd3fe6794ca02b1b0fd4b833a7128b8180137441a788f1f3ec5bb4186517ebb9e7422fabab2d19f60420b36e6b1ecab8b8326c99122aad185b8e45927232708f SHA512 e372f79907fbc5d60a41ea0db3a91575b0b304c1727c6091f94eec28445cd836faa32754582c59fd1eb8ce784986e63b4c8cabbd46d5e4cacec1150d9ca08481
-EBUILD seahorse-3.32.2.ebuild 1457 BLAKE2B c427aa81dd70a8308eab8eb59b08a70d44d03b1eae49185afaea88ceaaa1de0d219cc0c849f55fee6cee4c5545f8a939a5b15c8300d4722dc2e4eb96ebf87f2a SHA512 adecf0e83b24859135bbaaf997a564de93d4f530a653f150ae3079e54d24425ca163620ed3694ae43c2cb16c73c66715f1f4acbe2057fb9c82cf318e05ce91e6
+EBUILD seahorse-3.32.2.ebuild 1548 BLAKE2B c60b73c8b7e427f09b003ebc7d1028a82f236a9975dc41571bf05a16f443e11cd6566aafa502a74eabcb452b6b5b2e14b190c8aeb8b273045a4687eee21352ba SHA512 1aacea7daff0d72cd4b0826faf59430ba62b575dfafb968a950711a6fe68376b8a1afc3fef8176ea471def213ef08962c47d916f24bf7bbf2f64da0a11d7cf83
MISC metadata.xml 742 BLAKE2B 11cc6cebe3f395ccd9f2570a419e812951287d7a9af2bd88720a66c7349305c108c451b67a33f9a6da0c82d7b0731ca74980dd7515db3d167993008633973a6f SHA512 cf7cceeaedb1fdb503def974d945a7a5d38a95105dda77f7e917abcec8ce823b461bf3cd1ab5f1a458de859e48a4d58abde71a5a4599685772936eb3525ae3af
diff --git a/app-crypt/seahorse/files/3.32.2-libsecret-0.20-compat.patch b/app-crypt/seahorse/files/3.32.2-libsecret-0.20-compat.patch
new file mode 100644
index 000000000000..38c7ca2c15f7
--- /dev/null
+++ b/app-crypt/seahorse/files/3.32.2-libsecret-0.20-compat.patch
@@ -0,0 +1,30 @@
+From d9db29db567012b7c72e85e1be1fbf55fcc9b667 Mon Sep 17 00:00:00 2001
+From: Niels De Graef <nielsdegraef@gmail.com>
+Date: Sat, 11 May 2019 09:02:34 +0200
+Subject: [PATCH] gkr: Use 0 on empty flags
+
+A Flags-type variable without any flag set can be replaced with 0, so
+this is a safe thing to do. It also prevents us from having to deal with
+the accidental API break in libsecret (see
+https://gitlab.gnome.org/GNOME/libsecret/merge_requests/19)
+---
+ gkr/gkr-keyring-add.vala | 3 +--
+ 1 file changed, 1 insertion(+), 2 deletions(-)
+
+diff --git a/gkr/gkr-keyring-add.vala b/gkr/gkr-keyring-add.vala
+index 4e92a520..f60c9a22 100644
+--- a/gkr/gkr-keyring-add.vala
++++ b/gkr/gkr-keyring-add.vala
+@@ -41,8 +41,7 @@ public class Seahorse.Gkr.KeyringAdd : Gtk.Dialog {
+
+ var cancellable = Dialog.begin_request(this);
+ var service = Backend.instance().service;
+- Secret.Collection.create.begin(service, this.name_entry.text, null,
+- Secret.CollectionCreateFlags.COLLECTION_CREATE_NONE,
++ Secret.Collection.create.begin(service, this.name_entry.text, null, 0,
+ cancellable, (obj, res) => {
+ /* Clear the operation without cancelling it since it is complete */
+ Dialog.complete_request(this, false);
+--
+2.20.1
+
diff --git a/app-crypt/seahorse/seahorse-3.32.2.ebuild b/app-crypt/seahorse/seahorse-3.32.2.ebuild
index a23ee02bd5aa..3d701d04f420 100644
--- a/app-crypt/seahorse/seahorse-3.32.2.ebuild
+++ b/app-crypt/seahorse/seahorse-3.32.2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -38,6 +38,10 @@ DEPEND="${RDEPEND}
app-crypt/libsecret[vala]
"
+PATCHES=(
+ "${FILESDIR}"/${PV}-libsecret-0.20-compat.patch # included upstream for 3.34
+)
+
src_prepare() {
xdg_src_prepare
vala_src_prepare