summaryrefslogtreecommitdiff
path: root/app-crypt/seahorse
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-03-20 14:27:17 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-03-20 14:27:17 +0000
commit5bb9ff1ee56d2b5e75e01a7f066d8b0cec84ec02 (patch)
tree66e860a5099bcad013f1cf667255dc372a7c11b3 /app-crypt/seahorse
parent7218e1b46bceac05841e90472501742d905fb3fc (diff)
gentoo resync : 20.03.2021
Diffstat (limited to 'app-crypt/seahorse')
-rw-r--r--app-crypt/seahorse/Manifest2
-rw-r--r--app-crypt/seahorse/seahorse-3.38.1.ebuild76
2 files changed, 78 insertions, 0 deletions
diff --git a/app-crypt/seahorse/Manifest b/app-crypt/seahorse/Manifest
index 6d937474b038..3894614a970b 100644
--- a/app-crypt/seahorse/Manifest
+++ b/app-crypt/seahorse/Manifest
@@ -1,3 +1,5 @@
DIST seahorse-3.36.2.tar.xz 1695824 BLAKE2B e4efb20f952e879b0ff17a9c8664ba61d10c69e377a2fdda52904a8bf5c026d147f9feb9b55c07982f256b366f756dd1567a522d89969c8c5c461f653a130676 SHA512 6a0cb7847fe9917d6d6da31f9b81a4737e425d451fc80604d8e3deb9fa57798f04aa577dae68bc156a15743975f74fbde5ff06a0b05b34228bdc9ef2539b6451
+DIST seahorse-3.38.1.tar.xz 1725480 BLAKE2B 348d9fe1208a9205c58c5655ce97b79c279e2e3506f041a1ebac1f7c83666186ec792bafe7f23b470dd1202a12bc974376b8c369888c6fa194739e7a15973d63 SHA512 1a064ecaf1a25aa84010f914043c3776eba464844598b15e0822217ad330396516df64afed1aeffb3c7b6102d1477c280ec8ec32101cf9f5120c433431b9df32
EBUILD seahorse-3.36.2.ebuild 1617 BLAKE2B 74ce0bde4fcf4c6e4206075d5e16db5365ee57f90f32d86e07be2d881e8e4f4fb4cea3f77137450c03504cb63ae6243f4e5840c14756a2cca0d5ad9b478fa9bc SHA512 4c7e8563f478ae8852a1c9dca359fb4e0a731e1f6a5e508d40a3487f9b92ac38894bcf52db84e1dfe35239b9de8659957e6e303ebe05dc058ef744cd016cc91c
+EBUILD seahorse-3.38.1.ebuild 1619 BLAKE2B e619cfac7a6e96f1b0f66fdd9bc7368bd6ed9c59d7a2aa8ddc981bf33ac8050218c7162930bb95579e385231abe52e6979a78650910b3277da898ee74f6d3109 SHA512 16cd3b53b6d6410c04a97c23a868d27e8bce6c6c7082bcc6e1aa0efdfd0e2b21c361af8040f68f93d616f9b6fbf8a0cb2b1ba78f3305690368d6377310b23da6
MISC metadata.xml 742 BLAKE2B 11cc6cebe3f395ccd9f2570a419e812951287d7a9af2bd88720a66c7349305c108c451b67a33f9a6da0c82d7b0731ca74980dd7515db3d167993008633973a6f SHA512 cf7cceeaedb1fdb503def974d945a7a5d38a95105dda77f7e917abcec8ce823b461bf3cd1ab5f1a458de859e48a4d58abde71a5a4599685772936eb3525ae3af
diff --git a/app-crypt/seahorse/seahorse-3.38.1.ebuild b/app-crypt/seahorse/seahorse-3.38.1.ebuild
new file mode 100644
index 000000000000..031375c4f5c1
--- /dev/null
+++ b/app-crypt/seahorse/seahorse-3.38.1.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit gnome.org gnome2-utils meson xdg vala
+
+DESCRIPTION="Manage your passwords and encryption keys"
+HOMEPAGE="https://wiki.gnome.org/Apps/Seahorse"
+
+LICENSE="GPL-2+ FDL-1.1+"
+SLOT="0"
+IUSE="ldap zeroconf"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+RDEPEND="
+ >=dev-libs/glib-2.58:2
+ >=app-crypt/gcr-3.11.91:=
+ >=app-crypt/gpgme-1.7.0
+ >=x11-libs/gtk+-3.22.0:3
+ >=app-crypt/gnupg-2.0.12
+ gui-libs/libhandy:1=
+ >=app-crypt/libsecret-0.16
+ dev-libs/libpwquality
+ net-misc/openssh
+ ldap? ( net-nds/openldap:= )
+ >=net-libs/libsoup-2.33.92:2.4
+ zeroconf? ( >=net-dns/avahi-0.6:=[dbus] )
+"
+DEPEND="${RDEPEND}
+ $(vala_depend)
+ dev-libs/libxml2:2
+ app-crypt/gcr[vala]
+ app-crypt/libsecret[vala]
+ gui-libs/libhandy:1[vala]
+"
+BDEPEND="
+ app-text/docbook-xml-dtd:4.2
+ app-text/docbook-xsl-stylesheets
+ dev-libs/appstream-glib
+ dev-libs/libxslt
+ dev-util/gdbus-codegen
+ dev-util/glib-utils
+ dev-util/itstool
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ xdg_src_prepare
+ vala_src_prepare
+}
+
+src_configure() {
+ local emesonargs=(
+ -Dhelp=true
+ -Dpgp-support=true
+ -Dcheck-compatible-gpg=false # keep lowest version listed as compatible as min dep for gnupg RDEPEND
+ -Dpkcs11-support=true
+ -Dkeyservers-support=true
+ -Dhkp-support=true
+ $(meson_use ldap ldap-support)
+ $(meson_use zeroconf key-sharing)
+ -Dmanpage=true
+ )
+ meson_src_configure
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}