summaryrefslogtreecommitdiff
path: root/app-crypt/scute
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-crypt/scute
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-crypt/scute')
-rw-r--r--app-crypt/scute/Manifest3
-rw-r--r--app-crypt/scute/metadata.xml29
-rw-r--r--app-crypt/scute/scute-1.5.0.ebuild37
3 files changed, 69 insertions, 0 deletions
diff --git a/app-crypt/scute/Manifest b/app-crypt/scute/Manifest
new file mode 100644
index 000000000000..f6e283bfd492
--- /dev/null
+++ b/app-crypt/scute/Manifest
@@ -0,0 +1,3 @@
+DIST scute-1.5.0.tar.bz2 991598 BLAKE2B 3a5fdcb5c7d1ae50ce5aa508388e768c6f59c366d81d91312a60ff319b3ad7e01b3bfe5986ee880980b0f5371402c21bd8da963977459d3b90fbd607e64ea2ae SHA512 ad1dbdba5681a92696c851eca7e2bfb61f7bf84f5e02728efc1f72cd25c4ee2dc18fe975e2903d1a85c635d16be1e2085ff2305827b48d80e18c9354e555b39a
+EBUILD scute-1.5.0.ebuild 919 BLAKE2B 70a700361e4c1a613ea336ad850997a2eeb16369ab8204a03dbc5a1a944df514c3ec1b5ad252db99fd7ae2a7e7c96c2b4b4695d5b95b075340e5c9358f69aa76 SHA512 2a3ada5f2e21995fcd4920b460c578d37421c3916193b4a499c95c51aec5984fd57579300ea5dddac299e6c740501ab26a00aa3969abdf7b4149443100c86940
+MISC metadata.xml 1031 BLAKE2B cbe957a386e02db4f584dd3e844b0e86da8b17b3c09e000821925be37196a5aac46f4d3a7730dfd4062ee91018be2428f1270202183b60225a9da8614d006317 SHA512 60ff0db241cca0cd3442e635b3579fdcb574d1121b47806a0046f77e6c4b5a32146c44779e52939570110ed7a0745b8606e7ea6b8e5b923d850d8d08a22dd1af
diff --git a/app-crypt/scute/metadata.xml b/app-crypt/scute/metadata.xml
new file mode 100644
index 000000000000..ef8bdd1eaecc
--- /dev/null
+++ b/app-crypt/scute/metadata.xml
@@ -0,0 +1,29 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>lucas.yamanishi@gmail.com</email>
+ <name>Lucas Yamanishi</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>crypto@gentoo.org</email>
+ <name>Crypto</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <longdescription>
+ Scute is a PKCS #11 module that adds support for the OpenPGP
+ smartcard card to the Mozilla Network Security Services (NSS).
+ </longdescription>
+ <upstream>
+ <maintainer>
+ <email>mb@g10code.de</email>
+ <name>Marcus Brinkmann</name>
+ </maintainer>
+ <changelog>http://git.gnupg.org/cgi-bin/gitweb.cgi?p=scute.git;a=blob_plain;f=ChangeLog;hb=HEAD</changelog>
+ <doc lang="en">http://www.scute.org/documentation.xhtml</doc>
+ <bugs-to>https://bugs.g10code.com/gnupg/</bugs-to>
+ </upstream>
+</pkgmetadata>
diff --git a/app-crypt/scute/scute-1.5.0.ebuild b/app-crypt/scute/scute-1.5.0.ebuild
new file mode 100644
index 000000000000..85adede2192a
--- /dev/null
+++ b/app-crypt/scute/scute-1.5.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit ltprune
+
+DESCRIPTION="A PKCS #11 module for OpenPGP smartcards"
+HOMEPAGE="http://www.scute.org/"
+SRC_URI="mirror://gnupg/scute/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+# configure script try to check the version of gpgsm and gpg-agent when
+# non-crosscompiling so we need to have them as build-time dependency as
+# well as runtime. Require a version of gnupg that is patched to have
+# gpgsm-gencert.sh working (as that's what the documentation describe).
+DEPEND="
+ >=dev-libs/libgpg-error-1.4
+ >=dev-libs/libassuan-2.0.0
+ >=app-crypt/pinentry-0.7.0
+ >=app-crypt/gnupg-2.0.17-r1[smartcard]"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ econf \
+ --libdir=/usr/$(get_libdir)/pkcs11 \
+ --with-gpgsm=/usr/bin/gpgsm
+}
+
+src_install() {
+ default
+ prune_libtool_files --modules
+}