summaryrefslogtreecommitdiff
path: root/app-crypt/sbctl/sbctl-0.12.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-02-02 11:45:20 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-02-02 11:45:20 +0000
commit7e3d6dcede5749fe6a1adef4e673a9dde7703b7b (patch)
treed4b1fc995691d4c2cde45fc9d9875e80e85fda73 /app-crypt/sbctl/sbctl-0.12.ebuild
parentcc4bdc5d184af171efd67a1b32de966071ee18d3 (diff)
gentoo auto-resync : 02:02:2024 - 11:45:20
Diffstat (limited to 'app-crypt/sbctl/sbctl-0.12.ebuild')
-rw-r--r--app-crypt/sbctl/sbctl-0.12.ebuild9
1 files changed, 7 insertions, 2 deletions
diff --git a/app-crypt/sbctl/sbctl-0.12.ebuild b/app-crypt/sbctl/sbctl-0.12.ebuild
index 6d78f5f02945..97f67663daf4 100644
--- a/app-crypt/sbctl/sbctl-0.12.ebuild
+++ b/app-crypt/sbctl/sbctl-0.12.ebuild
@@ -1,9 +1,9 @@
-# Copyright 2022-2023 Gentoo Authors
+# Copyright 2022-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-inherit go-module verify-sig
+inherit go-module optfeature verify-sig
DESCRIPTION="Secure Boot key manager"
HOMEPAGE="https://github.com/Foxboron/sbctl"
@@ -31,3 +31,8 @@ src_unpack() {
src_install() {
emake PREFIX="${ED}/usr" install
}
+
+pkg_postinst() {
+ optfeature "automatically signing installed kernels with sbctl keys on each kernel installation" \
+ "sys-kernel/installkernel[systemd]"
+}