summaryrefslogtreecommitdiff
path: root/app-crypt/rhash
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-01-03 13:56:25 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-01-03 13:56:25 +0000
commit94b475013eb88e152032d5f8c684a7d9ce91e319 (patch)
tree09d40138872fbeea80b96af571a1da4de80bcf73 /app-crypt/rhash
parent8d3527b916ca7e0a2c8d9b8d064253a2eda02c1f (diff)
gentoo auto-resync : 03:01:2024 - 13:56:25
Diffstat (limited to 'app-crypt/rhash')
-rw-r--r--app-crypt/rhash/Manifest1
-rw-r--r--app-crypt/rhash/rhash-1.4.4-r1.ebuild96
2 files changed, 97 insertions, 0 deletions
diff --git a/app-crypt/rhash/Manifest b/app-crypt/rhash/Manifest
index f4b95452a683..cd39a77a27a9 100644
--- a/app-crypt/rhash/Manifest
+++ b/app-crypt/rhash/Manifest
@@ -2,5 +2,6 @@ AUX rhash-1.4.4-prefix.patch 836 BLAKE2B 9c3b953e5249c4ee0be5d23cb595ed1c84611ce
DIST rhash-1.4.3-src.tar.gz 429290 BLAKE2B d225aeae0b3a8fb2e093a9aef50cd07a790c7e9734e91114deef2ca8492c85261b8ed5dea45958e35e049ea888885175608962ea72297bdef48b00c52f51eaca SHA512 d87ffcde28d8f25cf775c279fed457e52d24523ed9b695629dae694b3c22372247d18f6032f8ce13a0b70fa2953be408982e46659daaa7c4ab227ae89eaed9c7
DIST rhash-1.4.4-src.tar.gz 435691 BLAKE2B f3d42f333ad9a82fe4a8ef5af5d8008abf526c05c06a00c7033881d5a27ba663c3cc5cefb73ea8157ac24cb10a50a4e500706d489e61a03dbaee74a4735d1722 SHA512 00a7e5e058b53ce20ae79509815452ed9cb699d1322b678220b72c61dea3ea2f8fa131acfade8bb6d9f6af913f0c3c472330841181b22314b8755166310c946f
EBUILD rhash-1.4.3.ebuild 2115 BLAKE2B 1d3d60098013e480dfd8c618a8ee0baf9b6cc30716fe9f30c1d5248e891bb62b4b1efc2f06a3e3a950b24e7b6f2cbb5cb26e840e47313d60e788ffe13b9049b9 SHA512 efd4f474ff34832d72851e838484195741031278426a6227a753d819747b52c9712d22afd8469a7bd3e5ec15696af0b240df4e3c985a6c073e2d0168bd27045a
+EBUILD rhash-1.4.4-r1.ebuild 2311 BLAKE2B 1911c9aca679832c69e4675146621fac02d7b62d93ed652db1176b930ea7fd55b51a08db4e6c14c2b123c2069801eb093296bf93fc6525a0942985a4b6b1a2ba SHA512 cc49cfe5e6c23371cd61091bf2dc1c7d4132874e87a44fb4303bf013f9f9fe59f65967b4f113e376d9ebcd61b517b1430f50c190f0cd6033e46e48695dc0bfab
EBUILD rhash-1.4.4.ebuild 2512 BLAKE2B 704301c0c26ec74501d53bef58113b797a65a4ea9900fd835287b4923bf96c13384ea4ce79e0a7d6495f84ead250515a0914475b646b6c5423b53931d7c1293d SHA512 d72ef5dfbe13c587f5788bb067d4ac39763405c5e3a6f721a060b6883c4479c92ee0fc426da7a264e0e93c426770c378b09847d10df7b9378a154a2efcd160e5
MISC metadata.xml 817 BLAKE2B eeb15cde9e06507f73330759d44dca59dea3bbcb972cb25af71d91f065eb64dbd1ddc61e43f8fad50c264c269542f92efdace36d3397647c3c53972e695da22f SHA512 3e2f688b57c74e051fcfb90d34685346c459c5e9f425266fd3d8e099f586037b14c2bfdac76f135a046c77cc850bb49954c0e7d8dc9ded1db47bf0919ab3ea93
diff --git a/app-crypt/rhash/rhash-1.4.4-r1.ebuild b/app-crypt/rhash/rhash-1.4.4-r1.ebuild
new file mode 100644
index 000000000000..02a4f11e44ac
--- /dev/null
+++ b/app-crypt/rhash/rhash-1.4.4-r1.ebuild
@@ -0,0 +1,96 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit flag-o-matic toolchain-funcs multilib-minimal
+
+DESCRIPTION="Console utility and library for computing and verifying file hash sums"
+HOMEPAGE="https://rhash.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}-src.tar.gz"
+
+LICENSE="0BSD"
+SLOT="0/1"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~arm64-macos ~ppc-macos ~x64-macos ~x64-solaris"
+IUSE="debug nls ssl static-libs"
+
+RDEPEND="
+ ssl? (
+ dev-libs/openssl:0=[${MULTILIB_USEDEP}]
+)"
+
+DEPEND="
+ ${RDEPEND}
+"
+
+BDEPEND="
+ nls? ( sys-devel/gettext )
+"
+
+S="${WORKDIR}/RHash-${PV}"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-prefix.patch
+)
+
+src_prepare() {
+ default
+
+ if [[ ${CHOST} == *-darwin* && ${CHOST##*darwin} -le 9 ]] ; then
+ # we lack posix_memalign
+ sed -i -e '/if _POSIX_VERSION/s/if .*$/if 0/' \
+ librhash/util.h || die
+ fi
+
+ # upstream fix for BSD and others, but was only applied for BSD
+ # we need support for Solaris, where we use a GNU toolchain, so use
+ # the original hack, hopefully next release has this fixed
+ # https://github.com/rhash/RHash/issues/238
+ if [[ ${CHOST} == *-solaris* ]] ; then
+ sed -i -e 's/^elif linux; then/else/' configure || die
+ fi
+
+ multilib_copy_sources
+}
+
+multilib_src_configure() {
+ append-ldflags $(test-flags-CCLD -Wl,--undefined-version)
+
+ set -- \
+ ./configure \
+ --target="${CHOST}" \
+ --cc="$(tc-getCC)" \
+ --ar="$(tc-getAR)" \
+ --extra-cflags="${CFLAGS}" \
+ --extra-ldflags="${LDFLAGS}" \
+ --prefix="${EPREFIX}"/usr \
+ --libdir="${EPREFIX}"/usr/$(get_libdir) \
+ --sysconfdir="${EPREFIX}"/etc \
+ --disable-openssl-runtime \
+ --disable-static \
+ --enable-lib-shared \
+ $(use_enable debug) \
+ $(use_enable nls gettext) \
+ $(use_enable ssl openssl) \
+ $(use_enable static-libs lib-static)
+
+ echo "${@}"
+ "${@}" || die "configure failed"
+}
+
+multilib_src_compile() {
+ emake all \
+ $(multilib_is_native_abi && use nls && echo compile-gmo)
+}
+
+multilib_src_install() {
+ # -j1 needed due to race condition.
+ emake DESTDIR="${D}" -j1 \
+ install{,-lib-headers,-pkg-config} \
+ $(multilib_is_native_abi && use nls && echo install-gmo) \
+ install-lib-so-link
+}
+
+multilib_src_test() {
+ emake test
+}