summaryrefslogtreecommitdiff
path: root/app-crypt/rhash
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-10-21 04:04:33 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-10-21 04:04:33 +0100
commit3dc4de6331223493015f198dc61854af604da86c (patch)
tree626add8c88d96adf9429cdb19226d9de60e6dafd /app-crypt/rhash
parentd895362f98ae63a6ed12cd16d3b3df95d6967f25 (diff)
gentoo auto-resync : 21:10:2024 - 04:04:33
Diffstat (limited to 'app-crypt/rhash')
-rw-r--r--app-crypt/rhash/Manifest2
-rw-r--r--app-crypt/rhash/rhash-1.4.5.ebuild91
2 files changed, 93 insertions, 0 deletions
diff --git a/app-crypt/rhash/Manifest b/app-crypt/rhash/Manifest
index 41e3112af7d7..e6ea20c83e3f 100644
--- a/app-crypt/rhash/Manifest
+++ b/app-crypt/rhash/Manifest
@@ -1,4 +1,6 @@
AUX rhash-1.4.4-prefix.patch 836 BLAKE2B 9c3b953e5249c4ee0be5d23cb595ed1c84611ce6299b29b2b3fd38b7de1f891fb5a8f6a4a5fed3e3b8862fff9f8623f310a0d436ab4eab44e42ff79e0b1f99f5 SHA512 3740a2ea78d28fa916533af27740011c2dd520eb2bc18a6a19fc530a0414a8eb7bd911a7a39ddd0a1a2fec5def20b61ed1731349880346c413d7d6000569bf32
DIST rhash-1.4.4-src.tar.gz 435691 BLAKE2B f3d42f333ad9a82fe4a8ef5af5d8008abf526c05c06a00c7033881d5a27ba663c3cc5cefb73ea8157ac24cb10a50a4e500706d489e61a03dbaee74a4735d1722 SHA512 00a7e5e058b53ce20ae79509815452ed9cb699d1322b678220b72c61dea3ea2f8fa131acfade8bb6d9f6af913f0c3c472330841181b22314b8755166310c946f
+DIST rhash-1.4.5-src.tar.gz 444526 BLAKE2B 11021119e8af28e12491eabd55232e24a056bce79b624c970e4806c28fe707ea1395eb390572dba3453900d4512e5896d70642370d0c9340359e2fee95d62c8d SHA512 49bd6aa2497efc4871ae31eaca51d2dc78ceb7126311557d5280b14fafe9355eaecad37f0f78f865e4e1dd1aeb506d3301989cd2f9fff7b0091c81978e8c2f2e
EBUILD rhash-1.4.4-r1.ebuild 2310 BLAKE2B e5f2d4dd82a1ef6d327457b0ab84360852caa4f640e828a2d2cc0b1a488386c6602ae3e0cd4b188401ef3092e6ffba095f2fada1c5416e08d8227b27ab37dda1 SHA512 3cb22c2991b48dd0df2a64c1d10781950bd32b6847e2e45508df8ebe2bcd8efb643e86dba2290b382c8aa03bb45e773480c1d344210d0aa9af159dedb9d8f768
+EBUILD rhash-1.4.5.ebuild 2271 BLAKE2B 6d7ddeec897958434796bb25c366f023707257e4edea5298181e20a97e17f8536f8400a1693fd97c12790428d0ee0883969114c8243fd88c5564ead6f7e9fd4c SHA512 1d152e030f5cdfd186a5578542782a2b26b2b07d197b6f53ee438fea46f959930f5ad82469af15a27b209d3cc7ae3f3fac3bd4beeec11b07e5afa3bed0e2bf9f
MISC metadata.xml 817 BLAKE2B eeb15cde9e06507f73330759d44dca59dea3bbcb972cb25af71d91f065eb64dbd1ddc61e43f8fad50c264c269542f92efdace36d3397647c3c53972e695da22f SHA512 3e2f688b57c74e051fcfb90d34685346c459c5e9f425266fd3d8e099f586037b14c2bfdac76f135a046c77cc850bb49954c0e7d8dc9ded1db47bf0919ab3ea93
diff --git a/app-crypt/rhash/rhash-1.4.5.ebuild b/app-crypt/rhash/rhash-1.4.5.ebuild
new file mode 100644
index 000000000000..a8d92ff1409b
--- /dev/null
+++ b/app-crypt/rhash/rhash-1.4.5.ebuild
@@ -0,0 +1,91 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit flag-o-matic toolchain-funcs multilib-minimal
+
+DESCRIPTION="Console utility and library for computing and verifying file hash sums"
+HOMEPAGE="https://rhash.sourceforge.net/"
+SRC_URI="https://downloads.sourceforge.net/${PN}/${P}-src.tar.gz"
+S="${WORKDIR}/RHash-${PV}"
+
+LICENSE="0BSD"
+SLOT="0/1"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~arm64-macos ~ppc-macos ~x64-macos ~x64-solaris"
+IUSE="debug nls ssl static-libs"
+
+RDEPEND="
+ ssl? (
+ dev-libs/openssl:0=[${MULTILIB_USEDEP}]
+)"
+
+DEPEND="
+ ${RDEPEND}
+"
+
+BDEPEND="
+ nls? ( sys-devel/gettext )
+"
+
+src_prepare() {
+ default
+
+ if [[ ${CHOST} == *-darwin* && ${CHOST##*darwin} -le 9 ]] ; then
+ # we lack posix_memalign
+ sed -i -e '/if _POSIX_VERSION/s/if .*$/if 0/' \
+ librhash/util.h || die
+ fi
+
+ # upstream fix for BSD and others, but was only applied for BSD
+ # we need support for Solaris, where we use a GNU toolchain, so use
+ # the original hack, hopefully next release has this fixed
+ # https://github.com/rhash/RHash/issues/238
+ if [[ ${CHOST} == *-solaris* ]] ; then
+ sed -i -e 's/^elif linux; then/else/' configure || die
+ fi
+
+ multilib_copy_sources
+}
+
+multilib_src_configure() {
+ append-ldflags $(test-flags-CCLD -Wl,--undefined-version)
+
+ set -- \
+ ./configure \
+ --target="${CHOST}" \
+ --cc="$(tc-getCC)" \
+ --ar="$(tc-getAR)" \
+ --extra-cflags="${CFLAGS}" \
+ --extra-ldflags="${LDFLAGS}" \
+ --prefix="${EPREFIX}"/usr \
+ --libdir="${EPREFIX}"/usr/$(get_libdir) \
+ --sysconfdir="${EPREFIX}"/etc \
+ --disable-openssl-runtime \
+ --disable-static \
+ --enable-lib-shared \
+ $(use_enable debug) \
+ $(use_enable nls gettext) \
+ $(use_enable ssl openssl) \
+ $(use_enable static-libs lib-static)
+
+ echo "${@}"
+ "${@}" || die "configure failed"
+}
+
+multilib_src_compile() {
+ emake all \
+ $(multilib_is_native_abi && use nls && echo compile-gmo)
+}
+
+multilib_src_install() {
+ # -j1 needed due to race condition.
+ emake DESTDIR="${D}" -j1 \
+ install{,-lib-headers,-pkg-config} \
+ $(multilib_is_native_abi && use nls && echo install-gmo) \
+ install-lib-so-link
+}
+
+multilib_src_test() {
+ emake test
+}