summaryrefslogtreecommitdiff
path: root/app-crypt/rhash/rhash-1.4.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-01-14 23:53:26 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-01-14 23:53:26 +0000
commit3bd85407abc9ed4434c2d3741f84fdb512638b1c (patch)
tree15a296c276aca23d87cb4f2181f2249d706ca05f /app-crypt/rhash/rhash-1.4.2.ebuild
parenta90c84e720803f3d26c0ade8f1f1e405ca97502a (diff)
gentoo auto-resync : 14:01:2023 - 23:53:26
Diffstat (limited to 'app-crypt/rhash/rhash-1.4.2.ebuild')
-rw-r--r--app-crypt/rhash/rhash-1.4.2.ebuild11
1 files changed, 9 insertions, 2 deletions
diff --git a/app-crypt/rhash/rhash-1.4.2.ebuild b/app-crypt/rhash/rhash-1.4.2.ebuild
index 28eb73baa382..85a78659e4d4 100644
--- a/app-crypt/rhash/rhash-1.4.2.ebuild
+++ b/app-crypt/rhash/rhash-1.4.2.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit toolchain-funcs multilib-minimal
+inherit flag-o-matic toolchain-funcs multilib-minimal
DESCRIPTION="Console utility and library for computing and verifying file hash sums"
HOMEPAGE="http://rhash.sourceforge.net/"
@@ -46,6 +46,13 @@ src_prepare() {
}
multilib_src_configure() {
+ # ideally we want !tc-ld-is-bfd for best future-proofing, but it needs
+ # https://github.com/gentoo/gentoo/pull/28355
+ # mold needs this too but right now tc-ld-is-mold is also not available
+ if tc-ld-is-lld; then
+ append-ldflags -Wl,--undefined-version
+ fi
+
set -- \
./configure \
--target="${CHOST}" \