summaryrefslogtreecommitdiff
path: root/app-crypt/rainbowcrack
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
commitd934827bf44b7cfcf6711964418148fa60877668 (patch)
tree0625f358789b5e015e49db139cc1dbc9be00428f /app-crypt/rainbowcrack
parent2e34d110f164bf74d55fced27fe0000201b3eec5 (diff)
gentoo resync : 25.11.2020
Diffstat (limited to 'app-crypt/rainbowcrack')
-rw-r--r--app-crypt/rainbowcrack/Manifest2
-rw-r--r--app-crypt/rainbowcrack/rainbowcrack-1.8.ebuild70
2 files changed, 72 insertions, 0 deletions
diff --git a/app-crypt/rainbowcrack/Manifest b/app-crypt/rainbowcrack/Manifest
index e8adcc138c32..c9180c615de2 100644
--- a/app-crypt/rainbowcrack/Manifest
+++ b/app-crypt/rainbowcrack/Manifest
@@ -1,3 +1,5 @@
DIST rainbowcrack-1.7-linux64.zip 208726 BLAKE2B 842e0a3ee74a8576a5331cc86259178b382e82f465f3093e7d1fa1b44907c1c30a73f53c2f7f527e052bc6266ceffd350c42b9b80b1298072a02c0cbd25e660d SHA512 068fe9d31004e08c0fcbe5a11500bd6248eca2f204a8d99a7343824ebc1dd847a01eb459f28d77fdd84eae98b05169a69e10b8893b9b5dd027381965c19b7bdb
+DIST rainbowcrack-1.8-linux64.zip 220109 BLAKE2B 164894ccb07490756a0c9b297b1497d6305fade66b31fd712914261219dd957632cd285ab2e7ad7a683dd3c0a425eb1969676ea23136abf7d688fcde9e445e74 SHA512 84dbf3431605fb5dcc8e7cd305a43e9b239ebd6e5ef120edd951a3180c38498fe3a26157e3b55d114c6630f8ac1382a610d8e6230779c5b12cbc42c04e9aff57
EBUILD rainbowcrack-1.7.ebuild 956 BLAKE2B da85a6de2ef97fc102845d75dd9050bf637377e0595d84f740421af4eb2ea62a78026c7800daf8ae90d8a3afbdc39d1531b42a23e51bf589ba7297cc810fc5c3 SHA512 c376de0e154c1c619e06004a4711c6039ce3b40b88b594d281111875bcf20690452c73bee8c8bf3c246df354e870ea31ce4827b3e70b43c073b38b187c0c36ff
+EBUILD rainbowcrack-1.8.ebuild 1447 BLAKE2B 136fb973a83d3b650ffacf3b6146a3ebb8fac7c7e827b5251dc2c976138a6d2e5412217de34c2febf35956143abb3e19dbdad591cb2ef9e1fd20b913a431656d SHA512 d6d354c4660bc52ad1e3d2a8d3843b58590a61edc81c890485106c8a7d333286b8f99c5da4302f0802859d26111eb320e5e03480186f0dbccecf12a4c91a681c
MISC metadata.xml 987 BLAKE2B 7976cc9d563bcec84a2f9e6ebc2865be112d9d6fbe3cd55cea9a5864adfc0548c77b9637085bc08f29ea70bb684a31925e659be1f48c6f6d160bb630c42ea945 SHA512 1b809cb5ae08e6309dd50d3925eaedfe7a72549dd75a2656d46afee1130bef798e290906fdc4228c4da87f4db61e3e8cd7da8939a63bdcbf1d1dad7b537a824c
diff --git a/app-crypt/rainbowcrack/rainbowcrack-1.8.ebuild b/app-crypt/rainbowcrack/rainbowcrack-1.8.ebuild
new file mode 100644
index 000000000000..7a4aba0ea140
--- /dev/null
+++ b/app-crypt/rainbowcrack/rainbowcrack-1.8.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit wrapper
+
+DESCRIPTION="Hash cracker that precomputes plaintext - ciphertext pairs in advance"
+HOMEPAGE="https://project-rainbowcrack.com/"
+SRC_URI="https://project-${PN}.com/${P}-linux64.zip"
+
+LICENSE="all-rights-reserved"
+SLOT="0"
+KEYWORDS="-* ~amd64"
+IUSE=""
+
+RESTRICT="bindist mirror" #444426
+
+RAINBOW_DESTDIR="opt/${PN}"
+
+QA_FLAGS_IGNORED="${RAINBOW_DESTDIR}/.*"
+QA_PRESTRIPPED="${RAINBOW_DESTDIR}/.*"
+
+DEPEND="app-arch/unzip"
+
+DOCS=(
+ readme.txt
+)
+
+S="${WORKDIR}"/${P}-linux64
+
+# rainbowcrack-1.8 zipfiles, including the ones for Linux, use backslashes as path separators.
+# unzip handles it just fine but produces a warning, the side effect of which is that it exits
+# with code 1 rather than 0.
+# Don't bother with iterating over A, we already assume the file to be a .zip so we might as well
+# assume there is only one.
+src_unpack() {
+ unzip -qo "${DISTDIR}/${A}"
+ local unzip_retval="${?}"
+ case "${unzip_retval}" in
+ 0|1)
+ ;;
+ *)
+ die "Failed to unpack the source archive"
+ ;;
+ esac
+}
+
+src_install() {
+ einstalldocs
+
+ local bin bins="
+ rcrack
+ rt2rtc
+ rtc2rt
+ rtgen
+ rtmerge
+ rtsort
+ "
+
+ exeinto "/${RAINBOW_DESTDIR}"
+ doexe alglib0.so ${bins}
+
+ for bin in ${bins}; do
+ make_wrapper ${bin} ./${bin} "/${RAINBOW_DESTDIR}" "/${RAINBOW_DESTDIR}"
+ done
+
+ insinto "/${RAINBOW_DESTDIR}"
+ doins charset.txt
+}