summaryrefslogtreecommitdiff
path: root/app-crypt/rainbowcrack/rainbowcrack-1.7.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-12-24 14:11:38 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-12-24 14:11:38 +0000
commitde49812990871e1705b64051c35161d5e6400269 (patch)
tree5e1e8fcb0ff4579dbd22a1bfee28a6b97dc8aaeb /app-crypt/rainbowcrack/rainbowcrack-1.7.ebuild
parent536c3711867ec947c1738f2c4b96f22e4863322d (diff)
gentoo resync : 24.12.2018
Diffstat (limited to 'app-crypt/rainbowcrack/rainbowcrack-1.7.ebuild')
-rw-r--r--app-crypt/rainbowcrack/rainbowcrack-1.7.ebuild56
1 files changed, 56 insertions, 0 deletions
diff --git a/app-crypt/rainbowcrack/rainbowcrack-1.7.ebuild b/app-crypt/rainbowcrack/rainbowcrack-1.7.ebuild
new file mode 100644
index 000000000000..48a4108c920f
--- /dev/null
+++ b/app-crypt/rainbowcrack/rainbowcrack-1.7.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit eutils
+
+DESCRIPTION="Hash cracker that precomputes plaintext - ciphertext pairs in advance"
+HOMEPAGE="http://project-rainbowcrack.com/"
+SRC_URI="amd64? ( http://project-${PN}.com/${P}-linux64.zip )"
+
+LICENSE="all-rights-reserved"
+SLOT="0"
+KEYWORDS="-* ~amd64"
+IUSE=""
+
+RESTRICT="bindist mirror" #444426
+
+RAINBOW_DESTDIR="opt/${PN}"
+
+QA_FLAGS_IGNORED="${RAINBOW_DESTDIR}/.*"
+QA_PRESTRIPPED="${RAINBOW_DESTDIR}/.*"
+
+DEPEND="app-arch/unzip"
+
+DOCS=(
+ readme.txt
+)
+
+src_unpack() {
+ default
+ mv ${P}-linux* "${S}"
+}
+
+src_install() {
+ einstalldocs
+
+ local bin bins="
+ rcrack
+ rt2rtc
+ rtc2rt
+ rtgen
+ rtmerge
+ rtsort
+ "
+
+ exeinto "/${RAINBOW_DESTDIR}"
+ doexe alglib0.so ${bins}
+
+ for bin in ${bins}; do
+ make_wrapper ${bin} ./${bin} "/${RAINBOW_DESTDIR}" "/${RAINBOW_DESTDIR}"
+ done
+
+ insinto "/${RAINBOW_DESTDIR}"
+ doins charset.txt
+}