summaryrefslogtreecommitdiff
path: root/app-crypt/qca
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-02-13 21:41:11 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-02-13 21:41:11 +0000
commitc8d60dada2ec8eb48b2d2b290cd6683ccec40e39 (patch)
treec44943ee0563a3fa957716de909fed683117fcb9 /app-crypt/qca
parent69051588e2f955485fe5d45d45e616bc60a2de57 (diff)
gentoo (valentine's day) resync : 14.02.2021
Diffstat (limited to 'app-crypt/qca')
-rw-r--r--app-crypt/qca/Manifest2
-rw-r--r--app-crypt/qca/qca-2.3.2.ebuild84
2 files changed, 86 insertions, 0 deletions
diff --git a/app-crypt/qca/Manifest b/app-crypt/qca/Manifest
index e5b534205ea5..8d65f7b78084 100644
--- a/app-crypt/qca/Manifest
+++ b/app-crypt/qca/Manifest
@@ -1,5 +1,7 @@
AUX qca-2.3.1-gcc11.patch 634 BLAKE2B 1bf5bc7404629800ddf120e902fa53c1a5b40afeb0dbc6565eb4249675beb71da52f9cec379c747ecb78c5e1b35113b874c6d31b2f22e97df7de1887956262a8 SHA512 3fb59a882df92f35b77b86892f913cc709cfb8b2d0f9d0002867517e2c8d3b9d5fa04e9eece44b83a8121329ecf3b9be926e75f51be9e66c1cfed80f9e1a4c83
AUX qca-disable-pgp-test.patch 446 BLAKE2B a98d5951d7b89c65787d7d586a5504949c51271ebe09c5e19b90a2e24f24fb6d03d6c1f76d7ad4234354bc2507cf7031c716b3b2bf8243b8c1d85065079dded4 SHA512 30bb6d31b9392166d6bbae39da2eeb1788ac9cccffb801b074468a3606a6e1a56d6a41ee276d3b8b8d39112bf6aea7025f07f4810bb835102bd00521ee9eb104
DIST qca-2.3.1.tar.xz 725984 BLAKE2B a99121dd95822ef5e1057dc9ad9250bb14486f42b0571936453644bc7c5649f16cbc918fa04d4a5af2c62bc35cc672159a84e27a86e685cfe320518a42076052 SHA512 092704a8d7c5973f05c82584ea55b4f8f874965aea943277e50fde873913a9bdad6a51ea74fc0036bbb632a13141cb4c030504229c06779890286205929f6021
+DIST qca-2.3.2.tar.xz 735500 BLAKE2B 559b27c48c756f2b4f4f206d2157c90ae4856610f1539b4162a2bffe7fffe19b5c768d3d3f9d0486d2098fb403eb64372515815f49fd428d22dfc0405d99e435 SHA512 da6415a097c99b878f45730c1dd1e0bfc7f96858ad7018918ac7c2ae2eca830cb73e131173b1018ee4caa6c3a504b80c8ad28f8f9448c2fd1593161c2ac8aad4
EBUILD qca-2.3.1.ebuild 1889 BLAKE2B a3f974d1dfbaf491f215819ff0c82b1c88a3d8945bd5445982cfc8b72f6a9f71a683162004b638f1372b60c58953d61075bdc2300369eb9bc53e615b78e3dec8 SHA512 d4753b751dab9a281d1d33caefc29415f14380145e9026fb76fa31979874cf80c9ca1925e8233beb6f703753ae96aa328b22e2ad3859127f4e5995ae3cc5914c
+EBUILD qca-2.3.2.ebuild 1846 BLAKE2B fc89a014fbc977c3c98a0ca19617a800b51b6f694f0b7aea34a638e6df0e10633d0d73b8a8d89b1add62f90afd86abbb674ccdd7fad160421bc27149ff87c6e0 SHA512 08baceaf008ded01f8b498e1e1cf44f17c05f7830f44d7255d164bd5c2a02224b0aa113f3c81268664f28bdb8efcf250b4800c71ebc3e3d0751e4f5ecca110f7
MISC metadata.xml 745 BLAKE2B ff8e25b082d3c642fce099df1a218a4936bdc862a96fd237303d040c477544cf6368d23cc5de414d95f021e9c6ec475879225ab201f7c6d6711c04153ac53140 SHA512 6b82494b8dfe0d36da9818a6dcf775252dbb7051430232ccc2519c449cc2877da6478ca98f5b7a982a7660a869a0b8ae7a814fb18108ff42fed9712a9253e867
diff --git a/app-crypt/qca/qca-2.3.2.ebuild b/app-crypt/qca/qca-2.3.2.ebuild
new file mode 100644
index 000000000000..9b020b5ca9f0
--- /dev/null
+++ b/app-crypt/qca/qca-2.3.2.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit kde.org cmake qmake-utils
+
+DESCRIPTION="Qt Cryptographic Architecture (QCA)"
+HOMEPAGE="https://userbase.kde.org/QCA"
+SRC_URI="mirror://kde/stable/${PN}/${PV}/${P}.tar.xz"
+
+LICENSE="LGPL-2.1"
+SLOT="2"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~sparc-solaris"
+IUSE="botan debug doc examples gcrypt gpg logger nss pkcs11 sasl softstore +ssl test"
+
+RESTRICT="!test? ( test )"
+
+BDEPEND="
+ doc? ( app-doc/doxygen )
+"
+RDEPEND="
+ dev-qt/qtcore:5
+ botan? ( dev-libs/botan:= )
+ gcrypt? ( dev-libs/libgcrypt:= )
+ gpg? ( app-crypt/gnupg )
+ nss? ( dev-libs/nss )
+ pkcs11? (
+ >=dev-libs/openssl-1.1
+ dev-libs/pkcs11-helper
+ )
+ sasl? ( dev-libs/cyrus-sasl:2 )
+ ssl? ( >=dev-libs/openssl-1.1:0= )
+"
+DEPEND="${RDEPEND}
+ test? (
+ dev-qt/qtnetwork:5
+ dev-qt/qttest:5
+ )
+"
+
+PATCHES=( "${FILESDIR}/${PN}-disable-pgp-test.patch" )
+
+qca_plugin_use() {
+ echo -DWITH_${2:-$1}_PLUGIN=$(usex "$1")
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DQCA_FEATURE_INSTALL_DIR="${EPREFIX}$(qt5_get_mkspecsdir)/features"
+ -DQCA_PLUGINS_INSTALL_DIR="${EPREFIX}$(qt5_get_plugindir)"
+ $(qca_plugin_use botan)
+ $(qca_plugin_use gcrypt)
+ $(qca_plugin_use gpg gnupg)
+ $(qca_plugin_use logger)
+ $(qca_plugin_use nss)
+ $(qca_plugin_use pkcs11)
+ $(qca_plugin_use sasl cyrus-sasl)
+ $(qca_plugin_use softstore)
+ $(qca_plugin_use ssl ossl)
+ -DBUILD_TESTS=$(usex test)
+ )
+ cmake_src_configure
+}
+
+src_test() {
+ local -x QCA_PLUGIN_PATH="${BUILD_DIR}/lib/qca"
+ cmake_src_test
+}
+
+src_install() {
+ cmake_src_install
+
+ if use doc; then
+ pushd "${BUILD_DIR}" >/dev/null || die
+ doxygen Doxyfile || die
+ dodoc -r apidocs/html
+ popd >/dev/null || die
+ fi
+
+ if use examples; then
+ dodoc -r "${S}"/examples
+ fi
+}