summaryrefslogtreecommitdiff
path: root/app-crypt/pius
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-04-25 11:37:10 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-04-25 11:37:10 +0100
commit38423c67c8a23f6a1bc42038193182e2da3116eb (patch)
tree04e2cf4bd43601b77daa79fe654e409187093c5e /app-crypt/pius
parent623ee73d661e5ed8475cb264511f683407d87365 (diff)
gentoo resync : 25.04.2020
Diffstat (limited to 'app-crypt/pius')
-rw-r--r--app-crypt/pius/Manifest4
-rw-r--r--app-crypt/pius/metadata.xml9
-rw-r--r--app-crypt/pius/pius-3.0.0.ebuild27
3 files changed, 38 insertions, 2 deletions
diff --git a/app-crypt/pius/Manifest b/app-crypt/pius/Manifest
index 4a94704e5e82..f70cb0b534bb 100644
--- a/app-crypt/pius/Manifest
+++ b/app-crypt/pius/Manifest
@@ -1,3 +1,5 @@
DIST pius-2.2.4.tar.bz2 40578 BLAKE2B e7989631813658ff888c72b825269482ff33296abf0b9780ecb24df4628c499087a7591372ef96449b4899b1bcd730b0c75411bcd3c8839c57d3d4b5de374862 SHA512 3a178d30d98d0ed7ddf6819578a54ccfb9719f77c1f6385e3b254e28cd890817f328685c02cc464d4d592961c28ba314ca3175056b412dcdb301b851d874eb60
+DIST pius-3.0.0.tar.bz2 46643 BLAKE2B 18abe6a93bd719adf50fa4bcbf5128845d732b598d611e716a536f78f4930e6e63e7f60d7444775fbc32072935c13b1828377a9e843114255a4101f4e3199f98 SHA512 0c906574ac703f45e3318ae3e7994fe6580fd172849b2956d9084033d6fbfd69fec942b95bc2edadadc223fa0685ff0b9799ad03570b712b9cdb09d69491cc91
EBUILD pius-2.2.4.ebuild 491 BLAKE2B 8be85b57f3f5c6f15d5202cec3171208b1b2c14c8fa70695a340806a714aa689cca203f935f7b54a737db2217ada4e73c61555f5f40de207fb399db0891040e4 SHA512 20a051fd9360c4b4f97bf945ec48a1dfb6096178b73e0ea01472647e9eec27d0a8a09db139196498dec872c67bbf545847853a1f4c0ac7da21f064c9558355b2
-MISC metadata.xml 616 BLAKE2B df1c92cdf11a6fb8987f60694d736086727e4c0dbfe9240011b4850d753b154b15cfbe323bd4ccc250227d8be76a855b1026cc8b172bd14fd124f374f5884e8b SHA512 fe8cde51d90fc53518b9c85c654a7bff3066fa3171d8f3b721b2ad840691d669450d3741806c46b1303e94ce7a9f598ca29cd04eadc2d716b3e0c3c297ec0191
+EBUILD pius-3.0.0.ebuild 655 BLAKE2B 5b122560970340facc2c025cd8fc591d3c3def90aacec82d3eaa392e2af4e0891be3eb17389f00d9368e0e8ac5f9f0f2d1cddf0c3df19c056230dbdb7f9afcac SHA512 b709be3e97e9cf34062199d6d741e6d78b9831f4957f30687acfadd6a0ee1513883a9d943b40ca193051123da797809984c368eb7540ab50196fa231ea323ad7
+MISC metadata.xml 822 BLAKE2B 5dc5796afbb5b5e3f070db3884adc17d0e6e73c568bd747d1ae5585416219305a48d3a7d53bd3f30761262b232e737e1f6633c7ba1dc0834cd95b3fe50b903cc SHA512 49833d454ceb01c9af3010643ba78da1c49152e2502a522fadcc13ce83e9e26f2bf24cc6b06c88cee42f1ee15ab5a18e8d3bf50b3e18b0bde7d1d64fa2211fcc
diff --git a/app-crypt/pius/metadata.xml b/app-crypt/pius/metadata.xml
index fdb742f14987..0be0c7e0c49f 100644
--- a/app-crypt/pius/metadata.xml
+++ b/app-crypt/pius/metadata.xml
@@ -1,7 +1,14 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <!-- maintainer-needed -->
+ <maintainer type="person">
+ <email>nickaristocrates@gmail.com</email>
+ <name>Nicholas Meyer</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
<longdescription lang="en">
The PGP Individual UID Signer (PIUS) is a tool for individually
signing all of the UIDs on a set of keys and encrypt-emailing each
diff --git a/app-crypt/pius/pius-3.0.0.ebuild b/app-crypt/pius/pius-3.0.0.ebuild
new file mode 100644
index 000000000000..f7f3745afd4d
--- /dev/null
+++ b/app-crypt/pius/pius-3.0.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=no
+PYTHON_COMPAT=( python3_{7,8} )
+
+inherit distutils-r1
+
+DESCRIPTION="A tool for signing and email all UIDs on a set of PGP keys"
+HOMEPAGE="https://www.phildev.net/pius/ https://github.com/jaymzh/pius"
+SRC_URI="https://github.com/jaymzh/pius/releases/download/v${PV}/pius-${PV}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+DEPEND=">=app-crypt/gnupg-2.0.0"
+RDEPEND="${DEPEND}
+ dev-lang/perl"
+
+python_test() {
+ ${EPYTHON} -m unittest discover -s test/* -v || die
+}