summaryrefslogtreecommitdiff
path: root/app-crypt/pinentry
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-05-13 16:38:56 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-05-13 16:38:56 +0100
commitea31ad0ed5501d0bf92267c35beaf06ac016bad2 (patch)
tree2fdc433d571e3ead010876d43ce2646b7d783680 /app-crypt/pinentry
parent88ebe56470c37b02a044e1091cad6b2df0f3be8f (diff)
gentoo resync : 13.05.2018
Diffstat (limited to 'app-crypt/pinentry')
-rw-r--r--app-crypt/pinentry/Manifest1
-rw-r--r--app-crypt/pinentry/pinentry-1.1.0-r2.ebuild102
2 files changed, 103 insertions, 0 deletions
diff --git a/app-crypt/pinentry/Manifest b/app-crypt/pinentry/Manifest
index 57ab4b5a02f3..29a4ab32821c 100644
--- a/app-crypt/pinentry/Manifest
+++ b/app-crypt/pinentry/Manifest
@@ -8,4 +8,5 @@ DIST pinentry-1.1.0.tar.bz2 467702 BLAKE2B cf43555848ab0dc60756fca123aba7599ebb1
EBUILD pinentry-1.0.0-r2.ebuild 2886 BLAKE2B 27f6057b0d5d0d474397660d755c90ab8dc025a80d5573e44c71093839efee3c0a126fb5dc10fb53083946c46989cdb63aa1baf6e75f40c2e3aef6bae558bfef SHA512 32cc1cc04357afe5f0b84f1bd75af877e1b849d3a4fc70d194e627a32da883a05037d36d15b25cea67d2963563402c13d125a928278f9326fda8463b5951eb3a
EBUILD pinentry-1.0.0-r3.ebuild 2958 BLAKE2B 350c3f20934857f72ce46dad5d8a047f5b04c10dbf4f398e346a5b1339a81fa1263296859a240fe717970840ed81b2f271a902d3e26b5d93f108bbdf3117cc20 SHA512 10c088dd6cd0efab43430856615cd795986c127765fbb47c0d324085aac9474da85bd317a8ec23aecc05fafba19f14392ccbf59b1820590223be0eb57855a2a6
EBUILD pinentry-1.1.0-r1.ebuild 2809 BLAKE2B b67fe9e2549179f6a035e7b47a2a5041e97e2924c381a66f889d656176c1ee464ab023297801f7f0442390565f5697f2e5fb67a54d7a4c3cfb8f5a4aeae23288 SHA512 e27748277d88402c8c46251ab95f7852fc6ff0499b00823cc1a980ebc222568acf6c31d6ebe92a29b414aba0a6f1796679b43ec279e36bd423183a1a25431411
+EBUILD pinentry-1.1.0-r2.ebuild 2876 BLAKE2B 00a80e0c23694d45c5ac529e086934f1ce28be2c46594171d6de17a2eeb7904df1ab031f4ba4c76d00e61944d229feabf204643ceb5a806b98c56566e262096c SHA512 9eccbd9d41ebf030ad823fa66f25509b6f68b29c5ea85a772453dd81a86c35d0734fbdb4b1d24970a7d0e3851dedd9357bf0c804d3f3987f7f34eab86674f923
MISC metadata.xml 352 BLAKE2B 75bb4d471f7b82b6cfe614d5c2ed226df087792ed84803ce4b011c5ad0a5a1548a87c6ab4c17ffeef53eb64bdea262fda4f89d27c38950ff1ced736b38d7df59 SHA512 3817eb6ad931ab0ee363ed7f8612b08a44c0d02e7abb9d0734452c289350c9909ca4208acad01c54a3f1b260417c400f4692e37b34113c6d618680d41796e2d0
diff --git a/app-crypt/pinentry/pinentry-1.1.0-r2.ebuild b/app-crypt/pinentry/pinentry-1.1.0-r2.ebuild
new file mode 100644
index 000000000000..5b9da6b3a473
--- /dev/null
+++ b/app-crypt/pinentry/pinentry-1.1.0-r2.ebuild
@@ -0,0 +1,102 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools flag-o-matic qmake-utils toolchain-funcs
+
+DESCRIPTION="Simple passphrase entry dialogs which utilize the Assuan protocol"
+HOMEPAGE="https://gnupg.org/aegypten2/index.html"
+SRC_URI="mirror://gnupg/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~x64-cygwin ~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="caps emacs gnome-keyring fltk gtk ncurses qt5 static"
+
+CDEPEND="
+ app-eselect/eselect-pinentry
+ >=dev-libs/libassuan-2.1
+ >=dev-libs/libgcrypt-1.6.3
+ >=dev-libs/libgpg-error-1.17
+ caps? ( sys-libs/libcap )
+ fltk? ( x11-libs/fltk )
+ gnome-keyring? ( app-crypt/libsecret )
+ gtk? ( x11-libs/gtk+:2 )
+ ncurses? ( sys-libs/ncurses:0= )
+ qt5? (
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtwidgets:5
+ )
+ static? ( >=sys-libs/ncurses-5.7-r5:0=[static-libs,-gpm] )
+"
+DEPEND="${CDEPEND}
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+RDEPEND="${CDEPEND}
+ gnome-keyring? ( app-crypt/gcr )
+"
+
+REQUIRED_USE="
+ gtk? ( !static )
+ qt5? ( !static )
+"
+
+DOCS=( AUTHORS ChangeLog NEWS README THANKS TODO )
+
+PATCHES=(
+ "${FILESDIR}/${PN}-1.0.0-make-icon-work-under-Plasma-Wayland.patch"
+ "${FILESDIR}/${PN}-0.8.2-ncurses.patch"
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ use static && append-ldflags -static
+ [[ "$(gcc-major-version)" -ge 5 ]] && append-cxxflags -std=gnu++11
+
+ export QTLIB="$(qt5_get_libdir)"
+
+ econf \
+ --enable-pinentry-tty \
+ $(use_with caps libcap) \
+ $(use_enable emacs pinentry-emacs) \
+ $(use_enable fltk pinentry-fltk) \
+ $(use_enable gnome-keyring libsecret) \
+ $(use_enable gnome-keyring pinentry-gnome3) \
+ $(use_enable gtk pinentry-gtk2) \
+ $(use_enable ncurses pinentry-curses) \
+ $(use_enable ncurses fallback-curses) \
+ $(use_enable qt5 pinentry-qt) \
+ MOC="$(qt5_get_bindir)"/moc
+}
+
+src_install() {
+ default
+ rm -f "${ED}"/usr/bin/pinentry || die
+
+ use qt5 && dosym pinentry-qt /usr/bin/pinentry-qt4
+}
+
+pkg_postinst() {
+ if ! has_version 'app-crypt/pinentry' || has_version '<app-crypt/pinentry-0.7.3'; then
+ elog "We no longer install pinentry-curses and pinentry-qt SUID root by default."
+ elog "Linux kernels >=2.6.9 support memory locking for unprivileged processes."
+ elog "The soft resource limit for memory locking specifies the limit an"
+ elog "unprivileged process may lock into memory. You can also use POSIX"
+ elog "capabilities to allow pinentry to lock memory. To do so activate the caps"
+ elog "USE flag and add the CAP_IPC_LOCK capability to the permitted set of"
+ elog "your users."
+ fi
+
+ eselect pinentry update ifunset
+}
+
+pkg_postrm() {
+ eselect pinentry update ifunset
+}