summaryrefslogtreecommitdiff
path: root/app-crypt/pesign/pesign-0.112.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-09-30 11:19:18 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-09-30 11:19:18 +0100
commit62f67115b5c46134c34f88f4b1cbdacc19384c0a (patch)
tree0a76b14de203a4c23040e5665e39df8de9867745 /app-crypt/pesign/pesign-0.112.ebuild
parent265dbe5dbc14c199299496c6db8fce3f76647015 (diff)
gentoo resync : 30.09.2018
Diffstat (limited to 'app-crypt/pesign/pesign-0.112.ebuild')
-rw-r--r--app-crypt/pesign/pesign-0.112.ebuild12
1 files changed, 9 insertions, 3 deletions
diff --git a/app-crypt/pesign/pesign-0.112.ebuild b/app-crypt/pesign/pesign-0.112.ebuild
index 314dcb7d8cd1..3937fb8fdcd6 100644
--- a/app-crypt/pesign/pesign-0.112.ebuild
+++ b/app-crypt/pesign/pesign-0.112.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -35,7 +35,13 @@ PATCHES=(
)
src_compile() {
- emake CC="$(tc-getCC)"
+ emake AR="$(tc-is-gcc && echo "$(tc-getCC)-ar" || tc-getAR)" \
+ AS="$(tc-getAS)" \
+ CC="$(tc-getCC)" \
+ LD="$(tc-getLD)" \
+ OBJCOPY="$(tc-getOBJCOPY)" \
+ PKG_CONFIG="$(tc-getPKG_CONFIG)" \
+ RANLIB="$(tc-getRANLIB)"
}
src_install() {
@@ -44,5 +50,5 @@ src_install() {
# remove some files that don't make sense for Gentoo installs
rm -rf "${ED%/}/etc/" "${ED%/}/var/" \
- "${ED%/}/usr/share/doc/${PF}/COPYING" || die
+ "${ED%/}/usr/share/doc/${PF}/COPYING" || die
}