summaryrefslogtreecommitdiff
path: root/app-crypt/pdfcrack/pdfcrack-0.19.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-05-14 11:09:11 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-05-14 11:09:11 +0100
commitdeba8115d2c2af26df42966b91ef04ff4dd79cde (patch)
tree9a48f42594e1a9e6b2020d5535a784314434d7a7 /app-crypt/pdfcrack/pdfcrack-0.19.ebuild
parent38423c67c8a23f6a1bc42038193182e2da3116eb (diff)
gentoo resync : 14.05.2020
Diffstat (limited to 'app-crypt/pdfcrack/pdfcrack-0.19.ebuild')
-rw-r--r--app-crypt/pdfcrack/pdfcrack-0.19.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/app-crypt/pdfcrack/pdfcrack-0.19.ebuild b/app-crypt/pdfcrack/pdfcrack-0.19.ebuild
new file mode 100644
index 000000000000..9ccc4f961851
--- /dev/null
+++ b/app-crypt/pdfcrack/pdfcrack-0.19.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="Tool for recovering passwords and content from PDF-files"
+HOMEPAGE="http://pdfcrack.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-0.14-cflags.patch"
+)
+
+src_compile() {
+ emake CC="$(tc-getCC)"
+}
+
+src_install() {
+ dobin pdfcrack
+ dodoc changelog README
+}