summaryrefslogtreecommitdiff
path: root/app-crypt/pdfcrack/pdfcrack-0.18.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-01-25 11:50:47 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-01-25 11:50:47 +0000
commitd42200bec37eef2a7478d88988ff00addd0a9202 (patch)
tree10394660b3cbe4b50173c06950b31302cd25d0d1 /app-crypt/pdfcrack/pdfcrack-0.18.ebuild
parent580f05ea8f512d11e23e8da80177d27835cbdbbc (diff)
gentoo resync : 25.01.2020
Diffstat (limited to 'app-crypt/pdfcrack/pdfcrack-0.18.ebuild')
-rw-r--r--app-crypt/pdfcrack/pdfcrack-0.18.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/app-crypt/pdfcrack/pdfcrack-0.18.ebuild b/app-crypt/pdfcrack/pdfcrack-0.18.ebuild
new file mode 100644
index 000000000000..9ccc4f961851
--- /dev/null
+++ b/app-crypt/pdfcrack/pdfcrack-0.18.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="Tool for recovering passwords and content from PDF-files"
+HOMEPAGE="http://pdfcrack.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-0.14-cflags.patch"
+)
+
+src_compile() {
+ emake CC="$(tc-getCC)"
+}
+
+src_install() {
+ dobin pdfcrack
+ dodoc changelog README
+}