summaryrefslogtreecommitdiff
path: root/app-crypt/pdfcrack/pdfcrack-0.16.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /app-crypt/pdfcrack/pdfcrack-0.16.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'app-crypt/pdfcrack/pdfcrack-0.16.ebuild')
-rw-r--r--app-crypt/pdfcrack/pdfcrack-0.16.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/app-crypt/pdfcrack/pdfcrack-0.16.ebuild b/app-crypt/pdfcrack/pdfcrack-0.16.ebuild
new file mode 100644
index 000000000000..206b6b4510de
--- /dev/null
+++ b/app-crypt/pdfcrack/pdfcrack-0.16.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit toolchain-funcs
+
+DESCRIPTION="Tool for recovering passwords and content from PDF-files"
+HOMEPAGE="http://pdfcrack.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+PATCHES=(
+ "${FILESDIR}/${PN}-0.14-cflags.patch"
+)
+
+src_compile() {
+ emake CC="$(tc-getCC)"
+}
+
+src_install() {
+ dobin pdfcrack
+ dodoc changelog README
+}