summaryrefslogtreecommitdiff
path: root/app-crypt/p11-kit
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-06-30 17:36:28 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-06-30 17:36:28 +0100
commit7014a5a3ea0feffab9701fdd6b64cc7667a985af (patch)
treef2cbbaa8bb9209cd15208721103228336149b799 /app-crypt/p11-kit
parent7a86906b67693cc65671d3e1476835d3a7e13092 (diff)
gentoo resync : 30.06.2019
Diffstat (limited to 'app-crypt/p11-kit')
-rw-r--r--app-crypt/p11-kit/Manifest2
-rw-r--r--app-crypt/p11-kit/p11-kit-0.23.16.1.ebuild60
2 files changed, 62 insertions, 0 deletions
diff --git a/app-crypt/p11-kit/Manifest b/app-crypt/p11-kit/Manifest
index 66284dd927f7..6a7aa00f315a 100644
--- a/app-crypt/p11-kit/Manifest
+++ b/app-crypt/p11-kit/Manifest
@@ -1,3 +1,5 @@
DIST p11-kit-0.23.12.tar.gz 1257028 BLAKE2B 8add003ad298b7c4548c40f863835e9aae4234a66a4b216149be7c473f2b3b7ffb633b95883d58e5b039c974dd8571e56e23f6dcc77e484672605e6178d75ad2 SHA512 ae43b1f6ba5400cf5ae7b64b8c93aa47e5c7ee927196828600fd88beb6fdf6bcb6a63bc822d356757255638f9fbf10896e0604e32a1332a9a833836fa0468726
+DIST p11-kit-0.23.16.1.tar.gz 1292783 BLAKE2B 60be56656156c86d6f0f3285bd691ed85ec1a992e8a789f0f21f9ada172a8cab0581cc42f89c3079a1bd7b3493f0d38cd952711fda50c2e80bf96e94fcd9ff87 SHA512 7d0bbd793b43dba081054b4d022a8dbd1d477a3bd6aced72a641087023cf020f1d898899a08e737880e6c810f924814c62497c5ecb19f8322cde42667426a9a7
EBUILD p11-kit-0.23.12.ebuild 1966 BLAKE2B 1206c4507d07eda081785b681500ff330f63a08b58bae8ec18a62b6cf7e6484f5f9647cc8b5cd5c9f08506b68191880e69f531dfa7105777b570861e28f4a264 SHA512 20436bddb6b3e615515dd263fca36fc0be2485b24cd455331fbc1647af9c39b9efc4158751de6580cc5e77d87df6aec760d4ac8410253d0806cdfc85e2999c27
+EBUILD p11-kit-0.23.16.1.ebuild 1977 BLAKE2B a937d8c5e932bea68cbc92a9293b7d5a68ec624d69d9769d1cc1d886391ac4653b3e94c2fa72d86016537bc9c0b4a09f00ba6fc8bff72f6cbf82ea67397fef92 SHA512 92499d081ea6adb01678301510123a2563222b6082ff7857a2e151ff8142f739894b747d79caa7ced9ea7699061c1ac65adc9953e165e528bc5798a87fa03c37
MISC metadata.xml 454 BLAKE2B 82db424896936d17b167806a47d54674d1d6eebe192ad1f8b4e985b00f74f10aa5f18ea587b866906571a91dcfda83626f6b25ebdbd6a6e02da65b34511b2b0e SHA512 24042c945cc3ab622b74c30eaa08819ebce4af9320b083ceb1f3f4db110fba6539121b4dbf0d245afdc395a9854bec022575861f7ae4e9418018d6bddbd4a888
diff --git a/app-crypt/p11-kit/p11-kit-0.23.16.1.ebuild b/app-crypt/p11-kit/p11-kit-0.23.16.1.ebuild
new file mode 100644
index 000000000000..ec7c6c32971e
--- /dev/null
+++ b/app-crypt/p11-kit/p11-kit-0.23.16.1.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit multilib-minimal
+
+DESCRIPTION="Provides a standard configuration setup for installing PKCS#11"
+HOMEPAGE="https://p11-glue.github.io/p11-glue/p11-kit.html"
+SRC_URI="https://github.com/p11-glue/${PN}/releases/download/${PV}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="+asn1 debug +libffi +trust"
+REQUIRED_USE="trust? ( asn1 )"
+
+RDEPEND="asn1? ( >=dev-libs/libtasn1-3.4:=[${MULTILIB_USEDEP}] )
+ libffi? ( >=virtual/libffi-3.0.0:=[${MULTILIB_USEDEP}] )
+ trust? ( app-misc/ca-certificates )"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+pkg_setup() {
+ # disable unsafe tests, bug#502088
+ export FAKED_MODE=1
+}
+
+src_prepare() {
+ if [[ ${CHOST} == *-solaris2.* && ${CHOST##*-solaris2.} -lt 11 ]] ; then
+ # Solaris 10 and before doesn't know about XPG7 (XOPEN_SOURCE=700)
+ # drop to XPG6 to make feature_tests.h happy
+ sed -i -e '/define _XOPEN_SOURCE/s/700/600/' common/compat.c || die
+ # paths.h isn't available, oddly enough also not used albeit included
+ sed -i -e '/#include <paths.h>/d' trust/test-trust.c || die
+ # we don't have SUN_LEN here
+ sed -i -e 's/SUN_LEN \(([^)]\+)\)/strlen (\1->sun_path)/' \
+ p11-kit/server.c || die
+ fi
+ default
+}
+
+multilib_src_configure() {
+ ECONF_SOURCE="${S}" econf \
+ $(use_enable trust trust-module) \
+ $(use_with trust trust-paths ${EPREFIX}/etc/ssl/certs/ca-certificates.crt) \
+ $(use_enable debug) \
+ $(use_with libffi) \
+ $(use_with asn1 libtasn1)
+
+ if multilib_is_native_abi; then
+ # re-use provided documentation
+ ln -s "${S}"/doc/manual/html doc/manual/html || die
+ fi
+}
+
+multilib_src_install_all() {
+ einstalldocs
+ find "${D}" -name '*.la' -delete || die
+}