summaryrefslogtreecommitdiff
path: root/app-crypt/ophcrack-tables/ophcrack-tables-1.0-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /app-crypt/ophcrack-tables/ophcrack-tables-1.0-r2.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'app-crypt/ophcrack-tables/ophcrack-tables-1.0-r2.ebuild')
-rw-r--r--app-crypt/ophcrack-tables/ophcrack-tables-1.0-r2.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/app-crypt/ophcrack-tables/ophcrack-tables-1.0-r2.ebuild b/app-crypt/ophcrack-tables/ophcrack-tables-1.0-r2.ebuild
new file mode 100644
index 000000000000..619eee011d2d
--- /dev/null
+++ b/app-crypt/ophcrack-tables/ophcrack-tables-1.0-r2.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+
+DESCRIPTION="Tables available for ophcrack"
+HOMEPAGE="http://ophcrack.sourceforge.net/"
+SRC_URI="xpfast? ( mirror://sourceforge/ophcrack/tables_xp_free_fast.zip )
+ xpsmall? ( mirror://sourceforge/ophcrack/tables_xp_free_small.zip )
+ vistafree? ( mirror://sourceforge/ophcrack/tables_vista_free.zip )"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64 ~ppc"
+IUSE="+xpfast xpsmall +vistafree"
+
+REQUIRED_USE="|| ( xpfast xpsmall vistafree )"
+
+DEPEND="app-arch/unzip"
+RDEPEND=""
+
+S=${WORKDIR}
+
+src_unpack() {
+ for i in ${A};
+ do
+ table=${i#tables_}
+ table=${table%.zip}
+ mkdir "${S}/${table}"
+ cd $_ || die
+ unpack "${i}"
+ done
+}
+
+src_install() {
+ dodir /usr/share/ophcrack/
+ cp -r "${S}"/* "${ED}"/usr/share/ophcrack/ || die
+}